Jump to content

Sony Vaio successful install


8 posts in this topic

Recommended Posts

After about 5 days of reading almost every single post in this forum i managed to get all hardware and components working on my vaio. I am telling you all this (especially noobs) because i want to stress the fact that if you search and read you will find what you are looking for....then if all else fails then ask.

the only thing i have left on my vaio is that the wireless kext (airportatheros5424.kext) will not load on start up. I have to load it manually after boot (sudo kextload -t /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros5424.kext) then i can use wireless. (if anyone knows a workaround let me know, its probally really simple and i probally missed it in the forums). I also want to note that i have an Intel 915 video card......tried all that i could find to get past the blue screen on boot (found thread on using external monitor) ..finally found out about the jumper from 6to12 on external vga.. works like a charm...all components functional. sound worked out of the box.

Here are my specs


Processor Celeron M 1.5 GHz

Installed Memory 1GB (DDR2 SDRAM)

Hard Drive 80 GB Ultra ATA, 4200 RPM

Display 15.4 in. WXGA TFT Active Matrix

Processor Type Celeron M


Chipset Intel 910GML

Bus Speed 533 MHz

RAM Technology DDR2 SDRAM

Max Supported RAM 2.048 GB

RAM Speed 533 MHz

Installed Cache Memory 1024 KB

Display Tech WXGA TFT Active Matrix

Display Size 15.4 in.

Display Max. Resolution 1280 x 800

Graphic Processor Intel Graphics Media Accelerator (GMA) 900

Expandability 1 x Type I/II PC Card Slot, 1 x Memory Stick Card Slot, Docking Station/Port Replicator, 1 x Memory Stick PRO, 1 x Memory Stick DUO

Expansion Ports 3 x USB 2.0, 1 x IEEE 1394a (FireWire), VGA out, RJ-11 (modem), RJ-45 (NIC)

Input Method Keyboard • Touchpad

Networking Type Integrated 10/100 Network Card • Integrated Wireless LAN (atheros)

Data Link Protocol EtherTalk • Fast Ethernet

Battery Run Time 2.5 Hour(s).

Battery Technology Lithium ion

Link to comment
Share on other sites

1) You might try the following on the IO80211Family.kext and/or the AirPortAtheros5424.kext: http://forum.insanelymac.com/index.php?s=&...st&p=199474


2) You can put your kextload command in the /etc/rc file. This file runs at startup as root, so you don't need the "sudo" command. Some people say put it at the beginning of the file. I say put it at the end. As an option, the rc script looks for a file called rc.local in the /etc directory. If you create rc.local and put the kextload command into that file, then it loads at the end of rc and if you ever install an update that replaces rc, the rc.local file won't get touched. Be sure to set permissions on rc.local the same as rc.

Link to comment
Share on other sites

Were you able to get the cardbus(PCMCIA) slot and the memory stick slot to work? I have a VAIO VGN-FS980 and got everything to work except these. I replaced the Intel Pro 220 wireless card with a Dell Truemobile 1450 (bought off Ebay for $20)to get my wireless back. I had it dual booting with XP until I got my wireless going and have since took the plunge and converted totally. I would like to get the cardbus to work if possible. Any help would be greatly apppeciated

Link to comment
Share on other sites

i am sorry ....i havent even tried pcmcia or the produo slot yet ......to tell you the truth i really havent found a need for either (i use usb and external sd card reader) ....but you have my curiosity up .....check back here ....i will try ...(will have to find a produo card though)

Link to comment
Share on other sites


  • Create New...