Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Strange - Internet works only after Mac is restarted

6 posts in this topic

Recommended Posts

Hello, first of all I'd like to say that I'm new here, but I'm really happy that I was able to install Mac on my PC, I've always wanted this.
Anyway, I have this problem, everything works absolutely great on my hackintosh, but my internet stops working sometimes. I tried many things to fix this but I couldn't and then I saw that it works flawlessly after I reboot my Mac. But if I shut it down and turn on, my kext won't even get recognized (AppleIntelE1000e.kext).
Anyway are there any ways to fix this problem? I'm tired of restarting my hackintosh just when I turn it on. Maybe there's a way to trick my hackintosh into thinking that my computer was restarted when it really was turned on?
Btw, this never happens when I boot my hackintosh with ##### CD. I'm using Mac OS X Snow Leopard 10.6.8.
Thanks in advance!

Share this post

Link to post
Share on other sites

Run Disk Utility, click your OS X partition and click Repair Permissions, wait until it completes and restart.

Thanks for your help.

I did that but it's all the same - I don't have any internet connection when I turn on my Mac after a shutdown, only after a restart.

Also, I noticed that my Mac "doesn't want to save" any changes that I do, for example - sound enhancement in VoodooHDA, or changing my default program for .mp4 files (VLC instad of QuickTime) - it just resets everything back to it's default settings.


I really appreciate your help guys, thank you.

P.S. Sorry for my bad english - it isn't my first language, I'm from Lithuania

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.