Jump to content

Leopard 10.5.2 on P4


visions_of_eden
 Share

7 posts in this topic

Recommended Posts

Hi ,

 

i'm trying to install Leopard 10.5.2 from Retail disc on P4 1.7 Ghz .

I'm using Voodoo Kernel 9.5.0 with its System.kext .

 

My problem is that install stops at "still waiting for boot device " .

 

To boot the Retail disk i made a boot cd with boot-132 dfe , with initrd.img

 

At first i thought it could be the ATA driver missing so i added ApplePIIXATA.kext to the initrd image , but the boot process still stops at that point .

 

I don't know what to think .

 

I succeeded to install Tiger 10.4.8 jas Build , so the board should support Leo too , but i'm not able to get past that message .

 

Boot flags i used are :

 

rd(0,1)/mach_kernel.voodoo -x -v -f rd=disk1s3 .

 

DVD is connected as secondary slave , so disk and partition number should be correct .

 

May i have to add addiotional extensions to the boot cd ?

 

Thanks in advance .

 

 

Link to comment
Share on other sites

you need the right ata driver.. witch motherboard are you using? intel ich(x)?

try this but I'm not sureArchive.zip

anyway you need to know your ichfamily and inject the dev id.

I suppose you have intel chipset.. otherwise maybe you need an old driver called genericpata.kext. I use it on my old amd system. good luck!

Link to comment
Share on other sites

Hi ,

 

chipset use ICH4 , dev iD : 8086 / 24cb

 

I checked and device id is already included in plist .

 

I will try the kext you posted too .

 

Other kext i'm using are SMBIOSEnabler , DSMOS , and applePS2Controller ApplePSNub ..... could it also be caused by one of those ?

 

 

Link to comment
Share on other sites

Try jumpering and connecting each drive (HDD, DVD) as master, at the end of the cable, one on each channel. Unplug any other drives.

 

Any BIOS settings available for the drive controller? "enhanced", "compatible", stuff like that?

 

After setting up the drives as I suggested, if it still doesn't work, try changing these settings. If they are there at all...I'm not familiar with the ICH4. ICH5 has them.

Link to comment
Share on other sites

Hi ,

 

yes, bios has two ATA modes , "enchanced" and "compatible" . Yesterday i did'n have time to the tests , i will try this evening .

Should i try with some other kernel ?

 

I checked and the ATA drivers i'm using are already those from Dune . IOATAFamily v 1.1 which supports my chipset .

 

Just one question ..... how could i know exactly to what disk my DVD is mapped ?

 

I'll try to explain .... using boot-132 to boot another kernel changes boot device to the ramdisk . How could i know to which disk (diskXsY) my DVD is mapped ?

I have also tried with boot-uuid flag , reporting the UUID of the install disc but this doesn't work either .

Link to comment
Share on other sites

Hi ,

 

i was finally able to get to the installation screen !

Problem was wrong ATA driver , and wrong root disk name .I changed the driver and used boot UUID  and installer started .

 

Unfortunately the disc i'm using is not the retail one ( as i though ) but a bundle specific (Grey Disc ) , so the installer stops complaining that the system cannot be installed on my PC .

This evening i'm goind to try to fool the installer changin SMBIOS parameters using one of the SMBIOS Injectors available .

 

 

Thanks  for your help ! !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...