Jump to content

Any MAC OS X on 790A Chipset Nforce Chipset AMD Processor! Ha I know


16 posts in this topic

Recommended Posts

So I have the M4N98TD evo motherboard, it has a very nice AMD 1090T X6 processor that can run at 3.9Ghz across all of its cores, the Graphics card that I have is a GTX 470 purchased to work well with adobe software which it does even in Windows, the board has a NF200 SLI chip and a MCP72 Chipset.


The board works well with windows, can do everything I want to do in that regard, overclocks well and has DDR3 memory running at 1600mhz 8GB.


Been researching for ages and trying to garner information but I have to say that my limited experience with Macs at college is meaning that I am probably lagging behind in my understandings here.


I know its difficult to get AMD to work, but I have DDR3, SSE3 and the Nvidia Graphics card in my favour here surely?


What's the best way of getting a hackintosh working with this combination?


I have tried a few different things which have had no success, I have researched much about boot flags and I have an ever increasing list of about twenty that I am interchanging.


Trying to install LION, I get as far as the ROOT DEVICE = 0XC000008 trying to mount image, that happens every time, it gets stuck, flies through CPU setup and PCI setup, is showing errors on USBEF, chip not halting within 100ms.


I saw Insanely MAC and thought I may be in the right place, NFORCE and AMD, Insanity looms.


Many thanks in advance, any help appreciated.



Forgot to mention that AHCI is enabled both in BIOS and in Windows and S3 is the only active sleep state which WIndows has no problems dealing with. Also have tried resetting to defaults in BIOS with cool and quiet, secure virtual machine mode and C1E turned off.

Link to comment
Share on other sites

AFAIK your MOBO chipset is the NVIDIA nForce 980a SLI……so try installing OS X using the AppleNForceATA.kext…...


Also, for audio VIA VT1708S Audio CODEC  and for LAN the Broadcom B5071 chipset…..

Link to comment
Share on other sites

Hi, I did wonder about the Nforce ata kext, again showing my complete noob nature on these matters, I am not entirely sure how to use a different kext? I have heard mention of custom installations and also custom DSDT files but again my understanding is a little limited??


Do I understand right in thinking that Mountain Lion will only install over the top of Snow Leopard anyway?? therefore I need to get snow leopard up and running?


I have a trial of mac drive and have formatted a 500GB hard drive with GUID and also formatted it as HFS+, there is an issue in the install text where it says HFS freeblks=0 danger=10610 or something like that, does this mean it is not seeing the hard drive??


Thanks in advance

Link to comment
Share on other sites

@ NOMAD8459


I suggest you look at this topic…...

Link to comment
Share on other sites

Hi, thanks for the information, it seems that you are the writer of some form of guide to this topic! Wow, I am in awe, I am on the verge of giving up, I have tried installing this distro of LION onto USB, DVD and straight toi an HDD, I know I am not doing this properly, the more I read the more confused I get, so may things are for so many different systems and its hard to collate the knowledge to something meaningful that works.


I am sure I am over complicating it all in my head, I am still unsure as to how to add custom kexts, I have copies of transmac and macdrive installed on my PC so I can expand DMG files and can sort of edit them but I dont really have a clue what to do!!


My Nforce being the last ever Nforce chipset, its actually an MP72 chip according to AIDA64 but was badged as 980A with SLI and DDR3 support.


Unlike the earlier models this does have an AHCI setiing in the BIOS and this is switched on. As mentioned the Driver for Nforce in WIndows is not very good so I dont use it, I know its not the same thing.


The distro seems happy but then gets stuck when it tries to mount the boot image, root device - hex code - gets stuck..... I have been thinking the root device means the hard drive, especially cause of the freeblks=0 danger=102610 thing, but I have trie dformatting my HDD to ever different thing going, MBR, GUID, APT, GPT, HFS, HFS+, FAT32, etc, so I guess it isnt the HDD after all.


I am sure I am missing the kexts that are required but as I said I dunno what to do really. I feel a little out of my depth, dont really understand the APPLE systems....


I have the specs as listed, I have a 60GB hdd that I can play with, another 500GB if really required, a 16GB flash drive, a DVDRW drive, a DVDBD drive as well, Windows, BCDEdit, Transmac and Macdrive...... PLEASE HELP ME WITH THIS....sleepless nights later...... its frustrating me a little now, so many people dual booting!!


If I get the retail Snow Leopard, I presume I will still have the issue of getting into it, no?


I have read that the kext APPLEAHCIPORT may be of some use for these later 7 series chipsets? If I copy the retail DMG and then edit it(not sure how to do this??), how can i get it to work and boot from a USB stick, have no dual layer DVDs to reburn the thing anyway!

Link to comment
Share on other sites

Take it step by step.......


1. Format your USB stick as a single volume bootable MBR / FAT32 USB flash drive e.g. using Windows and Rufus


2. Confirm that your BIOS can boot a bootable USB flash drive 


and then go from there...... setting up your BIOS, choosing a kernel patched for AMD, etc.

Link to comment
Share on other sites

Hi, gave up on mountain lion and have successfully installed Snow Leopard 10.6.6, I am slightly amazed but can confirm that it is up and running, it has taken me several re installs trying to get some of the customisation right and also several attempts to get the boot from HDD to work, but I have finally done it.


Used Nforce ethernet driver and I am typing on my mac as i speak so that worked, for the AHCI, I used the apple driver and it seems ok.


In order to successfully boot OS X from HDD, had to use these boot flags:


cpus=1 busratio=19 maxmem=4096 PCIRootUID=1 npci=0x2000 DSDT=0 DropSSDT=Yes. -v -f



However i know that there is now a process of making these boot flags go away some how?? editing DSDT or something??


If anyone could advise what sort of things I need to do to get rid of these boot flags, I would be most grateful, I don't think I dare turn this m(h)ac(k) off now, just in case!!!


Also my GTX470 has not been detected.....:-(  can I just install some sort of driver for this??

Link to comment
Share on other sites

Have you tried GraphicsEnabler=Yes in org.chameleon.Boot.plist.....?


Also the required boot flags can be put into the .Boot.plist file.....


In any case zip up your DSDT and run IORegistryExplorer (Google is your friend) and use "Save a Copy As" to save your IOReg output as a "Username"Mac Pro.ioreg file, then send me a download link for this file and for your extracted DSDT.aml file....


I assume you have checked all your BIOS setting......



OnChipA-ATA Controller [Enabled]

SATA Mode Select [AHCIMode]

Primary Graphics Adapter [PCIE VGA Card First]

Southbridge ACPI HPET Table [Enabled]



Link to comment
Share on other sites

Hi, I have checked BIOS of course, lol.


Now fully updated to 10.6.8, by saving the old mach_kernel and reinserting after update and also saving four or five old kexts and reinstalling them after update using kext utility. USB, ACPIplatform and AHCIport, also saved a copy of the old networking kext just in case. 


Apparently, there is a kext called GF100Hal it can only be installed once getting to 10.6.8, but it hasnt installed with the update so it must be a graphics driver, apparently once the kext is there, it may still not recognise the card.


DSDT editor wont work from the HDD apparently, not sure how to zip the files you request??


Will try the IOreg thing anyway. I don't actually have a boot.plist, I have looked for one and it isn't there! I know ##### will create one, I ran some thing that I cam across and it said my UID was 0, some line script to find UID apparently. Tried to get GFXUTIL to work but failed.....


IOreg, how do you save a file?????


Didn't instal the Nforce LAN driver this time, and before after updating the internet wasnt working, this time it works ok, Nforce lan not installed, using IOnetworkingfamily NVNET

Link to comment
Share on other sites

Re saving IOreg......explained in post above


You can also extract your original DSDT.aml file off the PC using the Ubuntu Live DVD, plug in a FAT32 formatted USB flash drive and then go to the Linux Terminal and type either

cd /media/"Volume name of the USB flash drive" 
sudo cat /sys/firmware/acpi/tables/DSDT > DSDT.aml

for Ubuntu 11.xx and later, or

cd /media/"Volume name of the USB flash drive" 
sudo cat /proc/acpi/dsdt > DSDT.aml

for Ubuntu 10.xx or earlier

In either case, the extracted DSDT.aml file should have been saved on the USB flash drive, for later decompiling, patching and recompiling using iasl or iasl based tools.

Link to comment
Share on other sites

Hi, still cant find a save as option in that ioreg utility am afraid.


Manged to screw up my install by mucking around with graphics stuff, had a pig to get it updated to 10.6.8 again!!


I think I better go for 10.6.7 first then try, 10.6.8, anyways next project if I get that going will be to use snow leopard to try and get LION going cause, the lack of graphics in snow leopard is a little annoying, despite a supposedly supported fermi card, oh well.

Link to comment
Share on other sites

Well, I have successfully installed all update up to 10.6.8.


In order to do this I had to first delete my system and library cache folders, fix permissions and reboot, copy six kexts to my desktop, AHCI, ACPI, IOUSBFamily, IOUSBBlockstorage, IOPCI and IONetworking, also copy my Mach_kernel to the desktop also.


Then install the combo update, then before it reboots, drop the old mach_kernel, now renamed mach_kernel_
x back into the root folder, using sudo command in terminal change the mach_kernnel_x to mach_kernel after renaming mach_kernel to mach_kernel_bad.


Then using Kext utility drag and drop the six kexts into this and then reboot.


I did this both updating to 10.6.7 then updating to 10.6.8, I found without this method, my internet would stop working.


Applying VoodooHDA 2.8.2 kext using kext utility has given me sound.


Installed Cuda drivers from Nvidia, then rebooted.


Installed the driver package from nvidia by first showing its contents and then installing individually.


Then alter AGPM kext so that my "mac mini 2,1" utilises a gpu using device vendor and the code from my system profiler, in my case 06cd for my GTX 470.


Rebooted with the flag GraphicsEnabler and "Graphics Mode"="1920x1080x32@60" and now have full resolution graphics!


Nice..... Now how to get to 10.7.2, that is the question....

Looking in system profiler, it now shows my display as a samsung, and in system preferences I can alter to many resolutions, however, in profiler, my GPU is unknown and my VRAM is showing as zero, now given that I should have 1280mb of VRAM, I need to sort this out somehow? 

Link to comment
Share on other sites

Used Chameleon Wizard to install the latest version of the bootloader, and my Mac Mini 2,1 is now a Mac Pro 3,1 and also my GTX 470 is showing up in system with its proper Gigabyte GTX 470 and VRAM 1280mb tags, didn't expect this to fix those things but hey, I am not complaining.


Went back into AGPM kext and altered the default Graphics Profile for the Mac Pro 3,1 to give my device vendor ID and also a better scheme for the power states taken from another post that someone had made based on their GTX 470. (copy agpm kext to desktop, show package contents, open plist info with text edit, find your device in list (macpro3,1 or amend one of them to say this, then alter the pstates high and low thresholds)


Last bugbear really is that I would like all My RAM to be available but unless I input maxmem=4096, seem to get a panic.


Also used Chameleon Wizard to generate a boot plist with all the boot flags that I need, so now I can just hit enter and boot straight into the MAC OS X hard drive, wow this process seemed hard but once you grasp the concepts then it all becomes apparent.


Kext Utility, Chameleon Wizard and Iatkos are now my favorite bits of software!


Thanks to all the Forums including this one and also thanks to OSX86, a mine of valuable information. Cant see a reason to try to update to mountain lion as yet, unless anyone has one, Logic pro works on this installation and that was my goal.


The full HD graphics make OS X look brilliant, it looks a bit boring in 1280x1024, but my gosh shines in 1080P!!


The boot flags that are now part of my bootlist are: cpus=1 busratio=19 npci-0x2000 maxmem=4096 GraphicsEnabler=Yes and "Graphics Mode"=1920x1080x32@60, this boots and works everytime and is running ok.

Link to comment
Share on other sites

This is how I got it all working in detail...... bear with me.


Use Iatkos S3 V7 burned to a disc using imgburn or whatever.


Make sure that in BIOS, AHCI is enabled, cool and quiet and C1E are turned off and also that the sleep mode state is set to S3 only.


Boot the disc via cd rom boot priority.


If you boot with -v, then you can see what it is up to.


Let it run for about five minutes or so and it will give you a screen with install options.


Select utilities and disk utility at the top of this page.


Find your disk and partition it how you like with the GPT format partition table, and MAC OS X journalled format or HFS+.


Exit the utility, click next and then click customize before you install.


Select the quoopz mach kernel, the latest one for AMD devices, this seems to work best.


Select either RC4 or RC5 bootloader.


Deselect the sound options, I found these didnt work?? (Voodoo HDA 2.8.2 kext installed later did however.)


Dont select any boot flags, i fyou have an AMD graphics card, see if there is any mention of anything useful for you, try to keep your selections minimal and only select one of each type of thing.


Let it install to your HDD - about 20 minutes.


On reboot, I had to use cpus=1 busratio=19 npci=0x2000 maxmem=4096 -v -f as boot flags.


This booted and my network was working so I started the download for 10.6.7 update.


Google how to enable show all files, copy and paste the text into "terminal" on your mac.


Then goto root of your HD, find mach_kernel and save a copy to your desktop, right click and select get info, rename it to mach_kernel_x.


Go into S/L/E and find the kexts relating to IOUSB (2) IOAHCIport IOAPICplatform and the IOnetworking kexts.


Right click on each and save a copy to your desktop.


Then in the main library folder, delete the "caches" folder and in System/Library delete the "caches" folder there too.


Use Disk utility to fix permissions, then reboot.


On restart, install 10.6.7 combo update.


Once finished and before reboot, open terminal again.


Drag the mach_kernel_x from your desktop back to the root of your HDD.


In terminal type: sudo -s


then: mv /mach_kernel /mach_kernel_bad (include the spaces)


then: mv /mach_kernel_x /mach_kernel


these commands will replace the mach kernel with the one you succesfully installed with.


Drag and drop the kexts that you saved into kext utility, let it do its thing, then once it has finished, reboot.


Do similar again, only this time install 10.6.8 update. same kext and mach_kernel and delete cach procedure.


Hopefully after reboot you should still have your network and USB devices etc, if for any reason you dont, its time to google, see if any other kexts are known to work better.


Then I edited my AGPM kext to reflect the system profiler(mac applications) view of what my system was, mac mini or whatever, I found a lsiting within the plist that resembled my own card in that it had four power states and it was a device vendor 10de, or NVIDIA. Changed one of these listings to reflect the system profiler say so of what my system is, ie Macmini2,1, changed the last bit after device vendor to my card code, also found under graphics in system profiler, mine being 06cd. Used kext utility to install the edited kext.


Installed VoodooHDA 2.8.2 kext via kext utility.


Installed the Cuda drivers from Nvidia.




Installed the graphics drivers for mac from Nvidia, right click and show package contents then install individually, all except the preinstall.pkg, using the default install method, I got not supported message, however, this way works.


Used Chameleon wiazrd to update bootloader using download option to install latest chameleon bootloader, and inserted a new plist into the S/L/E folder with the things I needed for boot cpus=1 busratio=19 (whatever yours is in bios) npci=0x2000 maxmem=4096 GraphicsEnabler=Yes "Graphics Mode"="1920x1080x32@60"  including the inverted commas on this one, although in Chameleon plist, you can just select the size you want, save the new plist file and drop into S/L/E.


Job done, fully booting, fully working mac with network, usb and sound support.

Link to comment
Share on other sites

Wanted to do some testing so downloaded cinebench, obviously only one core working as cpus=1, so deleted the command from the plist and rebooted and now have all six cores working....

Link to comment
Share on other sites


  • Create New...