Jump to content

RAID blues

1 post in this topic

Recommended Posts

Hi all folks,


this post is about my main hackintosh:

MB: Supermicro X8DA3

Video: Zotac GeForce 210 1GB


Case LianLi


Everything was good and well with ML 10.8.2 on RAID 1 (vanilla install based on digital_dreamer script). Graphics Enabler Yes.


Unfortunately a Mac AppStore update fired and system did not boot anymore.


After trying a few things to recover non booting RAID 1 I decided it was safer to leave as is (no recent backup) and start with a new couple of disks in RAID1. Once this new system is up I will migrate the install from old RAID to new RAID.


First I tried installing again (with digital_dreamer script) on single disc (Extra folder, Extensions), no boot cache, minimum set of kexts in Extra folder. Everything ok. So I got a working ML10.8.4 on target machine to work on new install on RAID1.

Note: kexts are all in Extra. Chosen kexts are:







Following digital_dreamer notes for RAID1 install, I setup ML, then installed Chameleon, then kexts in Extra/boot combo cache.


I boot and get the [PCI configuration begin]. I can get past this with npci=0x2000.


With npci=0x2000 I get the boot process to do many things:

I see DSMOS loaded, nVidia drivers (vanilla) loaded.


I have tried many settings:

EFI string for video card, PCIRootUID=0, GraphicsEnabler=No, updated to latest Chameleon bootloader (2.1 r2069) to no avail.


I should be close to it, since I can setup with no pain on single disk, it is the RAID setup that is creating problems (that is the cache thing, but his one seems to be mandatory according to the notes in the guide by digital_dreamer).


Any ideas folks?


Link to comment
Share on other sites


  • Create New...