Jump to content

Kernel Cache or Chameleon Problem?


1 post in this topic

Recommended Posts



I recently installed Lion using iATKOS L2.

It all worked fine except I had to get a kext for my Realtek PCI ethernet card.

It's still at 10.7.2


Then, I stupidly thought that if I deleted 'unnecessary' kexts from S/L/E it would speed up the boot time (which was a bit slower than I would have liked, probably should have just enabled UseKernelCache in the boot plist).


So anyway, I backed up then deleted 9 kexts/bundles relating to IntelGMA950 (I don't have onboard-graphics in my system).

I thought you didn't have to 'rebuild kext cache' in Lion, so I just rebooted after deleting them.

After that, rather than shutting down properly the system logged me off then stopped at a blank grey screen with a cursor on it. I had to hold down the power button to turn it off.


When I booted it again it went through the 'time out' screen (with the countdown timer to allow you to press any key and select a partition) and rather than booting it went black then a 'Disk Read Error' screen came up.


Next boot attempt I pressed a key at the 'time out' screen and selected the Lion partition (I didn't enter any boot flags). It started booting (no 'Disk Read Error' screen) but then there was a Kernel Panic (can't remember the exact call back kext thing, but it was AppleIntel....family something, I think)


Next attempt I entered the '-v' flag then booted, it booted perfectly.

After that I used the '-f' flag to boot it, again it booted perfectly.

After that I just pressed a key at the 'time out' screen and selected the Lion partition without any flags, again it booted perfectly.

But if I don't press a key, and I let the timer run out, I still get the 'Disk Read Error'.


So if I get rid of the time out screen altogether and have it go straight to partition selection then it will boot fine every time, but I don't want to do that.

I want to solve the problem.


Is it a problem with Chameleon or with the Kernel Cache, or with the boot selector...thing? All I did was remove some useless kexts from the Extensions folder why would it cause this problem? I put the kexts back and the problem persists, I also set UseKernelCache to 'yes' in the Chameleon boot plist.


Could I try rebuilding the kernel cache?






Link to comment
Share on other sites


  • Create New...