Jump to content

Success ! JaS 10.5.4 osx86 Client/Server


1 post in this topic

Recommended Posts

After 3 unsuccessful consecutive nights, finally i can accomplish the installation by using JaS 10.5.4 osx86 client/server iso.


As you may see my previous posting that I'm able to install but some of the device are not working properly.


This time I got it right. Here's the step-by-step:


Plug the HDD into the purple SATA


BIOS Setting :

Set "Sata Port0-3 Native Mode" = Enabled

Set "OnBoard SATA/IDE Device" = Enabled

Set "OnBoard SATA/IDE Ctrl Mode" = AHCI (if you set IDE it will take ages)


Put the Installer and reboot.


when the boot option shows up, press [F8] and then type -v next to "boot:" and hit [enter]


Language selection screen show up, then I select English


The Installation Screen - Open the Disk Utility make 3 Partitions with GUID

1st. 250GB - HFS+

2nd. 125GB - HFS+

3rd. 125GB - FAT32


Customize option:

- Essential package (default)

- Kernel -> StageXNU

- Chipset Driver -> IntelICHX

- Video -> NVKush

- Audio -> ALC888

- Device Identification -> Generic SATA Drive Icon Fix

- SMIBIOS -> MacPro

- CleanUp (default)


and the installation start. it takes about 15 - 17 minutes. dont bother the estimation time.




I got the

! (in various language)




Sound, Video, WiFi, Bluetooth, Mouse, Keyboard, USB, all working properly.


I go straight into the System Profiler and found only 1 wierd device detection. "SATA Unknown AHCI Standard Controller" but still it can detect my HDD.




Problem that I got is the Ethernet not detected by the system. I tried to look at the .kext file and found that AppleYukon.kext is not there. I was comparing with my other HDD that is already installed Leo Kalyway 10.5.1 upgraded to 10.5.2.


What I did is just copy the IONetworkingFamily.kext to /System/Library/Extensions folder and run this command below from the Terminal


sudo chown -R root:wheel /System/Library/Extensions/IONetworkingFamily.kext [Enter]
sudo rm -rf /System/Library/Extensions.mkext [Enter]


Restart. Then to check I go straight into System Preferences, Networking and there you go ! The Ethernet is there, but still mark with red color. Tried to turn off, apply and then turn on, apply again. This time it going green.




Here's my rig:


Gigabyte 965P-DS3P,

Intel core 2 duo E6550,

LAN Marvel 8056,

Audio Realtek ALC888,

ICH8R Southbridge,

RAM: Patriot 2GB dual channel,

Nvidia GeForce 7600GS,

DVD Asus 1608P2S- PATA

Linksys WMP54GV2 (Broadcom),

HDD SATA Western Digital model: WDC WD5000AACS-00G8BO 500GB

Logitech USB Keyboard, Logitech USB Mouse,

ViewSonic VA2026W 20"


Next post, I will share some screenshot and more on the server installation...

Link to comment
Share on other sites


  • Create New...