Jump to content

The DS3x Retail Guide for Snow People


1 post in this topic

Recommended Posts

If you aren't Snow, go away. This isn't for you :dev:




Ok, first boot up into Kalyway install DVD.

Format your whole drive CLEAN with HFS+/GUID.

Now, go to "Partitions" and create two partitions.

Partition #1 will be where Retail goes, call it "Macintosh"

Partition #2 will be where Kalyway goes, call it "Kalyway"

Apply these changes, and then go on to install Kalyway on the proper partition (use GUID EFI install option).

Why did I tell you to put it on the 2nd partition instead of the first? Because it will be less work for you later on when you want Retail on partition #1. Make sure you don't have any other partitions on this drive, and please, for chrissakes Snow, just disconnect your other drives, you stubborn {censored}. :dev:





Now you're in Kalyway, right? I hope so. I never tried Kalyway 10.5.2 - just 10.5.1, but it should have worked for you. You have one of the most compatible boards on InsanelyMac, right? If Kalyway 10.5.2 doesn't work for you OOTB, then it's time to send a hate letter to Kalyway.


Ok, so first copy your Retail disk image over. You ARE using the Retail image I linked you to at TPB, right SNOW? If not, go download it IMMEDIATELY.


Ok, done downloading the PROPER retail? :dev: Let's move on...


Now that you have the disk image on your desktop, let's install it on your retail partition. I know you remember how to do this, but for the sake of being thorough, I will put the Terminal command down here just so you can't say I didn't include it:


sudo -s
(now you can't say I didn't tell you to do it)
cd /Volumes/Mac\ OS\ X\ Install\ DVD/System/Installation/Packages/
open OSInstall.mpkg


Install with options to your taste, but I'd suggest not installing X11. I don't know if it's okay or not, but I didn't install it to be safe. Once install finishes, take control:


/usr/sbin/vsdbutil -a /Volumes/Macintosh/


Now for the first kext removals/replacements:


cd /Volumes/Macintosh/System/Library/Extensions/
mkdir ../Extensions.retail
mv AppleIntelCPUPowerManagement.kext ../Extensions.retail
mv AppleSMBIOS.kext ../Extensions.retail
mv AppleEFIRuntime.kext ../Extensions.retail


Now, get the dsmos.kext and AppleSMBIOS.kext that I gave you (mac.nub default #27) and put them both in a folder on your desktop called "kexts". Just those two files, nothing else, okay?


cd ~/Desktop/kexts/
chown -R 0:0 *
chmod -R 755*
mv * /Volumes/Macintosh/System/Library/Extensions/


We're also going to make life easier right now by editing your boot.plist so you can select partitions and see verbose mode:


nano /Volumes/Macintosh/Library/Preferences/SystemConfiguration/com.apple.Boot.plist


You know what to do here, right? Well just in case...

<key>Kernel Flags</key>


control+o to save, hit enter

control+x to exit


Ok now reboot into Retail.






Ok bro, I am going to say this really fast: Don't fukk around here and start customizing and all that bullshiit just yet. That stuff waits until the system works ok? Don't even change the fukking desktop wallpaper, alright? You hate me already, so I don't care if you hate me more after saying that :dev:


Once you're done setting up the user account and all that fun stuff, download the 10.5.2 update from Apple website. DON'T RUN IT YET. Go into Terminal:


sudo -s
while sleep 1; do rm -rf /System/Library/Extensions/AppleIntelCPUPowerManagement.kext; done


Now, install the update, but don't restart when it finishes. Back in Terminal:


nano /System/InstallAtStartup/scripts/1


replace: "dont steal mac os x.kext"

with: "dsmos.kext"

control+o to save, hit enter

control+x to exit


Ok, now you can reboot, but it may not boot up the first time. This was the case for me, it WILL boot up the second time, and some people have said that if it doesn't, just boot into safe mode with -x.


Once you're back into Retail, do all the updates. I might suggest doing ONE AT A TIME and reboot after each one. That way, if something screws up for some reason, you will know which one did it. I have to say though, that I didn't have a problem with any of them. So if you get a panic, well, you did something wrong, probably. Start over. If it doesn't work again, start over, and over, and over, until you learn your lesson! :P


Ok, updates done? No kernel panics? Good! Let's put the proper kexts in now. You still have that zip file I sent you on MSN right? Ok, unzip it to your desktop and call the folder "kexts" to make things easy.


In Terminal:


sudo -s
(you feeling the repetition yet?)
cd /System/Library/Extensions/
mv AppleAHCIPort.kext ../Extensions.retail
mv IOAHCIFamily.kext ../Extensions.retail
mv IOATAFamily.kext ../Extensions.retail
mv IONetworkingFamily.kext ../Extensions.retail
mv AppleACPIPlatform.kext ../Extensions.retail
cd ~/Desktop/kexts
chown -R 0:0 *
chmod -R 755 *
mv * /System/Library/Extensions/
rm -rf /System/Library/Extensions.mkext
rm -rf /System/Library/Extensions/Caches/
rm -rf /System/Library/Caches/
diskutil repairPermissions /


Your system will reboot now. Use -f at darwin prompt to reload kext info (must do this!).


All good now, right bro? You didn't fukk around or do anything I didn't tell you to do, right? Right? :P


If it doesn't work after these steps, then take a long vacation to Jamaica and come back next year.



Link to comment
Share on other sites


  • Create New...