Jump to content

Apple Superdrive USB not recognized


7 posts in this topic

Recommended Posts



My Apple Superdrive USB is not recognized by my configuration.

I Run OSX Mountain Lion with latest updates.

When connected I hear a soft click but can not enter a CD.

It is not taken by the drive.

I tested it on a mac mini and there it works fine so no hardware problem.

Is there a special kext I need to let it work?

MB is gigabit GA-Z77N. Tried several USB ports but no result.


I didn't test it before because I didn't need a DVD.

I just found out some days ago.


Any ideas or tips are very welcome.


Thanks in advance


Best regards



Link to comment
Share on other sites

I have a couple suspicions...first, can you use other USB devices with your build right now? Is the SuperDrive the only device not recognized or are there others as well?


The other thing is that if you look at the SuperDrive compatibility page it says you can only use the SuperDrive with a Retina MacBook Pro, MacBook Air, Mac Mini (late '09+), or iMac (latest model). That being said, there might be some sort of protection that prevents the drive from being used with other computers, either software or firmware. If it is software, you can simply obtain an iMac smbios.plist (make sure it's iMac13,1) or a Mac Mini smbios.plist (either Macmini4,1 Macmini5,1 or Macmini6,1) and see if the drive works. Finding and using an smbios.plist shouldn't be too difficult, but if you need help just let us know. ;)


If the SMBIOS trick doesn't work...well we can probably assume there's some type of firmware protection on the drive, making it impossible for your hack to use...


Update: Just did a little research...apparently you don't have to use an SMBIOS, you just have to change a couple .plist files and it'll work. When I have more time I'll give you details.

Link to comment
Share on other sites

I know the SuperDrive for the Air originally needed a boot flag to work on other Macs. Not sure if it'll help in this case, but you could try adding mbasd=1 to your chameleon boot plist.


Another possibility is the USB ports aren't providing enough power to drive it. Can you charge anything that requires high power like a iPhone 5 or retina iPad off the same USB ports? If you look at the USB section of System Profiler does it list the SuperDrive and if so is there an "Extra Current" section below it?

Link to comment
Share on other sites

you could try adding mbasd=1 to your chameleon boot plist.

That's what I was talking about. :P Just found that out today

Link to comment
Share on other sites

Very sorry for my late reply. I was abroad for the last days and had no time to read my started topic.

I will check all your suggestions ASAP and let you know how things worked out.

BG Hans


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...