Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
BenA

OS X Snow Leopard on ThinkPad X60

8 posts in this topic

Recommended Posts

Hey everybody, first post here!

 

Need a little help, and hope to return the favor as I get better versed on this subject...

 

I've installed OS X on my IBM / Lenovo X60 using iATK OS S 3 (10.6.3) and the good news is I can boot up in safe mode (-x) to a totally functional system. When I attempt a normal boot, it gives me a message that I must turn off my computer. The graphical picture of a power button with that message in several languages.

 

Used iATKOS for convenience, I have a copy of Snow Leopard on the bookshelf above my desk :)

 

Specs on the X60: http://support.lenov...ID=PD010033#arc (Mine has the T2400, 2 GB of RAM)

 

To get this far I've tried several things, on the latest attempt I've disabled speed step and used minimal customization options during the install.

 

Booting up with (-v), the last lines I see are:

 

http://hostthenpost....00779dbdce3.jpg

 

Any advice is greatly appreciated! Can't wait till I've got a slick little macbook that's tough as nails.

Share this post


Link to post
Share on other sites

It's a kernel panic with the VoodooHDA kext. The reason you can boot in safe mode is because VoodooHDA doesn't get loaded. Delete the kext and boot with -f

Share this post


Link to post
Share on other sites

What's the best way to go about removing it? I noticed that I can't see the Extensions directory in finder... and I tried kextunload via the terminal, but it asks for a sudo password. I don't have a password, and it won't accept it blank.

 

EDIT: Now the system refuses to boot, yet again... Going to do a fresh install on a different HDD without the VooDoo, and I guess I'll give up if that doesn't work. The HD I'm using is out of a machine that was dropped, but it's shown no errors. The system is painfully slow though.

Share this post


Link to post
Share on other sites

That seems to have fixed one thing (removing the VoodooHDA)... but now when I boot up not in safe mode I see the apple boot screen, with the loading animation frozen. I do have a cursor at some point though, of the colored spinning pin wheel in the top left corner of the screen.

 

EDIT: Just tried GraphicsEnabler=No and now I'm at the boot screen with a cursor. Can't do anything though.

Share this post


Link to post
Share on other sites

Any advice? Not sure what I can do to provide more information... If I boot in safemode it just boots up, and if I boot regularly I am stuck with the boot screen & moving cursor / colored spinning wheel...

Share this post


Link to post
Share on other sites

2nd option for Intel GMA 950. I've also installed with the 1st, and both (1&2). It seems like every time it does the same thing. Is there an easy way to remove my current kext and replace it while booted in safe mode?

Share this post


Link to post
Share on other sites

I would try delete all graphics kext and see what happens. Back them up first and replace the kext you need.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Few more minutes to go before going live again with https://OSXLatitude.com
          So you can lock this topic again @Allan Hopefully for a bit longer than a couple of weeks this time hehe.
    • ok, I am having a weird glitch with my Primary bios after modding it myself. can I get some help getting a Clean osmosis modded (for High Sierra and beyond) Bios Image?   https://www.gigabyte.com/us/Motherboard/GA-Z87X-UD5-TH-rev-1x#support-dl   the version I have always stuck with was F4, because the F5d.  I use a custom iMac 14,2 configuration that has been stable, the issues I have with stability come from not being able to get Access to the Bios, and prior to my attempt to mod it has been stable with up to High Sierra using clover, and up to Sierra with my very very old Ozmosis 894m F4 rom. I am not opposed to installing Ozmosis on the EFI Partition, But Gigabyte locked the Bios loading .efi Files, there is no shell to Force it to load HFS+ or APFS drivers.   so what I am asking for is assistance ether unlocking a Shell for my Bios, or getting a bios with the APFS, HFS+, and Ozmosis related files in it.   thanks again for everyones assistance. HBP
    •     Install from fresh again. This time without Tony Tools, follow some guide in this topic. Install IntelHD kexts as usual in S/L/E and thats it. Everything works again, except for backlight, I never could have this work, also got heating problem and when boots apple logo dissapears from like 5 seconds and then appear the login window... Any ideas on any of this????  
    • MAld0n, I can't post a new topic on post installation forum. is it on maintenance?
      Notebook Asus X550VX i7 - 7700hq
      GTX950MX - UHD630
      A1718086 - 025510ec ALC255 that works only on VoodooHDA 
      RTL8111 LAN Hwinfo
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL   Not work:
      1. White Screen Wake up
      EDID not a asolution
      IOREG output http://www.mediafire.com/file/u7odzbaxa7bbb6a/ioregSaved.txt and EDID
      http://www.mediafire.com/file/hqlapgf4luwchdf/DisplayProductID-69c.plist Image
      https://ibb.co/faL5wx 2. Battery info status bar sometimes goes on / off like battery has off
      3. Crackle Sound using   earphone using VoodooHDA
             Still investigation using patched iomatch voodooha info.plist
             The sound card can’t be using AppleALC, no sound came out using layout 3, 13, 17, 18, 27, 28, 99
      I have your (Mald0n) DSDT   http://www.mediafire.com/file/lmp5yy65rblx9ne/DSDTtitomaldon2.dsl   I have re-patched again for FnKeys and Brighness Key http://www.mediafire.com/file/5rs93ij0wco99s6/DSDTtitomaldon2editv2.aml

       
      codec dump linux
      https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view
       
       
      latest debug
      http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip
       
      clover and kext
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL
       
    • somehow I can't post a topic using safari and Firefox on Mac. no box for inserting text, is this kind of maintenance?  


×