Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Aska

Bios don't detect HDD

5 posts in this topic

Recommended Posts

I don't know if this is the right forum, in that case sorry :P

 

First off, i set my HDD as following:

 

1° partition: 100mb windows partition

2° 50gb windows

3° 50gb MacOSX

4° 50gb MacOSX clone

5° 300gb NTFS for stuff

 

My bootable partition was the 3°, and by chamaleon I was able to boot both windows or macosx.

 

I uninstalled windows 8 and reinstalled windows 7, obviously it changed /boot flag to 1°.

I used to use gparted to switch the flag back to 3°, but this time I tried with the diskpart and set 3° as active (aka /boot).

 

Now the HDD isn't bootable anymore, BIOS doesn't detect it. I plugged the HDD in another Windows PC by USB. It doesn't work: i can't see no disk nowhere! Nor in Disk Manager.

 

I tried to use gparted and plug the HDD AFTER gparted was running. I was able to see the disk and each partition as they used to be (that makes me think that there's any "physical" issue).

 

I would like not to format the disk (however even though I would do it, i can't because it's not detected anywhere).

 

What can I do? Can someone help me please?

 

Thank you in advance.

Share this post


Link to post
Share on other sites

Nop, it's a Maxtor.

 

After many hours, I finally end up to switch to IDE mode from AHCI in the BIOS setup. Now I am able to boot Windows 7 again... half work is done.

 

Since Mac OSX run only in AHCI mode, I enabled AHCI driver in the windows registry (I read some tutorial here and there on internet).

 

Then I restarted the PC, changed back to AHCI in the BIOS, rebooted again and... nothing, auto-detection of SATA 1 is still in "guru meditation".

 

That sounds wierd to me because I already had that setup before Windows 8 install (dual-boot Win7+Macosx x2, in AHCI mode).

And plus, since the first bootloader is chamaleon and it starts from an HFS+ partition, why BIOS doesn't detect the disk and allows to boot the Mac straightly, bypassing Windows?

 

IDE mode: disk detected.

AHCI mode: disk undetected.

 

Maybe I'm doing something wrong or I miss something...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×