Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Funky frank

Core i7 q720 1,6 / 2,8 ghz - how to configure correctly in Chameleon?

2 posts in this topic

Recommended Posts



I use a Sony Vaio F11 (core i7 4core max 2,8ghz, Geforce GT330M1GB) running Snow Leopard 10.6.8 for some years now. I also have a workstation with a Core2Quad 2,6 + ATI 5750 1GB running Snow Leopard ,too.


In the last days I worked with Final Cut X. The strange thing is now that the Core2Quad system absolutely running Final Cut smoothy and fast, but the Core i7 system stutters and runs slow.


So I asking myself if I maybe wrongly did setup the core i7 in Chameleon? The system profiler only shows a quad core with 1,6ghz. But the core i7 can go up to 2,8 ghz. So maybe there is no upclocking at all?


I did enable GeneratePStates and GenerateCStates in the boot.plist of Chameleon.Should I disable it? The fan of the cpu seems to running at full speed always, if I boot into OSX (not so in Windows). If I disable PStates, would the processor always run at 2,8 ghz?


Is there any special C-State I should define for using a Core i7? Or any hint I forgot?


Thanks for help and regards.

Share this post

Link to post
Share on other sites

Ok, I patched AppleIntelCPUPowermanagement.kext using the "speedstepper" tool and added a "-allowAppleCPUPM" to the Kernel Flags in Chameleon's boot.plist.


Speed step seems to be enabled, but also the OSX gui is now very very slow, because it seems that it quite too much underclocked now.


Is there a way only to enable Corei7's turbo mode without power saving modes??


I need full power.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.