Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Alex Auditore

How to launch ATI-card by DSDT

98 posts in this topic

Recommended Posts

Hello! Today I want to narrate how to inject ATI-card by DSDT.
First of all, we need in Windows and AIDA64 to receive video-bios.
1) We should take it with the help of AIDA64. And make it as it is shown at the screenshot.(Just to click right key of mouse at the left lower corner of AIDA64)
post-974387-0-99741300-1366300453_thumb.png
2) After that we should rename our file called vgabios.dmp to vgabios.bin
3)The next step will be to convert our video-bios with the help of the program named rom_dsdt_converter.exe.
4)Now go to the DSDT and to correct this deal for it. I try to explain it on my example.
I prescribe it at the Device (DP)

Device (DP)
{
Name (_ADR, 0x0220)
Method (_DCS, 0, NotSerialized)
{
If (DP0A)
{
Return (0x1F)
}
Else
{
Return (0x1D)
}
}
Method (_DGS, 0, NotSerialized)
{
If (DP0A)
{
Return (One)
}
Else
{
Return (Zero)
}
}
Method (_DSS, 1, NotSerialized)
{
Store ("DP -- _DSS", Debug)
}
}
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x6A)
{
"@0,HasPanel",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
},
"@0,Haslid",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
},
"@0,display-link-component-bits",
Buffer (0x04)
{
0x06, 0x00, 0x00, 0x00
},
"@0,display-pixel-component-bits",
Buffer (0x04)
{
0x06, 0x00, 0x00, 0x00
},
"@0,display-dither-support",
Buffer (0x04)
{
0x00, 0x00, 0x00, 0x00
},
"@0,backlight-control",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
},
"@0,VRAM,memsize",
Buffer (0x08)
{
/* 0000 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x40
},
"@0,compatible",
Buffer (0x0D)
{
"ATY,Alouatta"
},
"@0,name",
Buffer (0x0D)
{
"ATY,Alouatta"
},
"@0,built-in",
Buffer (One)
{
0x01
},
"@0,AAPL,boot-display",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
},
"@1,VRAM,memsize",
Buffer (0x08)
{
/* 0000 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x40
},
"@1,compatible",
Buffer (0x0D)
{
"ATY,Alouatta"
},
"@1,name",
Buffer (0x0D)
{
"ATY,Alouatta"
},
"@2,VRAM,memsize",
Buffer (0x08)
{
/* 0000 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x40
},
"@2,compatible",
Buffer (0x0D)
{
"ATY,Alouatta"
},
"@2,name",
Buffer (0x0D)
{
"ATY,Alouatta"
},
"@3,VRAM,memsize",
Buffer (0x08)
{
/* 0000 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x40
},
"@3,compatible",
Buffer (0x0D)
{
"ATY,Alouatta"
},
"@3,name",
Buffer (0x0D)
{
"ATY,Alouatta"
},
"AAPL,overwrite_binimage",
Buffer (One)
{
0x01
},
"AAPL,aux-power-connected",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
},
"AAPL,backlight-control",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
},
"AAPL00,InverterFrequency",
Buffer (0x04)
{
0x08, 0x52, 0x00, 0x00
},
"AAPL00,Dither",
Buffer (0x04)
{
0x00, 0x00, 0x00, 0x00
},
"AAPL00,DualLink",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
},
"AAPL00,blackscreen-preferences",
Buffer (0x04)
{
0x00, 0x00, 0x00, 0x00
},
"AAPL01,Coherency",
Buffer (0x04)
{
0x02, 0x00, 0x00, 0x00
},
"AAPL01,blackscreen-preferences",
Buffer (0x04)
{
0x00, 0x00, 0x00, 0x00
},
"AAPL,slot-name",
Buffer (0x07)
{
"Slot-1"
},
"ATY,Card#",
Buffer (0x0E)
{
"109-B77101-00"
},
"ATY,Copyright",
Buffer (0x32)
{
"Copyright AMD Inc. All Rights Reserved. 2005-2009"
},
"ATY,EFICompileDate",
Buffer (0x0C)
{
"Jan 26 2009"
},
"ATY,EFIDispConfig",
Buffer (0x08)
{
/* 0000 */ 0x0D, 0x10, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00
},
"ATY,EFIDriverType",
Buffer (One)
{
0x02
},
"ATY,EFIEnabledMode",
Buffer (One)
{
0x01
},
"ATY,EFIHWInitStatus",
Buffer (0x08)
{
/* 0000 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00
},
"ATY,EFIOrientation",
Buffer (0x02)
{
0x08
},
"ATY,EFIVersion",
Buffer (0x0A)
{
"01.00.318"
},
"ATY,EFIVersionB",
Buffer (0x14)
{
"113-SBSJ1G04-00R-02"
},
"ATY,EFIVersionE",
Buffer (0x0F)
{
"113-B7710A-318"
},
"ATY,MCLK",
Buffer (0x04)
{
0x01, 0x38, 0x73, 0x00
},
"ATY,MemRevisionID",
Buffer (0x02)
{
0x03, 0x00
},
"ATY,MemVendorID",
Buffer (0x02)
{
0x02, 0x00
},
"ATY,PlatformInfo",
Buffer (0x80)
{
/* 0000 */ 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0008 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0010 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0018 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0020 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0028 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0030 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0038 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0040 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0048 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0050 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0058 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0060 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0068 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0070 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0078 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00
},
"ATY,Rom#",
Buffer (0x0F)
{
"113-B7710C-176"
},
"ATY,SCLK",
Buffer (0x04)
{
0xF4, 0x1F, 0x00, 0x00
},
"ATY,VendorID",
Buffer (0x02)
{
0x02, 0x10
},
"device_type",
Buffer (0x13)
{
"ATY,AlouattaParent"
},
"model",
Buffer (0x1C)
{
"ATI Mobility Radeon HD 5850"
},
"name",
Buffer (0x13)
{
"ATY,AlouattaParent"
},
"hda-gfx",
Buffer (0x0A)
{
"onboard-1"
},
"ATY,bin_image",
Buffer (0xEE00)
{
......................................


}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}
I think many of this parameters are understandable for many people. Therefore I will tell about how to paste video-bios correctly(Don't tell about patching of Framebuffer and the other things).
"ATY,bin_image",
Buffer (Here should be empty)
{
Here we put down our video-bios
}
Afterwards, it will take time to past video-bios to DSDT in the program DSDTSE. After that, we will see very long line. Don't worry, it's OK. It will be adjusted after compilation. And as a result, the last step of that affair is to click on the button called "Compile DSDT"
Hope that my little manual will hope to somebody!
post-974387-0-64748800-1366369616_thumb.png
Another ready solution for AMD Radeon HD 6650M
http://www.insanelymac.com/forum/topic/287995-how-to-launch-ati-card-by-dsdt/?do=findComment&comment=1910121

Inject for ATI7XXX

http://www.insanelymac.com/forum/topic/287995-how-to-launch-ati-card-by-dsdt/?p=1938946

DSDT.aml.zip

rom_dsdt_converter.exe.zip

ioreg.zip

Edited by Alex Auditore

Share this post


Link to post
Share on other sites

I will check it and let you know :moil:

Thanks

 

 

N.B. Converted video-vios, got something unorganized !!! Added (ATY_Bin_to_DSDT.txt) see if it is normal. One more thing, on dsdt also need to edit one's own graphics frame buffer ?

It's Ok. Now press ctrl+a and ctrl+c. After go to DSDTSE and open your dsdt. Afterwards past your dsdt in the necessary place(ctrl+v)

Yes, of course. You need to patch your framebuffer as well. My method is substitution of bootloader's injection. But it is better as with this method working "Display Sleep".

Sometimes, there is only way to start up the function of "Display Sleep"

post-974387-0-73746000-1366319606_thumb.png

Share this post


Link to post
Share on other sites

Check out my edited dsdt, it is ok or not ?

All things added under the method _DSM, cause as like you method _DCS, _DGS, _DSS not present on my DSDT. So not added device _DP & What was under method _DSM assigned as normal.

Thank you

Palash

DSDT file.zip

Share this post


Link to post
Share on other sites

I think many of this parameters are understandable for many people.

I don't think so. Can you please explain what they stand for and what each one of them does or changes?

Share this post


Link to post
Share on other sites

Check out my edited dsdt, it is ok or not ?

All things added under the method _DSM, cause as like you method _DCS, _DGS, _DSS not present on my DSDT. So not added device _DP & What was under method _DSM assigned as normal.

Thank you

Palash

And did you try your DSDT that you had compiled?

If it doesn't work, try to put Device (GFX0) into Device (PEG0)(See ATY_Dsts_sample)

You can test it on such bootloaders as Chameleon or XPC(on USB stick). It's comfortable to test new things on Mac. But we can also use Clover for it but I think it has a little inconvenience(editing config.plist, choosing DSDT for testing and so on)

 

I don't think so. Can you please explain what they stand for and what each one of them does or changes?

Year, I will try to make a manual which is more exatly. We didn't have to change all of the parameters. I should understand how it works, not only my computer, on other computers as well.

ATY_Dsts_sample.txt

ATI48x0_for_DSDT.txt.zip

Share this post


Link to post
Share on other sites

Tried different framebuffer(Shrike, Gliff) system not boot with DSDT !!!

Even I tried Cyrus the Great's method (using my bin image) - http://www.insanelym...650-in-shrike/.

Cause my card is a renamed version of 4650 & also dev_ven. are same.

 

No way to get boot with DSDT,When I tried to inject graphics (without graphics injection on dsdt everything goes normal).

 

Thanks

Palash

DSDT.zip

Share this post


Link to post
Share on other sites

I have 2x6950(dual video cards).I was setup GraphicsEnabler=yes openGL extensions test high but if set dsdt in 2x cards its very low. why its low with dsdt? can you look my dsdt ple.

thankyou.

dsdt.aml.zip

Share this post


Link to post
Share on other sites

Tried different framebuffer(Shrike, Gliff) system not boot with DSDT !!!

Even I tried Cyrus the Great's method (using my bin image) - http://www.insanelym...650-in-shrike/.

Cause my card is a renamed version of 4650 & also dev_ven. are same.

 

No way to get boot with DSDT,When I tried to inject graphics (without graphics injection on dsdt everything goes normal).

 

Thanks

Palash

Please, give me your dsdt where video-bios is not pasted. I will try to fix it.

I think we need some time for it.(We should experiment)

PS you should choose framebuffer where it works with Graphics Enabler. In other words don't change your working framebuffer.

 

I have 2x6950(dual video cards).I was setup GraphicsEnabler=yes openGL extensions test high but if set dsdt in 2x cards its very low. why its low with dsdt? can you look my dsdt ple.

thankyou.

Sorry, that I can't help you right now. I look it into.

Is information correct in "about this mac"?

It should something like this

ATI Mobility Radeon HD 5850:
Chipset Model: ATI Mobility Radeon HD 5850
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x68a1
Revision ID: 0x0000
ROM Revision: 113-B7710C-176
EFI Driver Version: 01.00.318
Displays:
Color LCD:
Resolution: 1920 x 1080
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

Do DVDPlayer, Geek-bench, and heavy games work with DSDT where it is put two video-bioses.

 

There is example dsdt of 6670 and as we can see

Tried different framebuffer(Shrike, Gliff) system not boot with DSDT !!!

Even I tried Cyrus the Great's method (using my bin image) - http://www.insanelym...650-in-shrike/.

Cause my card is a renamed version of 4650 & also dev_ven. are same.

 

No way to get boot with DSDT,When I tried to inject graphics (without graphics injection on dsdt everything goes normal).

 

Thanks

Palash

Try to put video-bios to the second Device (PEGP). You pasted it in first.

Share this post


Link to post
Share on other sites

both same video cards.xfx 2x6950 please fix my dsdt thank you

 

 

8] Chipset Model: AMD Radeon HD 6950

8] Type: GPU

8] Bus: PCIe

8] Slot: PCI Slot 1

8] PCIe Lane Width: x16

8] VRAM (Total): 2048 MB

8] Vendor: ATI (0x1002)

8] Device ID: 0x6719

8] Revision ID: 0x0000

8] ROM Revision: 113-B7710C-176

8] EFI Driver Version: 01.00.318

8] Displays:

9]
SDM-HS95P:

9] Resolution: 1280 x 1024

9] Pixel Depth: 32-Bit Color (ARGB8888)

9] Display Serial Number: 6389000

9] Mirror: Off

9] Online: Yes

9] Rotation: Supported

2]
S27A950D:

2] Resolution: 1920 x 1080 @ 120 Hz

2] Pixel Depth: 32-Bit Color (ARGB8888)

2] Main Display: Yes

2] Mirror: Off

2] Online: Yes

2] Rotation: Supported

2] Connection Type: DisplayPort

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Try to put video-bios to the second Device (PEGP). You pasted it in first.

 

Exactly where you are indicating is not clear to me :( .

Anyway I have prepared a texts of my graphics info, also added ioreg and dsdt (without any graphics edition) Files.zip- try to control.

If you can correct it and add it to my dsdt or indicate me where to put the method.

 

Thank you

Palash

Share this post


Link to post
Share on other sites

Exactly where you are indicating is not clear to me :( .

Anyway I have prepared a texts of my graphics info, also added ioreg and dsdt (without any graphics edition) Files.zip- try to control.

If you can correct it and add it to my dsdt or indicate me where to put the method.

 

Thank you

Palash

Hello. Try this please and disable everything that injects your bootloader for Graphics.

Now I think video bios was placed in correct place. But it may contain some mistakes with some of the parameters.

See second Device (DVI)

Don't forget to paste video-bios to ATY,bin_image",

--------

Buffer (Zero) {}, And you have to delete "zero".

PS I attach my IOReg to the top of this thread just in case.

 

both same video cards.xfx 2x6950 please fix my dsdt thank you

 

 

8] Chipset Model: AMD Radeon HD 6950

8] Type: GPU

8] Bus: PCIe

8] Slot: PCI Slot 1

8] PCIe Lane Width: x16

8] VRAM (Total): 2048 MB

8] Vendor: ATI (0x1002)

8] Device ID: 0x6719

8] Revision ID: 0x0000

8] ROM Revision: 113-B7710C-176

8] EFI Driver Version: 01.00.318

8] Displays:

9]
SDM-HS95P:

9] Resolution: 1280 x 1024

9] Pixel Depth: 32-Bit Color (ARGB8888)

9] Display Serial Number: 6389000

9] Mirror: Off

9] Online: Yes

9] Rotation: Supported

2]
S27A950D:

2] Resolution: 1920 x 1080 @ 120 Hz

2] Pixel Depth: 32-Bit Color (ARGB8888)

2] Main Display: Yes

2] Mirror: Off

2] Online: Yes

2] Rotation: Supported

2] Connection Type: DisplayPort

Give me your ioger please with GraphicEnabler=Yes and without video-bios in DSDT.

--------------------------

I've decided to attach another ready solution for AMD Radeon HD 6650M

Original Ipomoea:
00040000040300000001000012040105
00080000040200000001000011020403
10000000100000000001000000000002    
Patch
02000000400000000901000010010003
00080000000200000001000011020401
10000000100000000001000000000105


Device (PEGP)
{
Name (_ADR, Zero)
Name (_PRW, Package (0x02)
{
0x09,
0x04
})
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x54)
{
"@0,AAPL,boot-display",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
},
"@0,ATY,EFIDisplay",
Buffer (0x05)
{
"LVDS"
},
"@0,compatible",
Buffer (0x0C)
{
"ATY,Ipomoea"
},
"@0,device_type",
Buffer (0x08)
{
"display"
},
"@0,built-in",
Buffer (One)
{
0x01
},
"@0,display-dual-link",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
},
"@0,display-type",
Buffer (0x04)
{
"LCD"
},
"@0,name",
Buffer (0x0C)
{
"ATY,Ipomoea"
},
"@1,device_type",
Buffer (0x08)
{
"display"
},
"@1,compatible",
Buffer (0x0C)
{
"ATY,Ipomoea"
},
"@1,connector-type",
Buffer (0x04)
{
0x00, 0x08, 0x00, 0x00
},
"@1,display-type",
Buffer (0x05)
{
"HDMI"
},
"@1,name",
Buffer (0x0C)
{
"ATY,Ipomoea"
},
"@2,device_type",
Buffer (0x08)
{
"display"
},
"@2,compatible",
Buffer (0x0C)
{
"ATY,Ipomoea"
},
"@2,connector-type",
Buffer (0x04)
{
0x10, 0x00, 0x00, 0x00
},
"@2,display-type",
Buffer (0x04)
{
"VGA"
},
"@2,name",
Buffer (0x0C)
{
"ATY,Ipomoea"
},
"AAPL,backlight-control",
Buffer (0x04)
{
0x00, 0x00, 0x00, 0x00
},
"AAPL00,DualLink",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
},
"AAPL,EMC-Display-List",
Buffer (0x40)
{
/* 0000 */ 0x03, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0008 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0010 */ 0x06, 0x10, 0x00, 0x00, 0x1B, 0x92, 0x00, 0x00,
/* 0018 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0020 */ 0x06, 0x10, 0x00, 0x00, 0x1C, 0x92, 0x00, 0x00,
/* 0028 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0030 */ 0x06, 0x10, 0x00, 0x00, 0x21, 0x92, 0x00, 0x00,
/* 0038 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00
},
"AAPL,aux-power-connected",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
},
"ATY,bin_image",
Buffer ()
{
Here you have got to past your video-bios.
},
"ATY,Card#",
Buffer (0x0E)
{
"109-B77101-00"
},
"ATY,Copyright",
Buffer (0x33)
{
"Copyright AMD Inc. All Rights Reserved. 2005-2012"
},
"ATY,EFICompileDate",
Buffer (0x0C)
{
"Apr 19 2012"
},
"ATY,EFIDriverType",
Buffer (One)
{
0x02
},
"ATY,EFIEnabledMode",
Buffer (One)
{
0x02
},
"ATY,EFIHWInitStatus",
Buffer (0x08)
{
/* 0000 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00
},
"ATY,EFIOrientation",
Buffer (0x02)
{
0x00, 0x01
},
"ATY,EFIVersion",
Buffer (0x0B)
{
"01.00.3180"
},
"ATY,EFIVersionB",
Buffer (0x0F)
{
"113-B77101-012"
},
"ATY,EFIVersionE",
Buffer (0x0F)
{
"113-B7710A-318"
},
"ATY,MemRevisionID",
Buffer (0x02)
{
0x09, 0x00
},
"ATY,MemVendorID",
Buffer (0x02)
{
0x02, 0x00
},
"ATY,PlatformInfo",
Buffer (0x80)
{
/* 0000 */ 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0008 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0010 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0018 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0020 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0028 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0030 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0038 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0040 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0048 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0050 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0058 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0060 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0068 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0070 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
/* 0078 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00
},
"ATY,Rom#",
Buffer (0x10)
{
"113-B7710C-176"
},
"AAPL,slot-name",
Buffer (0x0C)
{
"PCIe Slot-1"
},
"device_type",
Buffer (0x12)
{
"ATY,IpomoeaParent"
},
"VRAM,totalsize",
Buffer (0x04)
{
0x00, 0x00, 0x00, 0x80
},
"model",
Buffer (0x14)
{
"AMD Radeon HD 6650M"
},
"hda-gfx",
Buffer (0x0A)
{
"onboard-1"
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}
}

[/codeBOX]

[/font][/color]

dsdtfor_plsh2me.zip

6650MDSDT.aml.zip

Share this post


Link to post
Share on other sites

my ioreg GraphicsEnabler=Yes

 

Personality: Gibba

ConnectorInfo count in decimal: 5

Disk offset in decimal 179984

0000000 00 08 00 00 04 02 00 00 00 01 00 00 11 02 06 04

0000010 04 00 00 00 04 02 00 00 00 01 00 00 11 02 01 03

0000020 00 02 00 00 14 02 00 00 00 01 00 00 00 00 03 05

0000030 00 04 00 00 04 03 00 00 00 01 00 00 12 04 04 01

0000040 00 04 00 00 04 03 00 00 00 01 00 00 22 05 05 02

0000050

GE=Yes ioreg.zip

Share this post


Link to post
Share on other sites

my ioreg GraphicsEnabler=Yes

 

 

Personality: Gibba

ConnectorInfo count in decimal: 5

Disk offset in decimal 179984

0000000 00 08 00 00 04 02 00 00 00 01 00 00 11 02 06 04

0000010 04 00 00 00 04 02 00 00 00 01 00 00 11 02 01 03

0000020 00 02 00 00 14 02 00 00 00 01 00 00 00 00 03 05

0000030 00 04 00 00 04 03 00 00 00 01 00 00 12 04 04 01

0000040 00 04 00 00 04 03 00 00 00 01 00 00 22 05 05 02

0000050

Hello. If you could load with video-bios in DSDT it's good.

But why I didn't see the Device (PEGP), Device (GFX0), and so on, in DSDT the you give me in twelfth message?

Your DSDT with video-bios has some mistakes.

For example, it have to be so

 "ATY,MemVendorID",
						 Buffer (0x02)
						 {
							 0x02, 0x10
						 },

But you had 0x02, 0x00(your ioreg show me it)

And I didn't discole this parameter in your DSDT.

			 "@3,VRAM,memsize",
						 Buffer (0x08)
						 {
							 /* 0000 */ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x80(it should be 8 if you have 2Gb memory, ioreg shows me so)
						 },

Take Method (_DSM, 4, NotSerialized) from the head of the topic or from fourteenth message(maybe it even better as it's closer to your video card and maybe depends less corrections) and to adjust it for your video-card. It will takes some time.

Compare my IOReg and your IOReg and it ought to help to choose necessary meanings.

If you will have some complications, don't feel shy I will try to help.

post-974387-0-74566200-1366904837_thumb.png

Share this post


Link to post
Share on other sites

Hello. Try this please and disable everything that injects your bootloader for Graphics.

Now I think video bios was placed in correct place. But it may contain some mistakes with some of the parameters.

See second Device (DVI)

Don't forget to paste video-bios to ATY,bin_image",

--------

Buffer (Zero) {}, And you have to delete "zero".

PS I attach my IOReg to the top of this thread just in case.

 

 

 

Alex, Tried your sended DSDT & others(edited by me) !!!

I don't know what goes wrong with DSDT.

System not booting with DSDT, if I add graphics injection.

It is strange for me, cause anyway I have patched my graphics kexts and with these kexts using ATY_Init (which is a gr. injector).

I mean anyway I am injecting my graphics card and this works both shrike & peregrine framebuffer (differently patched kexts), why not with DSDT?

On the sequence also tried without pasting bin_image, result same system not booting.

Attaching dsdt's, ioreg and aty.init kext (my card is 4600series) if you can find out something, otherwise I have to give up of the process.

 

Thank you

Palash

Files.zip

Share this post


Link to post
Share on other sites

thanks alex I change your idea #16

please look my ioreg after test still openGL low.

Hello I've found a solution for your card. This human told that he could launch his ATI HD 6950 2 gB.


Device (PEX0)
{
Name (_ADR, 0x001C0000)
Device (GFX1)
{
Name (_ADR, Zero)
Name (_PRW, Package (0x02)
{
0x09,
0x05
})
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x3C)
{
"@0,compatible",
Buffer (0x0A)
{
"ATY,Gibba"
},

"@0,connector-type",
Buffer (0x04)
{
0x00, 0x08, 0x00, 0x00
},

"@0,device_type",
Buffer (0x08)
{
"display"
},

"@0,display-type",
Buffer (0x05)
{
"NONE"
},

"@0,name",
Buffer (0x0A)
{
"ATY,Gibba"
},

"@1,compatible",
Buffer (0x0A)
{
"ATY,Gibba"
},

"@1,connector-type",
Buffer (0x04)
{
0x00, 0x02, 0x00, 0x00
},

"@1,device_type",
Buffer (0x08)
{
"display"
},

"@1,display-type",
Buffer (0x05)
{
"NONE"
},

"@1,name",
Buffer (0x0A)
{
"ATY,Gibba"
},

"@2,compatible",
Buffer (0x0A)
{
"ATY,Gibba"
},

"@2,connector-type",
Buffer (0x04)
{
0x04, 0x00, 0x00, 0x00
},

"@2,device_type",
Buffer (0x08)
{
"display"
},

"@2,display-type",
Buffer (0x05)
{
"NONE"
},

"@2,name",
Buffer (0x0A)
{
"ATY,Gibba"
},

"@3,compatible",
Buffer (0x0A)
{
"ATY,Gibba"
},

"@3,connector-type",
Buffer (0x04)
{
0x00, 0x04, 0x00, 0x00
},

"@3,device_type",
Buffer (0x08)
{
"display"
},

"@3,display-type",
Buffer (0x05)
{
"NONE"
},

"@3,name",
Buffer (0x0A)
{
"ATY,Gibba"
},

"@4,compatible",
Buffer (0x0A)
{
"ATY,Gibba"
},

"@4,connector-type",
Buffer (0x04)
{
0x00, 0x04, 0x00, 0x00
},

"@4,device_type",
Buffer (0x08)
{
"display"
},

"@4,display-type",
Buffer (0x05)
{
"NONE"
},

"@4,name",
Buffer (0x0A)
{
"ATY,Gibba"
},

"AAPL,slot-name",
Buffer (0x09)
{
"PCIe x16"
},

"device_type",
Buffer (0x10)
{
"ATY,GibbaParent"
},

"model",
Buffer (0x12)
{
"ATI Radeon HD6950"
},

"name",
Buffer (0x10)
{
"ATY,GibbaParent"
},

"hda-gfx",
Buffer (0x0A)
{
"onboard-1"
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}

Device (HDAU)
{
Name (_ADR, One)
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x02)
{
"hda-gfx",
Buffer (0x0A)
{
"onboard-1"
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}
[/codeBOX]

He has two video card, namely ATI and Nvidea. ATI stands on second PCI.

Try his section and don't forget to paste

[code]
"ATY,bin_image",
Buffer (0xFC00)
{
[/code]

And don't listen him that your have not perfact card for hackintosh. We shouldn't give up!

http://netkas.org/?p=959

http://netkas.org/?p=1056

http://applelife.ru/...-12#post-335048

(Use Google translator)

He recomends these drivers for your card. But try it with your drivers that you have now at first

post-974387-0-93337800-1367001697_thumb.jpg

 

Alex, Tried your sended DSDT & others(edited by me) !!!

I don't know what goes wrong with DSDT.

System not booting with DSDT, if I add graphics injection.

It is strange for me, cause anyway I have patched my graphics kexts and with these kexts using ATY_Init (which is a gr. injector).

I mean anyway I am injecting my graphics card and this works both shrike & peregrine framebuffer (differently patched kexts), why not with DSDT?

On the sequence also tried without pasting bin_image, result same system not booting.

Attaching dsdt's, ioreg and aty.init kext (my card is 4600series) if you can find out something, otherwise I have to give up of the process.

 

Thank you

Palash

Sorry me. No idea yet, but we didn't give up. We will mull it over further.

Share this post


Link to post
Share on other sites

Wow thanks man you did.morthen year I have this problem.now solved.changed to PEGP to PEX0 and PEG1 to PEX1

thank you very much your hard work. I update working dsdt.

if you don't mind can you fix wright Personality because dvi i and dvi d not working I have 2 xfx 6950 only one slot is working if i connect borth video cards.

 

Last login: Tue Jun 26 09:14:57 on ttys000

navaratnams-Mac-Pro-2:~ navaratnammanoranjan$ /Users/navaratnammanoranjan/Desktop/VBIOS/redsock_bios_decoder </Users/navaratnammanoranjan/Desktop/slot1/1002_6719.rom

695CNF80.BIN:

 

CAYMAN PRO Hill GDDR5 BIOS

 

Subsystem Vendor ID: 1682

Subsystem ID: 3122

Object Header Structure Size: 436

Connector Object Table Offset: 52

Router Object Table Offset: 0

Encoder Object Table Offset: 145

Display Path Table Offset: 12

Connector Object Id [19] which is [DISPLAY_PORT]

encoder obj id [0x21] which is [iNTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false

Connector Object Id [19] which is [DISPLAY_PORT]

encoder obj id [0x21] which is [iNTERNAL_UNIPHY2 (osx txmit 0x22 [duallink 0x2] enc 0x5)] linkb: true

Connector Object Id [12] which is [HDMI_TYPE_A]

encoder obj id [0x20] which is [iNTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false

Connector Object Id [3] which is [DVI_D]

encoder obj id [0x20] which is [iNTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false

Connector Object Id [2] which is [DVI_I]

encoder obj id [0x1e] which is [iNTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false

Connector Object Id [2] which is [DVI_I]

encoder obj id [0x15] which is [iNTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false

navaratnams-Mac-Pro-2:~ navaratnammanoranjan$

------------------------------------

Last login: Sat Jun 30 18:33:56 on ttys000

navaratnams-Mac-Pro-2:~ navaratnammanoranjan$ /Users/navaratnammanoranjan/Desktop/xfx6950\ files1/radeon_bios_decode </Users/navaratnammanoranjan/Desktop/xfx6950\ files1/1002_6719.rom

ATOM BIOS Rom:

SubsystemVendorID: 0x1682 SubsystemID: 0x3122

IOBaseAddress: 0x0000

Filename: 695CNF80.BIN

BIOS Bootup Message:

CAYMAN PRO Hill GDDR5 BIOS

 

PCI ID: 1002:6719

Connector at index 0

Type [@offset 44199]: DisplayPort (10)

Encoder [@offset 44203]: INTERNAL_UNIPHY2 (0x21)

i2cid [@offset 44335]: 0x90, OSX senseid: 0x1

Connector at index 1

Type [@offset 44209]: DisplayPort (10)

Encoder [@offset 44213]: INTERNAL_UNIPHY2 (0x21)

i2cid [@offset 44362]: 0x91, OSX senseid: 0x2

Connector at index 2

Type [@offset 44219]: HDMI-A (11)

Encoder [@offset 44223]: INTERNAL_UNIPHY1 (0x20)

i2cid [@offset 44389]: 0x93, OSX senseid: 0x4

Connector at index 3

Type [@offset 44229]: DVI-D (3)

Encoder [@offset 44233]: INTERNAL_UNIPHY1 (0x20)

i2cid [@offset 44416]: 0x92, OSX senseid: 0x3

Connector at index 4

Type [@offset 44239]: DVI-I (2)

Encoder [@offset 44243]: INTERNAL_UNIPHY (0x1e)

i2cid [@offset 44453]: 0x94, OSX senseid: 0x5

Connector at index 5

Type [@offset 44249]: DVI-I (2)

Encoder [@offset 44253]: INTERNAL_KLDSCP_DAC1 (0x15)

i2cid [@offset 44453]: 0x94, OSX senseid: 0x5

navaratnams-Mac-Pro-2:~ navaratnammanoranjan$

 

ori

 

00 04 00 00 04 03 00 00 00 01 00 00 12 04 04 01

00 04 00 00 04 03 00 00 00 01 00 00 22 05 05 02

00 08 00 00 04 02 00 00 00 01 00 00 11 02 03 04

00 02 00 00 14 02 00 00 00 01 00 00 00 00 06 05

02 00 00 00 40 00 00 00 29 05 00 00 00 00 00 04

 

 

patched

 

 

Personality: Gibba

ConnectorInfo count in decimal: 5

Disk offset in decimal 179984

0000000 00 08 00 00 04 02 00 00 00 01 00 00 11 02 06 04

0000010 04 00 00 00 04 02 00 00 00 01 00 00 11 02 01 03

0000020 00 02 00 00 14 02 00 00 00 01 00 00 00 00 03 05

0000030 00 04 00 00 04 03 00 00 00 01 00 00 12 04 04 01

0000040 00 04 00 00 04 03 00 00 00 01 00 00 22 05 05 02

0000050

test3.zip

Share this post


Link to post
Share on other sites

Wow thanks man you did.morthen year I have this problem.now solved.changed to PEGP to PEX0 and PEG1 to PEX1

thank you very much your hard work. I update working dsdt.

if you don't mind can you fix wright Personality because dvi i and dvi d not working I have 2 xfx 6950 only one slot is working if i connect borth video cards.

 

Last login: Tue Jun 26 09:14:57 on ttys000

navaratnams-Mac-Pro-2:~ navaratnammanoranjan$ /Users/navaratnammanoranjan/Desktop/VBIOS/redsock_bios_decoder </Users/navaratnammanoranjan/Desktop/slot1/1002_6719.rom

695CNF80.BIN:

 

CAYMAN PRO Hill GDDR5 BIOS

 

Subsystem Vendor ID: 1682

Subsystem ID: 3122

Object Header Structure Size: 436

Connector Object Table Offset: 52

Router Object Table Offset: 0

Encoder Object Table Offset: 145

Display Path Table Offset: 12

Connector Object Id [19] which is [DISPLAY_PORT]

encoder obj id [0x21] which is [iNTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false

Connector Object Id [19] which is [DISPLAY_PORT]

encoder obj id [0x21] which is [iNTERNAL_UNIPHY2 (osx txmit 0x22 [duallink 0x2] enc 0x5)] linkb: true

Connector Object Id [12] which is [HDMI_TYPE_A]

encoder obj id [0x20] which is [iNTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false

Connector Object Id [3] which is [DVI_D]

encoder obj id [0x20] which is [iNTERNAL_UNIPHY1 (osx txmit 0x11 [duallink 0x1] enc 0x2)] linkb: false

Connector Object Id [2] which is [DVI_I]

encoder obj id [0x1e] which is [iNTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false

Connector Object Id [2] which is [DVI_I]

encoder obj id [0x15] which is [iNTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false

navaratnams-Mac-Pro-2:~ navaratnammanoranjan$

------------------------------------

Last login: Sat Jun 30 18:33:56 on ttys000

navaratnams-Mac-Pro-2:~ navaratnammanoranjan$ /Users/navaratnammanoranjan/Desktop/xfx6950\ files1/radeon_bios_decode </Users/navaratnammanoranjan/Desktop/xfx6950\ files1/1002_6719.rom

ATOM BIOS Rom:

SubsystemVendorID: 0x1682 SubsystemID: 0x3122

IOBaseAddress: 0x0000

Filename: 695CNF80.BIN

BIOS Bootup Message:

CAYMAN PRO Hill GDDR5 BIOS

 

PCI ID: 1002:6719

Connector at index 0

Type [@offset 44199]: DisplayPort (10)

Encoder [@offset 44203]: INTERNAL_UNIPHY2 (0x21)

i2cid [@offset 44335]: 0x90, OSX senseid: 0x1

Connector at index 1

Type [@offset 44209]: DisplayPort (10)

Encoder [@offset 44213]: INTERNAL_UNIPHY2 (0x21)

i2cid [@offset 44362]: 0x91, OSX senseid: 0x2

Connector at index 2

Type [@offset 44219]: HDMI-A (11)

Encoder [@offset 44223]: INTERNAL_UNIPHY1 (0x20)

i2cid [@offset 44389]: 0x93, OSX senseid: 0x4

Connector at index 3

Type [@offset 44229]: DVI-D (3)

Encoder [@offset 44233]: INTERNAL_UNIPHY1 (0x20)

i2cid [@offset 44416]: 0x92, OSX senseid: 0x3

Connector at index 4

Type [@offset 44239]: DVI-I (2)

Encoder [@offset 44243]: INTERNAL_UNIPHY (0x1e)

i2cid [@offset 44453]: 0x94, OSX senseid: 0x5

Connector at index 5

Type [@offset 44249]: DVI-I (2)

Encoder [@offset 44253]: INTERNAL_KLDSCP_DAC1 (0x15)

i2cid [@offset 44453]: 0x94, OSX senseid: 0x5

navaratnams-Mac-Pro-2:~ navaratnammanoranjan$

 

ori

 

00 04 00 00 04 03 00 00 00 01 00 00 12 04 04 01

00 04 00 00 04 03 00 00 00 01 00 00 22 05 05 02

00 08 00 00 04 02 00 00 00 01 00 00 11 02 03 04

00 02 00 00 14 02 00 00 00 01 00 00 00 00 06 05

02 00 00 00 40 00 00 00 29 05 00 00 00 00 00 04

 

 

patched

 

 

Personality: Gibba

ConnectorInfo count in decimal: 5

Disk offset in decimal 179984

0000000 00 08 00 00 04 02 00 00 00 01 00 00 11 02 06 04

0000010 04 00 00 00 04 02 00 00 00 01 00 00 11 02 01 03

0000020 00 02 00 00 14 02 00 00 00 01 00 00 00 00 03 05

0000030 00 04 00 00 04 03 00 00 00 01 00 00 12 04 04 01

0000040 00 04 00 00 04 03 00 00 00 01 00 00 22 05 05 02

0000050

Maybe you should use frame-buffer which has 6 ports, Bulrushes, for example.

 

00 04 00 00 04 03 00 00 00 01 00 00 12 04 00 01

00 04 00 00 04 03 00 00 00 01 00 00 22 05 01 02

00 08 00 00 04 02 00 00 00 01 00 00 11 02 02 04

04 00 00 00 04 02 00 00 00 01 00 00 11 02 03 03

00 02 00 00 14 02 00 00 00 01 00 00 10 00 04 05

00 02 00 00 14 02 00 00 00 01 00 00 00 10 05 05

-----------

Palash. Hello, Maybe you should try a similar solution that manor has.

http://www.insanelym...t/#entry1910636

Share this post


Link to post
Share on other sites

 

Palash. Hello, Maybe you should try a similar solution that manor has.

http://www.insanelym...t/#entry1910636

 

Actually my system running smoothly :P , Just wanna give a try with your method :D .

Always was successfull to patch my graphics kexts with the old method - http://www.insanelymac.com/forum/topic/252061-mobility-radeon-hd-4650full-resolution-with-qe-ci-working-on-internal-lvds-screen/#entry1655903

Any kind of co-operation & testing purpose you should call me, freely :weight_lift:

Thank you

Palash

Share this post


Link to post
Share on other sites

 

 

Actually my system running smoothly :P , Just wanna give a try with your method :D .

Always was successfull to patch my graphics kexts with the old method - http://www.insanelymac.com/forum/topic/252061-mobility-radeon-hd-4650full-resolution-with-qe-ci-working-on-internal-lvds-screen/#entry1655903

Any kind of co-operation & testing purpose you should call me, freely :weight_lift:

Thank you

Palash

ATIInit is also good. I was consulting with person who has more experience than me in this deal. And he explained that he don't know what should do with your card.

As a meter of principle This method into DSDT and ATIInit should be the same. But adjustment of ATIInit is not easy work as well.

When I creating this topic I don't think that it has so many exceptions. My card should be corrected so, yours in a different way, manor's also has some peculiarity. and so on. Our goal it to gather all of these features as more as possible.

Share this post


Link to post
Share on other sites

I try like this not work

 

ori

Personality: Bulrushes

ConnectorInfo count in decimal: 6

Disk offset in decimal 179504

0000000 00 04 00 00 04 03 00 00 00 01 00 00 12 04 04 01

0000010 00 04 00 00 04 03 00 00 00 01 00 00 21 03 02 02

0000020 00 04 00 00 04 03 00 00 00 01 00 00 12 04 03 03

0000030 00 04 00 00 04 03 00 00 00 01 00 00 22 05 04 04

0000040 00 08 00 00 04 02 00 00 00 01 00 00 11 02 06 04

0000050 00 04 00 00 04 03 00 00 00 01 00 00 20 01 06 06

0000060

patched

00 04 00 00 04 03 00 00 00 01 00 00 12 04 00 01

00 04 00 00 04 03 00 00 00 01 00 00 22 05 01 02

00 08 00 00 04 02 00 00 00 01 00 00 11 02 02 04

04 00 00 00 04 02 00 00 00 01 00 00 11 02 03 03

00 02 00 00 14 02 00 00 00 01 00 00 10 00 04 05

00 02 00 00 14 02 00 00 00 01 00 00 00 10 05 05

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×