Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
jimmyco2008

PS2 keyboard no-go > Try yet another kext or skip the Welcome menu?

3 posts in this topic

Recommended Posts

Hey all,

 

I got a swell AMD hackintosh based on 10.6.0 installed, and booting! It takes its sweet time waiting for IntelCPUPowerManagement.kext, otherwise I eventually end up at the Welcome screen.

 

My USB mouse works, however my PS2 keyboard does not... I've tried at least three different PS2 kext groups (two or three kexts in each group, ie VooDoo, ApplePS2....) to no avail, the PS2 kexts make is so it tried to detect my keyboard, but it freezes either after a while or after I press the key next to shift, not sure which...

 

So if I could just skip this the Welcome screen, that would help me out a lot, I could add my Bluetooth keyboard and use that... But the only method I know of for skipping the Welcome screen is -s boot flag and entering text... Keyboard works in Chameleon, but when I get into the -s environment, it does not work.

 

If you guys need this info: The mobo is AMD, nForce 430 chipset (I have a kext for that, needed to make the HDD and ODD show up), with the kernel I do not need ANY boot flags...

 

I'm assuming a USB keyboard would work, but I don't have one handy and would rather not spend $20+ on one at BestBuy... Yes I've heard of Amazon and eBay... let's just try to get PS2 or BT working?...

 

Thanks!

Share this post


Link to post
Share on other sites

Thanks for the reply... Keyboard only works in Chameleon, it does not work in OS X at all, including in the -s environment... Unless I can do this via the myHack USB installer?

 

EDIT: That's a no-go, keyboard doesn't work, either... It's almost like it's frozen, Num lock is on, but I can't turn it off or anything... If I turn on caps lock at the BIOS boot, it stays on "frozen", too.

 

Makes sense since the same kexts on the myHack are on the HDD.... I forget if keyboard works in the installer menu, but if it does, can I enter the commands into Terminal?

 

Oh! I have a Macbook Pro and a USB to SATA cable I've been using to install PS2 kexts on the Hackintosh HDD... Can I do something with access to the file system?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×