Jump to content
InsanelyMac Forum
WhatTheTech

Firewire 800 Drive Not Recognized...

Recommended Posts

Well, I just purchased a WD My Passport Studio Drive for my iMac. I wanted a Firewire drive to free up one of my USB ports on the iMac, so I chose this relatively inexpensive new 500GB drive.

 

The issue:

Well, when plugged in to the Firewire 800 port, the drive spins up, powers on, LED lights up and flashes as if it's being read (initially), but doesn't show up in either Disk Utility, Finder or System Information. The firewire port shows up in system profiler, and after running the hardware test it reported no errors.

 

What I have tried:

Plugging in with USB works, so at least the drive is known working.

Performed WD's tests via USB, passed without issue.

Tried a different cable, same issue.

Tried resetting SMC, didn't fix it.

 

I don't have another mac with FW800, otherwise I would try it on another computer, and I don't have another FW800 device to eliminate port issues on the drive itself. I might have a buddy with a FW800 port on his computer, so that might be an option, but for now I'm looking for other things I can do today to eliminate user error.

 

Any thoughts much appreciated!

Share this post


Link to post
Share on other sites
Advertisement

Update - the following is showing up in console repeatedly:

 

4/11/13 11:31:44.000 AM kernel[0]: FireWire (OHCI) Lucent ID 5901 built-in: no valid selfIDs for more than 3 minutes after bus reset.

 

Good news is it would seem I'm not the only one with the issue, and that FW800 is problematic for many people. Some have had success resetting PRAM so I'm going to try that now and see if it gets me anywhere...

 

Edit - also found this before plugging in the drive this morning:

 

Apr 6 08:32:13 localhost kernel[0]: FireWire (OHCI) Lucent ID 5901 built-in now active, GUID 001e52fffe5b94d0; max speed s800.

 

Could be drive related...God I hope my FW800 port isn't messed up, I really would prefer an HDD on that than USB...

Share this post


Link to post
Share on other sites

Update - reset the PRAM and NVRAM, of course I wasn't expecting it to do much and it didn't. I was surprised at how easy WD was to deal with - they've definitely made some customer services changes recently. I told him about the issue and let him know the log error that was popping up - he didn't seem very surprised at all, in fact as soon as I mentioned the error he said he would RMA the drive. No "unplug the device", "use a different cable", just a straight up "I'll get you an RMA number right away".

 

I'm still going to try it out on another mac first, but we'll see if it's the drive or not.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×