Jump to content
InsanelyMac Forum
Sign in to follow this  
gibranxmacx

100% working OSX 10.5.8. ON ASUS P5B - E8400 - ATI X1300

Recommended Posts

HACKINTOSH osx leopard 10.5.8

 

(sorry for my bad english)!!!

im a graphic designer and i utilise my hackintosh for job (i have tested all cs4, shake and many software)

 

i hope this guide can help to have a perfect hackintosh on this configuration

THIS GUIDE FIX TIME MACHINE mac address problem

(audio - ethernet - front row - time machine - usb - QE/CI perfect enable and full functionally!)

 

MY PC

ASUS P5B (but tested also on p5b-e with firewire)

intel core2duo e8400

2 gb ram

hd eide 80gb

dvd rom lg

ATI SAPPHIRE x1300 256 pci-e

USB KEYBOARD cooler master

tablet pen and mouse WACOM graphire 3 xl

-----------------------------------------------------------------------

- you need:

 

iatkos v7

 

kext helper

 

uinstaller

 

osx86tools

 

some kext

 

combo update 10.5.8

 

-------------------------------------------------------------------------

BIOS DEFAULT

 

+ USB LEGACY ENABLE

 

+ PLUG PLAY OS

 

CONNECT YOU MONITOR ON VGA NO DVI!!!!!!! (dvi not work on ati x1300 for this guide)

------------------------------------------------------------------------

 

1 - boot from iatkosv7

 

2 - format hd guid mac os journaled

 

3 - select this customization:

 

 

unchek all and select: (if you have a ps2 mouse or keyboard you need to select the correct ps2 decrypter but i dont rember)

 

iatkos v7 system

 

chameleon v2

 

extra dir

 

dsdt

 

dsmos

 

(note: DONT SELECT KERNEL if you have core2duo e8400 or similar. If your cpu is a PENTIUM D 945 (tested!) select 9.7 voodo)

 

apic driver

 

disabler

 

ohr

 

remove tymce

 

ahci

 

intel sata

 

sata ide

 

j micron sata/ide

 

voodo hda driver

 

realtek r1000

 

select your langage

 

post instal action

 

-------------------------------------------------------------------------------------

 

TADAAA!!! enjoy intro video!! ( insert a password when register you account or kext helper dont work...)

 

but the mouse have a strange square icon....dont worry!

 

kext_guide_2013.zip

 

1- open kext helper

2 - drag and drop natitx1300.kext and instal-

3 - open uinstaller and select your hd

4 - select your boot native resolution for the monitor (ex my lcd work at native 1280x1024)

5 - REBOOT

 

NOW YOUR ATI X1300 is fully functional rotate, quartz extreme, core image , open gl - rotation and selectable resolution work

 

this is for leopard a great graphic card... it work best in photoshop to rotate screen in open gl and i have tested for 2 years

on all professional software (shake final cut cs4 suite lightwave houdini etc..)

 

 

now its time to update...

 

download and instal combo update 10.5.8

 

reboot

 

the system reboot again automaticaly

 

ok you have a 10.5.8 but time machine e front row dont work - time machine error mac address and front row for apple trailer

is non internet connected but you navigate in internet!

 

dont worry...

 

this is a strange think i have found to fix.....

 

open OSX86tools and restore to default

 

reboot

 

1 - kext helper instal iousbfamilykext

 

2 - open uinstaller and fix time machine

 

3 - reboot

 

CONGRATULATION YOU HAVE time machine , front row fixed !!!!!! ONLY STOP DONT WORK but its normal on this hackintosh

 

now you can make all the apple update!!!!!!!

 

 

 

 

before this setting i have tried 30 installation, this guide on my configuration work at 100%

 

today attach kext for this guide

Share this post


Link to post
Share on other sites
Advertisement

hi fantomas1 !

 

from 2 weeks i tri to install iatkos s3 v2 on this configuration.

 

i have the correct setting for custom installation (yestarday i have installed a pci card firewire 800 and 400 with chip texas instrument)

work plug and play on leopard and on snow leopard (because the chip is texas instrument the best for apple and hackintosh)

 

the audio work, time machine work, front row work (but after varoius kext tried today nont work)

 

the problem is that the ati x1300 for the system is an ati hd4890 whit 256mb but no QE/CI (front row work) and resolution blocked on 1024x768

 

i have fixed the square mouse pointer problem whith 2 kext but no QE/CI and resolution (dashboard have ripple effect)

 

the combo update gave me kernel panic (i tried myhack and #####)

 

the system is perfect (after fixed mouse problem similar to itakosv7 installation but whit other kext pached) for internet navigation

and little software but no for me

 

iv tried to install houdini 12 and partially work! i have render some little frame from pyro module but the software is not usable...

 

for me the problem is: the graphic card ati x1300 and the combo update

 

i try to instal about 10 times

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • MaLd0n i created my hackintosh but at pci device not show up all device, can help me to makae DSDT   My hackintosh specification: ASUS Z270 MAXIMUS IX CODE BIOS 1301 Core i5 7600K overclock 4.8Ghz Memory 16GB AMD RADEON RX 560 Use pci card broadcom wifi & bluetooth   DSDT and clover compile RunMe.app    
    • Cool! Do you have a link? Googled and didn't see anything yet.   Never mind... you're quick! I just noticed you updated it on the 1st page THANKS!!!!!!
    • I resolved the problem. Just set this coding in your config.plist:   "
      <key>KextsToPatch</key>
              <array>
                  <dict>
                      <key>Comment</key>
                      <string>USB 10.13.4+ by PMHeart</string>
                      <key>Disabled</key>
                      <false/>
                      <key>Find</key>
                      <data>
                      g32UDw+DlwQAAA==
                      </data>
                      <key>InfoPlistPatch</key>
                      <false/>
                      <key>MatchOS</key>
                      <string>10.13.x</string>
                      <key>Name</key>
                      <string>com.apple.driver.usb.AppleUSBXHCI</string>
                      <key>Replace</key>
                      <data>
                      g32UD5CQkJCQkA==
                      </data>
                  </dict>
              </array>     "
    • New Web Driver - 387.10.10.10.30.107 for 10.13.4 build 17E202
    • I guess having pre{max-height: 500px;overflow: auto;} in CSS was too much for IPS Devs' tast.  Until an admin has hands on this, you still can use stylish plugin to accomplish it.     In fact, it is pretty easy than it appears - Just apply a simple click on the codebox (it will highlight it), then 'delete' key.


×