Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
betahash

[solved] MSI U100 GMA950 0x27A68086 bufferframe on SL

2 posts in this topic

Recommended Posts

I have trouble with framebuffer of a very specific set : Intel GMA 945 GME on MSI U100. After a lot of search on internet, none package could solve this issue and I turn to professionals here.

 

U100 has a 945GME core, with [0x27A68086 on bus 0:2:1 ] as VGA controller with bufferframe facility & rendering engineering, as well as [ 0x27AE8086 on bus 0:2:0] as GFX0. Judging from outcome of IORegistryExplorer, it seems INCORRECT that most posts says 0x27A6 is a controller for external display. Infact, "IONDRVSupport" provides "Framebuffer functions" @ [0x27A68086] ; and [0x27AE8086 @ bus 0:2:0] works as a framebuffer CLIENT.

 

I set it up with Snow Leopard 10.6.7 Installation DVD with ANDY's legacy_Kernel_v8 (atom support), and put an online update to 10.6.8.

 

 

Anyway, when I tried to overwrite the device-id in order that official kext could drive 0x27a6 as 0x27a2, I failed to find DSDT secions.

 

Well After following Andy's post [Intel GMA945 (0x27AE8086+0x27A28086) resolution + CI/QE/OpenGL solution] I got following issues:

1. LCD or VGA could not recognize its resolution even if I adjusted it to "800x600x32@60Hz" with VNC .

2. Display settings does have more options, but they are for desktop 4:3 VGAs. No native 1024x600x32 LCD 16:9 settings available.

3. On board LCD turns gray, VGA got unrecognizable 1175x___@75Hz signal

4. It does NOT help to add deviceid to kexts (AppleIntelGMA950&AppleIntelIntegratedFramebuffer)

 

Even so, I got some pictures with Andy's kext with screenshots. Please check the screenshot & dsdt @

http://www.insanelym...-wind-oem-dsdt/

 

Thanks in advance

Share this post


Link to post
Share on other sites

The reason seems to be Chameleon Loader. Some change was made with versions( build > 168x). Rollback to Chameleon 1400 and everything seems okay. Will follow this issue and list a tutorial here.

 

[follow- up]

The keypoint is:

 

put both 0x27ae8086 0x27a28086 in [iopcimatch] secions of *.kext / Content/Info.plist . It seems one is for framebuffer and the other for rendering engine. Usually you could find 0x27ae kexts from osx86 but don't forget to put 27a2 in iopcimatch as well.

 

And I used to make use of netbook-installer (google project) but give it up for its unfriendly bootloader. The effective part of this pack is in fact evilappleacpi & eviliopcifamily kexts in Extra directory. Without these two packages you could not reach single user mode, and it could cause other minor issues. Just forget about its (netbook-installer) modules because they are mostly built-in components in ChameLeon's newer versions.

 

As MSIWIND uses rtk wifi& eth adapters, you have to install realtek pro and rollback io80211family to 10.6.7 to prevent disconnection issues. It is advised to keep 10.6.7 AppleACPIPlatform.kext IOACPIFamily.kext in /Extra directory to overwrite 10.6.8 ones, which might be a coordination for io80211faimly.kext.

 

Audio is always a problem. But not so big with u100.

 

In fact I set up two msi wind u100 laptops. This instruction just works.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×