Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


[Intel HM76 Express] Parallel disk access are locking the OS - how to fix it?

1 post in this topic

Recommended Posts

I'm trying since a while to optimize Mac running on an Asus n56vm, and one of the outstanding problem is that parallel random accesses to the disk lock up the OS!

This makes Chrome and some other process-and-disk intensive apps hard to use, and in general makes everything somewhat unresponsive.


I've worked around this by disabiling paging, thus removing most disk read/writes...

however I would like to fix the underlying problem and make everything faster!


The chipset is an Intel HM76, and I don't really know which kexts/settings might be causing the locks...


so my first question is - what kexts are involved in disk accesses for this chipset?

That is, for SATA, AHCI, etc. I can't be sure about which ones they are :/



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By yperomatik
      Hello everyone! I am trying to install El Capitan 10.11.4 on my laptop Asus X751LX using Clover. I managed to succesfully reach the install with no problems, but when I go to Disk Utility in order to prepare my HD, it simply isn't on the list. The only drive it sees is the usb I'm using as installer.
      Here are my PCI devices:

      And this is what I see when I do "diskutil list" in terminal

      I attach my EFI folder with config.plist inside and other stuff. Any Ideas?
    • By conmac7
      Hello my configuration is this:
      Asus P8z77-M
      8GB DDR3 (Corsair 1600)
      Nvidia 560SE 1536MB RAM
      Seagate 250GB SATA3 (ST3250318AS)

      I had a problem with USB not working inside installer but i solved it with this:
      Now remain the other problem with my disks. i have internal sata disk seagate 250GB but it appear as external in disk utility at el capitans installer. i tryed this:
      but with this, no longer start the installer. it stuck at some point. When i remove this code from config.plist, i can go to installer but again the drive appear as external. I tryed also other disks but all internal drives appear as external.

      Any solution?
      Im reffering ofcourse for El Capitan installation
    • By chriz74
      I think this guide will help people install Yosemite on Asus x301a and possibly x401a, x501a intel HM76 (probably also hm70) based laptops both Ivy and Sandy bridge.
      1) we need an unlocked MSR bios in order to get native cpu powermanagement, so download and flash your latest bios, restart your pc enter bios press F9 and load optimized setup.
      2) download fptw64, open an elevated command prompt in window, change directory to fptw64 one and dump your bios with this command:
      fptw64 -d BIOS-Backup.rom -BIOS Now download uefiPatch from coderush and patch your bios, please pay attention to what the output is, if there is some errors or something. Refer to this post. You should now have an MSR unlocked patched bios that you can flash back with the command...
      **** if you are not sure or don't understand what a failed bios flash can do to your pc stop and ask in the forum ****
      **** of course the names of the roms are of your choice so modify the commands accordingly ****
      fptw64 -f patched.rom -BIOS after flashing restart the laptop, enter bios and again press F9 to load optimized defaults, also be sure that graphics framebuffer is set to 64MB.
      3) create a uefi USB with Yosemite and clover, put these kexts in the clover / kexts / 10.10 directory in efi partion of usb:
      VoodooPS2Controller  > the correct driver for me is Elan  However I think some versions of these notebooks have Alps Touchpad as the Asus support website lists both drivers.
      4) start pc from uefi usb (press esc at boot to show boot menu)
      5) in clover press F1 to show some options, dump your DSDT with F4.
      6) restart pc in windows, download dsdteditor  and mount EFI partition of the USB with clover 
      7) open the DSDT in clover / acpi / origin and apply these patches:
       - IRQ patch by rehabman
       - hd4000 patch (if you have an ivy bridge cpu)
       - hd3000 patch  (if you have a Sandy bridge cpu)
       - this battery patch 
      - asusNBFnkeys BrightnessKeys_Patch
      - orange icons patch
      compile the DSDT and see if there are errors or warnings, search and apply patches accordingly (e.g. Tx rename patch)
      once you have your dsdt.aml put it in efi clover / acpi/ patched
      8) restart pc from USB and install Yosemite, when finalizing installation put the time zone manually, tell the pc is not connected to the internet for now.
      9) at desktop we need some files:
       - dpci manager to install some kexts
       - clover and clover configurator to install clover in efi
       - ssdtpregen to generate our ssdt (for cpu)
       - RealtekRTL8111.kext
       - asusNBFnkeys.kext
       - this appleHDA kext
       - Rehabman acpibacklight kext -> this kext was causing this behavior: http://bit.ly/1LYGOKq. Brightness still works without the kext.
       - Rehabman battery kext
       - eapd codec commander (you will have to build this one with xcode)
      so, install clover into efi in the hard disk (look this other guide of mine for more details on options),
      generate your ssdt (install the lan driver first as this script downloads info from the internet while running).
      with clover configurator mount efi and put the kexts from the usb on disk.
      put the DSDT and SSDT in efi (in clover / acpi / patched on disk)
      load the attached config.plist in clover configurator, generate your own smbios (chose macbook air 5.2), export the plist to efi. Note if you are using an SSD please apply the trim kernel patch as per third method in this post: http://www.insanelymac.com/forum/topic/298507-enable-trim-on-non-apple-ssd/
      Now install the kexts with dpcimanager, when finished installing reboot from USB and  open uefi shell:
         - find your efi partition with fsx: (fs1: , fs2: whatever is yours, check with ls what is the content)
         - when your found yours do cd \EFI\CLOVER ; bcfg boot dump ; bcfg boot add 0 CLOVERX64.efi "OSX"
       - reboot, press ESC and choose boot from EFI:OSX (the option we just added).
      everything should work apart WIFI (you can buy a compatible half mini pcie card, I replaced mine with an Atheros  AR5B93 half mini pcie card, it works out of the box).
      Please note: if audio doesn't work you will have to find out the verbs of your codec and replace them in applehda kext.
      ----- This part is for patching HDMI audio and LVDS screen in HD4000 -----
      This is what I did for mine, I have an i7-3630qm with HD4000 graphics.
      First thing the DSDT patch for HD4000 video and audio (igpu and hdef). I have id 1660009 of HD4000 in this cpu so I put the same layout id in the DSDT patch. At this moment without patches only the external HDMI monitor will work so I put these patches in config.plist of clover:
      for lvds internal video to work
      AppleIntelFramebufferCapri 010000000200000030000000 to 050300000200000030000000

      for hdmi


      AppleIntelFramebufferCapri 030400000004000007010000 to 030400000008000006000000
      ---------------> for that part I followed this guide but put the patches in clover instead of patching the kext.
    • By macinsane
      Do I have a USB problem or not? All USB ports only work really with me AFTER sending El Capitan to sleep and wake it up again(dummy kexts, GenericUSB makes no difference, with FakePCIID_XHCIMux.kext all USB ports are dead). In Disk Utility some disks are somehow detected (grayed out, spinning wheel, not mountable). After Wake however all disks work properly. No problems at all with other devices like keyboard, mouse, Bluetooth or USB audio. Has anyone an idea what's going on? Many thanks!
      Edit: Ok, USB 2.0 Ports are working (System profiler shows them as usb 3.0). All USB 3.0 Ports dead.
      Edit2: Compiled DSDT (it's a mess but at least no errors anymore, only a few hundred remarks and warnings...). The result: 4 of the 6 USB 3 Ports are now recognized (used Dummykexts with port restrictions removed). Has that something to do with iMac 14,2 SMBIOS (need it for my nVidia to work, Macpro defintion leads to black screen)? Sleep doesn't work anymore, seems USB wakes the Captain instantly. Any suggestions?