Jump to content
InsanelyMac Forum
Sign in to follow this  
cwestpha

10.8.3 & Radeon 6870 boot insanity (fixed)

Recommended Posts

I think my head is slowly going to explode, 10.8.3 is perhaps one of the single greatest breaking of OS X for me since I first booted up the 10.4 dev2 build on a Pentium 4 rig. Many years and computers latter and I now am dealing with 10.8.3 trying to do everything to block my enjoyment of 10.8.3 after playing with Clover EFI.

 

Setup:

10.8.3 Final (tried upgrade from 10.8.2 and fresh install)

Chameleon 2.2 r2189 (also tried Chameleon 2.0.1 & Clover EFI v2 r1174)

Core i7 3770K - ASUS P8Z77V-Premium /w patched 1805 firmware

XFX Radeon 6870 1GB - OCX Vector 512 GB SSD

MacMini6,2 SMBIOS - no DSDT - GraphicsEnabler=No - Duckweed or Gibba buffer

 

So far I have gotten every boot loader to get to the point where it tries to load up Windowserver and the frame-buffer... which then flickers and stays at verbose screen. I am pretty sure it has to do with the 6800 kexts. On Safemode boot I get the wonderful white screen with nothing displayed. I can go to my firmware and set iGPU as default and boot -x to the desktop (even the Radeon GPU gets detected and brought up in that case. Normal booting with iGPU and no safemode switch results in same issue as before.

I have gone through several threads so far and saw disabling the iGPU helps some people, not an option for me since its a Thunderbolt board with no disable option. I have also seen recommendations injecting IDs, but no instructions how and I have never needed to modify the kext before to add dev ids or more definitions. I have seen people having SSD issues with this update but am not getting any AHCI/SATA/etc errors or issues at any point. Also have tried different smbios defs like MP3,1 and iMac13,1 with no improvement.

Any ideas? A bit frustrated since all I ever had to do with the last update was do a ssdt if I wanted to over clock.

 

P.S. Can include a DarwinDumper if requested.

 

[update] Ok, once again I am disgusted with myself because I fixed the issue without any dramatic DSDT edits or plist hacking. All one has to do to disable the iGPU on the Asus bored is switch the default graphics to PCIE from Auto and disable the two iGPU options for fast standby (or whatever its called) and the display virtualization option in the firmware. I feel so stupid. x.x

Also as an added bonus I grabbed the generic USBXHCI kext that is being developed on the site and now all of my USB ports are being detected and brought up properly. Now I just have to figure out my Thunderbolt, why AirplayMirroring isn't working, and figure out how to get the BCM20702A0 working.

 

For the record if you are having similar problems just go under System Agents and switch to PCIE and disable the other iGPU options. Dont think you need to set a frame-buffer or ports in boot.plist but I did anyways. Graphics Enabler is still set to No.

Share this post


Link to post
Share on other sites
Advertisement

Hi!

 

Perhaps it will work with a dual-card setup: http://www.insanelym...-the-same-time/

 

All the best!

Thanks for the idea, its tempting, but honstly I want it to just work and dont feel like crawling under my desk swapping cards any more then I have to. Just out of curiocity do you have AirPlay mirroring working? Does that require the iGPU to function?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×