Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Aidass

[SOLVED] Legendary "still waiting for root device" error

1 post in this topic

Recommended Posts

Hey guys. So I've installed ML into my asus n53sm(i5-2450m, hd3000+630m) everything went well, installed all needed kexts, dsdts, ssdts and etc.

After using few days I've decided to fiddle with the optimus technology as I've seen someone getting it working. So I started playing with different dsdts and kexts, after some experiments I've started to get KP's at boot, so I was unable to boot into single user mode and as my USB stick with ML installation isn't working anymore, I had no choice, just booting up Ubuntu.

So I've mounted my hfs+ partition in ubuntu, tried reverting the changes - unluckily. As I got bored to search for the same websites everytime I boot ubuntu, I decided to install it. Some time later I finally managed to revert all changes to OSX, configure GRUB2 to boot chimera, aaaaand I started to get "Still waiting for root device" thingy...

Things I've tried:

1)fiddling with BIOS

2)rd=diskXsY

3)countless other boot options

4)changing AHCI kexts

5)trying to repair kext permissions from linux (dunno if that works)

 

So, what would your suggestions be? btw, here's list of kext's I used when I was trying to get optimus working:

AppleAHCIPort.kext
AppleHWSensor.kext
AppleIntelHD3000Graphics.kext
AppleIntelSNBGraphicsFB.kext
AppleLPC.kext
AppleMCCSControl.kext
AppleSDXC.kext
AppleUpstreamUserClient.kext
GeForce.kext
IO80211Family.kext
IOAHCIFamily.kext
IONetworkingFamily.kext
IOPlatformPluginFamily.kext
IOUSBFamily.kext
NVDAResman.kext
PXHCD.kext

I have removed new or restored original kexts afterwards, but anyways.

 

edit:shoot, this should be in post-installation section...

 

edit2: managed to create bootable usb install from linux, repaired permissions and disk, everything works fine!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×