Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.

Recommended Posts

I feel like it is 2007/2008 again .... I'm struggling with this almost whole week:

Supermicro X8DAE

Xeon 5530 x 2

Nvidia GTX 570

24GB RAM

SSD for OS

 

- Installation went smoothly, like many times before with different configurations (however this is my first dual Xeon build)

- After restart I see that I can barely interact with UI. Terrible lag and completely unresponsive. Ok .... looks like GPU issue, although that is very strange because the same GPU works W/O issues on X58A-UD3R and Z77X-UP5TH (GraphicsEnabler=yes).

- Safe mode (-x), boots fine, both CPUs are there, RAM ..... good.

- For troubleshooting I deleted GeForce.kext, reboot. System boots fine (of course with crippled graphics), but there is no lag and freezing. Definitely looks like GPU issue.

- Edited AGPM.kext (device ID and threshold), than fakesmc.kext to match Mac Pro 5.1 system definition. Installed GeForce.kext back, reboot. Result - just a bit less lag and freezing, but far, far from normal.

- Again safe boot, system boots fine, no lag.

- OK, maybe I'm going mad .... pulled out GTX 570, installed GTX 285 (also from other working system), edited AGPM.kext accordingly. Result - same lag and freezing.

- Back in with GTX 570. I installed Windows (just to check that there are no hardware issues with MB). Everything works great.

- Formated drive (to avoid temptation of the dark side :) )

- Reinstalled OS X with Mac Pro 3.1 definition this time (to avoid AGPM). Result - even more freezing.

- Back to Mac Pro 5.1, GraphicsEnabler=no, GPU injection via DSDT .... no luck.

- Various tests with different BIOS options,.... nothing

 

What ever I try, with any GPU, I always have lag and freezing. Safe boot and booting without GeForce.kext are fine. I have read countless threads trying to find solution, but W/O success.

 

I'm probably overlooking something obvious .... but WHAT?

Any help would be much appreciated.

 

Kext used:

fakesmc

hnak's e1000 (for intel network adapters)

 

DSDT attached

Share this post


Link to post
Share on other sites
Advertisement

Yes, it has to work with GraphicsEnabler, and absolutely the same card IS working that way in two other hacks. Now, in this build I get terrible lag and freezing (please note that I don't have kernel panics or black screen),....scrolling, opening finder window, any simple operation takes minimum 5-6 seconds. I have already tried retail drivers but results were the same.

With DSDT injection (according to instructions from your site) I get black screen.

Share this post


Link to post
Share on other sites

Update:

I have realised that there was a mistake in my DSDT (when I was trying DSDT injection). I've corrected that, DSDT GPU injection worked, but the result was the same (almost frozen UI with terrible lag).

Patched DSDT:

https://dl.dropbox.com/u/3436683/DSDT.aml

Original extracted DSDT:

https://dl.dropbox.com/u/3436683/DSDTraw.aml

If somebody could take a look that would be great. I'm slowly losing hope :( This whole situation is completely confusing.

Share this post


Link to post
Share on other sites

I'm still struggling with this, and I have to check that I'm not mad:

- If there is no lag / freeze when I delete GeForce.kext and boot normally, that's definitely GPU issue, right? It can't be anything else?

- If I get the same lag / freeze with GraphicsEnabler=yes or DSDT edit + all possible bootloaders, problem is somewhere in settings (AGPM or somewhere else)?

- If the same card/s work in couple different hacks, and the same configuration is working well with Windows, there is no hardware error?

 

So .... if the GPU is proven to work (as it is), and installation went without any issues, and when I'm getting almost 14000 Geekbench score with this setup (on OS X), why the hell I have slow motion UI :)

Share this post


Link to post
Share on other sites

Yeeeeees! It worked ..... Netkas IOPCIFamily.kext (for Mountain Lion).

Now let see if this can be fixed with DSDT edits instead of replacing IOPCIFamily.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×