Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.

[SOLVED] Really weird Realtek 8168 problem

Recommended Posts



Having a super unusual (possibly unique) problem with my network adapter here. Been up down half a dozen forums with no hits.


This morning, I had a perfectly functional 10.8.2 installation. The internet was working just fine with Lnx2Mac Realtek kext. There were, however, some intermittent connection drops and packet loss problems. I isolated the problem to OSX by checking similar behavior on my Windows partition and my laptop (Windows/Linux dualboot). So then I decided to see if I could fix the issue by trying out a different kext.


After backing both the Lnx2Mac and the IONetworkingFamily kexts, I uninstalled the Lnx2Mac kext, replaced it with Slide's newly released R1000SL. Repaired permissions, rebuilt the cache and rebooted. Internet stopped working. I just replaced the backed up files, rebooted to regain the internet, and when I came back in, internet still wasn't working.


Now the really weird part is that, OSX still thinks that there's an Ethernet connection active even when I unplug the cable. In network settings, the Ethernet connection is shown as "Connected". It has an IP address (169.254.134.{censored}) and a Subnet Mask ( However, it doesn't have an IP for the Router, or the DNS Server, or the Search Domains. Sure enough, when I check my router's connected devices page, my Hackintosh isn't visible there either. These settings don't change when I unplug the ethernet cable. The computer still thinks it's connected.


I've never seen anything like this in my life. Can't figure out how to fix this for the life of me. I tried everything, including restoring kexts from my installation USB. No success whatsoever.


If someone can point me in the right direction, I would really appreciate it. I can provide an IOReg output if that's going to be helpful. Just let me know.



- Core i7 2600K 3.5GHz

- ASRock P67 Extreme4 Gen3 (Realtek RTL8168 on-board)

- Gigabyte nVidia GTX 680



Share this post

Link to post
Share on other sites

disable in bios LAN and bootup with -f .. now reboot and enable in bios and boot with -f again.


likely caches or permissions issue

Share this post

Link to post
Share on other sites

Yeah it occurred to me that might fix it. I'm in the process of doing a CMOS reset and reconfiguring the BiOS right now. Will post an update afterwards whether it worked or not.


Yeah, confirming that CMOS reset did in fact solve this issue. Awesome.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.