Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Sign in to follow this  
NBS

Very strange issue with GMA950 64 bit drivers on ML

Recommended Posts

For the past couple of days I've been trying, unsuccessfully, to get the graphics working properly on my new tablet PC. It's a Lifebook (1.83Ghz C2D) which unfortunately has the old GMA 950 graphics. But, apparently, there are drivers from Snow Leopard for it. 64 bit drivers. Since Mountain Lion cannot use 32 bit drivers. Anyway. I have installed the 64 bit SL drivers and, no matter what I do, I cannot get it to work with these drivers. The machine WILL work as long as I don't have any drivers installed, but then the there is flickering and the resolution limited to 1024x768. When I have the 64 bit SL drivers installed, I get a 3/4 white and 1/4 screen upon boot. I've tried -v, -x, -f GraphicsEnabler=No/Yes, same thing. The system is running, it's not frozen, if I hit the volume keys I can hear the chirps, but I can't see anything (except the black/white screen). Occasionally, when I use GraphicsEnabler=Yes, it will give me an entirely white screen instead of half black/half white. I have searched all over the internet and cannot find anyone with a similar issue to mine. I don't understand why it will not work, its supposed to work on Mountain Lion and its 64 bit and many other people have had success using these very drivers on their system with Mountain Lion. I've tried on 10.8 and 10.8.2, same thing on both.

 

Now, here's what's really strange. I reinstalled the OS and installed the graphics drivers right afterwards then booted and the OS X setup actually ran and it actually worked, proving the drivers do work on my system! I had the GMA950 drivers functioning on my system and higher resolutions and all that good stuff was available. Until I restarted. Then the black/white screen started again, and I have not been able to get it to run again. Haven't tried reinstalling again so I'm not sure if it will work again if I do. And I didn't change any settings either, just went through the setup and rebooted. And its not working again.

Specs:

Fujitsu LifeBook T4215

Core 2 Duo T5600 (1.83GHz)

GMA 950 graphics

Install method:

Mountain Lion app from AppStore + myHack method

I have to use a patched IOPCIFamily kext to get passed the popular [PCI Configuration] issue.

Share this post


Link to post
Share on other sites
Advertisement

I think this topic should be accounting like a Wiki: why it is not possible to install 10.8 on computer with GMA950.

I want just confirm. Yes. You are restricted to 10.7.5 in 32bit mode. See my signature.

 

For me sleep/wake is more important then iCloud integration into TextEdit.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Posts

    •   Sadly the relevent information is between these 2 pictures.   I know there is a dont reboot on panic flag in Clover which might help you taking a better picture.   [mention=1166456]Allan[/mention] or other might have more experiences than I with High Sierra and laptop as I have none   Envoyé de mon PH-1 en utilisant Tapatalk      
    • Oh okay so should I still go ahead with your first suggestion then? 
    • Well this is what I got: Displays: Framebuffer: 0x2BC4E780 Size: 1600x900 Depth bits Per Pixel: 24 Depth bits Per Sample: 8 Depth is Planar: false Frame: (0.0, 0.0, 1600.0, 900.0) Visible Frame: (37.0, 0.0, 1563.0, 877.0) Depth backing Scale Factor: 1.0 Name: Display Vendor Id: 0x6AF (1711) Product Id: 0x139E (5022) Year Of Manufacture: 2013 Week of Manufacture: 17 Blue Point X: 0.150390625 Blue Point Y: 0.0595703125 Green Point Y: 0.3251953125 Green Point Y: 0.5703125 Red Point X: 0.6201171875 Red Point Y: 0.33984375 White Point X: 0.3134765625 White Point Y: 0.3291015625 White Gamma: 2.20000004768372 Brightness Affects Gamma: true Horizontal Image Size: 380 Vertical Image Size: 210 Has Back light: true Is Digital: true Is HDMI Sink: false EDID data: 0x00, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0x00, 0x06, 0xAF, 0x9E, 0x13, 0x00, 0x00, 0x00, 0x00, 0x01, 0x13, 0x01, 0x03, 0x80, 0x26, 0x15, 0x78, 0x0A, 0xC4, 0x95, 0x9E, 0x57, 0x53, 0x92, 0x26, 0x0F, 0x50, 0x54, 0x00, 0x00, 0x00, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x1C, 0x2A, 0x40, 0x6E, 0x61, 0x84, 0x0C, 0x30, 0x30, 0x20, 0x36, 0x00, 0x7E, 0xD6, 0x10, 0x00, 0x00, 0x18, 0x00, 0x00, 0x00, 0x0F, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x20, 0x00, 0x00, 0x00, 0xFE, 0x00, 0x41, 0x55, 0x4F, 0x0A, 0x20, 0x20, 0x20, 0x20, 0x20, 0x20, 0x20, 0x20, 0x20, 0x00, 0x00, 0x00, 0xFE, 0x00, 0x42, 0x31, 0x37, 0x33, 0x52, 0x57, 0x30, 0x31, 0x20, 0x56, 0x33, 0x20, 0x0A, 0x00, 0x24 next step is to integrate relative code in the app
    • Anyone with 3d envy can share his dsdt?
×