Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.

White Screen - SAPPHIRE VAPOR-X HD 4890 2GB

Recommended Posts

Hey I have a full working System running OSX 10.7.4 on Gigabyte UD5 MOBO, and an Nvidia GT520 graphic card.. working really perfect since over a year..


No I changed the GT520 to an SAPPHIRE VAPOR-X HD 4890 2GB.. the System is booting up, but hangs on a white screen exactly before the login screen appears..


and the boodloader is flashing something like: Bad display config Block signature for a second or so, before switching to the apple logo with the spinning wheel...


also tried to boot -v -x

last line is:

DSMOS has arrived
//but nothing is coming up


and I also see a line:

NVDAGF100HAL loaded and registered.
//isn't this an Nvidia Driver thing ?

Share this post

Link to post
Share on other sites

Remove Graphics Kext: boot whit -s

mount -uw /

rm -rf /System/Library/Extensions/GeForce.kext

rm -rf /System/Library/Extensions/Ge*.kext

rm -rf /System/Library/Extensions/NVDA*kext


rm -r /System/Library/Extensions/Extensions.mkext

cd /

shutdown -r now

Share this post

Link to post
Share on other sites

ok did it exactly like this just the /System/Library/Extensions/Extensions.mkext

wasn't there.. then I boot it with -f -v but it still come not up last line:


vnic0: promiscuous mode enable failed
vnic1: promiscuous mode enable failed
/drv/ HypIoctls.c:779  Ioctl VT-d status: 0


by booting up without a command it keeps hanging after a while spinning exectly there where the login screen should appear.. and shows this reboot screen with the big switchoff symbol in the background... ?

Share this post

Link to post
Share on other sites

I have installed now the 48xxExotic10-7-4 hdmi kexts into System/Library/Extensions/ and I deleted the Extensions.mkext from the Extra folder + Insert into the org.chameleon.Boot.plist this lines

<key>Graphics Mode</key>

but no effect here is the screenshot where it hangs:


Share this post

Link to post
Share on other sites

It can not be a big thing ? I set Graphics Mode to No and system boots up perfectly, I repaired system premissions and set back to Graphics Mode Yes, System Boot but don't show the screen (hangs at the apple logo)... so no I simply type in my password and hit enter without seeing anything.. and now this computer appears in the Network (can access with my Macbook onto).. so means that the system is running and up but just no graphic displayed... ??


what can I do...

Share this post

Link to post
Share on other sites

well I got it so far.. I didn't clean the kext cache.. now everything is working.. just the System Profiler shows 1GB instate of two... how can I personality edit the card... by the way the guys use this card.. is there a way to use DVI (Master Display) HDMI (Second Display).. and maybe the VGA as 3 Display ?


for now just DVI and VGA works separately for Dual Display... (didn't tried the display port)...

Share this post

Link to post
Share on other sites

Chameleon started adding basic recognition sometime around r1980 or so for this card, I have one and supplied the info for it. It's still a reasonable card for my use.


The regular patched QE/CI exotic drivers have always worked fine for me. I have hacked the personalities to support simultaneous dual-link DVI+HDMI displays.


Scroll down for my patched drivers: http://www.insanelymac.com/forum/topic/258665-how-to-enable-hdmi-dp-dvi-output-on-ati-4890-4870-4850-4830-series-testing/page__st__20

Share this post

Link to post
Share on other sites

@ Nolis: I'm in the same boat as you; I keep getting this same error in Verbose mode:


/drv/ Hyploctls.c:779 loctl VT-d status:0


You can take a look at my thread below:




Were you able to solve this issue? Any feedback would be well appreciated. Thanks.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.