Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Nemorosus

Installing Mountain Lion on Fujitsu Lifebook AH530-GFX (With almost everything working!)

3 posts in this topic

Recommended Posts

Okay. I am finally, finally glad to successfully install Mountain Lion on my laptop. This is the first time i get this kind of responce from the OS. I previously written an guide for the same laptop but different distro (click here, Niresh12495 - but i do not reccommend it.) So after this i've got some hope, because that was the first time getting native resolution on my graphics card (Mobility 4650HD with 1GB RAM, downclocked and rebranded into 550v). But i tried, and tried and nothing helped. The problem was that {censored} distribution, it couldn't update successfully, so it showed that my OS X is 10.8.2, but i wasn't able to run all the Apple software (iTunes, appStore...) after the update! When i installed the kext for my ATI i got the resolution, but no hardware support at all! It was choppy, oh boy.

 

So i got back to Windows 7 dissapointed, and waiting to get my new computer (i've installed Hackintosh previously on a computer, I am a proud owner of one of the most-compatible hackintosh motherboards, the P5KPL-AM SE) or someone to make a driver. Previously i have always installed iAtkos, but this time when i tried the Niresh distro, the Mountain Lion version of iAtkos wasn't out. So i waited and few days ago i needed to do some music, and i was tired of my hard disk speed in Windows. I defragmented that {censored}, i formatted it but nothing works. My whole operating system was falling appart. So one day I got to my uncle to see why his laptop wasn't booting up (the RAM wasn't set up properly if you're curious) and he just gave me an 8GB Sony USB. I first refused, because i seriously don't need USBs, i eventually loose them, or not even use them at all. But at one point i remembered that i can install an OS to an USB, and my first thought was OS X, of course. BTW i installed Chrome OS on the usb at first, but it failed with a Kernel Panic, lol. What a story teller I am. But these are 3 years trying to get hackintosh working, and now i am writing this on my laptop! Oh boy. I had many many problems with 'burning' the OS X iAtkos image onto the USB drive. My whole day was free so i descided i'll keep on doing it untill i come up with a solution. So firstly i tried on Windows burning it with PowerISO (a great tool btw), but it didn't boot. This was probaby because i needed to install Chameleon bootloader into the usb, and the only way to do that is by the Disk Utility in OS X. So i downloaded Virtualbox, because it's free, and i didn't have time for cracking right now. I installed iAtkos and i always got Resource busy errors when trying to "restore" my image onto the usb. So i thought this was probably because the USB is connected by software (its connected to a Windows machine and simulated trough Virtualbox onto OS X). So i formated my hard disk and went for iAtkos L (Lion) so i can get a raw Mac OS installation on my laptop so i can restore the image onto the USB disk. Firstly it didn't want to restore, but there was a fix... you'll make it, you have to restore the mounted image onto the USB disk, or something like that. Doesn't matter. I than installed Chameleon on the USB with no problem. Restarted my laptop, and booted successfully from the USB! Wohoo! The installation process was very very very fast! It took 15 or less minutes to install it. I choose nothing specific from the drivers list, audio and network was auto-recognized by iAtkos drivers bundles, i only selected PS/2 and some other minor {censored}.

 

So it installed very fast. I even thought that there was an error and it wouldn't boot because of this. But everything went smooth. I installed

this driver for the graphics card: http://www.osx86.net...for_10._...html

and it worked! Previously with the Niresh distro i've got only full resolution, but now for the first time i have seen the transparency in the menubar. I was so excited, haha! Everything working out of the box btw. Camera, card reader, audio, wifi, ethernet, usb. What else... Oh yeah, the battery indicator, i can't get to work. Sometimes my usb mouse is bugging, my left click is constantly clicking but it is a glitch and it fixes itself after a short period of time.

 

If you need any help with Hackintosh, don't ask me. I am a total noob. But i wasn't asking all the time for drivers, i was looking for solutions. 3 years. I am posting this "boring" (probably) post showing you that there is hope for you and your little machine!

 

From non-functional Hackintosh laptop, i've got everything working. And the solution is always the same: patience and time.

 

Thanks!

 

p.s. busratio=22 makes things so much faster. Just sayin'

 

50c6a145b6fd438185ff5d4.png

Share this post


Link to post
Share on other sites

Another update.

I now don't use busratio as it is the fastest, using it seems kinda like giving my machine a bottleneck. I still am not able to receive the battery indicator or the trackpad working correctly (its working like a mouse, no multi-touch). Also the sleep doesn't work with KextEnabler. I haven't tried other things to patch the sleep as i don't know how to do those. Today i found out that the HDMI port is working! :) That is great news, full 1080p on my aunts TV. Pretty neat. Unfortunately the VGA port does not work :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×