Jump to content
InsanelyMac Forum
srkie

DSDT MSI MS-7525

Recommended Posts

Buenas tardes,

 

tengo un Compaq Presario sr5412ES. Que lleva:

 

Procesador Intel Core 2 Duo E2160

Placa Base MSI MS-7525

2gb Ram DDR2

Sonido ALC662

Ethernet Realtek RTL9101E

 

Tengo problemas a la hora de generar el dsdt para osx86. Lo saque por medio de Aida64 pero tengo problemas porque no hay un dsdt generado para usar con el autopatcher y soy un poco novato aun como para editarlo yo. Además con el "DSDT Editor and patcher" me saca un montón de errores al compilar y no se bien que parches usar.

 

Antes de esto comentar que como soy novato en este tema, he usado varios dsdt para la misma placa encontré por Internet pero no me valen se cuelga (supongo que porque el hardware no es exactamente igual)

 

Me podría echar alguien una mano? Sobre todo para saber porque deja de funcionar el teclado y la ethernet?

 

Muchas gracias de antemano.

 

EDIT: corregido, creo que ya esta bien.

Share this post


Link to post
Share on other sites
Advertisement

hola srkie, welcome to insanelymac, post tu DSDT.bin from AIDA en una carpeta zip, te lo voy a mirar si puedo compilar y aplicar los patches, use un boot cd linux en la teminal use este comando, lspci -nn y postea el resultado.

 

 

 

Edit: no te olvides de leer las reglas del forum, no tonymac here please, edit your post.

Share this post


Link to post
Share on other sites

Me sale lo siguiente con el lspci -nn:

 

-------------------------------------------------------

00:00.0 Host bridge [0600]: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller [8086:29c0] (rev 10)

00:01.0 PCI bridge [0604]: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port [8086:29c1] (rev 10)

00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 01)

00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 01)

00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 01)

00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 01)

00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 01)

00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 01)

00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 01)

00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev e1)

00:1f.0 ISA bridge [0601]: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge [8086:27b8] (rev 01)

00:1f.2 IDE interface [0101]: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller [8086:27c0] (rev 01)

00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086:27da] (rev 01)

01:00.0 VGA compatible controller [0300]: nVidia Corporation G86 [GeForce 8500 GT] [10de:0421] (rev a1)

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 01)

03:00.0 Communication controller [0780]: Tiger Jet Network Inc. Tiger3XX Modem/ISDN interface [e159:0001]

--------------------------------------------

 

 

Muchas gracias de antemano.

Share this post


Link to post
Share on other sites

Voy!! que como estaba en ubuntu live no sabia como comprimirlo que lo tenia en 7z :D

 

He probado varías cosas y añadir algunos kexts... pero ha sido a peor dejando de funcionar teclado ps2 y tarjeta ethernet :)

 

Muchas gracias de nuevo.

acpi_dsdt.zip

Share this post


Link to post
Share on other sites

me recomiendas algún bootloader en concreto? Y que haga algunas comprobaciones típicas a parte de comprobar Ethernet y teclado?

 

De veras, muchas gracias.

Share this post


Link to post
Share on other sites

No hay manera :(. Instale bootloader de enoch coloque el dsdt en la raíz y no arranca. Sale la pantalla y al momento me sale como un mensaje de que apague del botón y vuelva a encender. Por si acaso prole con chameleon y tampoco. Lo raro es que desde el usb si me arranca sin problemas y rápido. Que podrá ser? ah y en verbosa me sale lo de "pci configuration begin" para lo cual modifique unas lineas en el dsdt pero no surgieron efecto. Alguna idea? Como siempre muchas gracias por la ayuda.

Share this post


Link to post
Share on other sites

esto no es problema del bootloader, lo que nescessita es editar los kexts NVDA com el device id de tu graphics, y poner bel boot plist el correcto PCIRootUID de tu card, también puede ser el kext Geforce que te de este problema, prueba deletar de S/L/E , primero respalda.

 

EDIT: el DSDT.aml lo tienes que poner in Extra

Share this post


Link to post
Share on other sites

ya he conseguido averiguar de donde viene el fallo. Arranque con "GraphicsEnabler=yes PCIRoot=0 npcio=0x2000 -v". Y el error es un panic por hpet. El caso es que en el boot.plist esta configurado y reañadido un patch de newhpet... pero persiste.

Share this post


Link to post
Share on other sites

ForceHPET=Yes ...para los problemas de HPET (tiene que estar en 64-bit en la BIOS), incompatible o mal configurado en la DSDT. Saludos.

Share this post


Link to post
Share on other sites

Me esta dando mucho problemas. Tengo configurado el forcHPET=yes pero no hay manera. Parcheado el dsdt con el dsdt editor, tanto el patch hpet como con uno que pone newhpet y sigue igual. Además mi placa al ser una de hp compaq esta capada por todos lados, no hay opción para hpet. Gracias. Si se os ocurre algo, yo sigo investigando.

Share this post


Link to post
Share on other sites

Aplica el "Fix de las IRQs", que involucra al dispositivo HPET, éste necesita al menos las IRQs 0 y 8 para ser compatible con OS X. Así como RTC, IPIC y TIMR, las cuales transfieren sus propias IRQs hacia HPET (8, 2 y 0 respectivamente), quedando éstas tres sin IRQs asignadas... y HPET como debe ser.

Share this post


Link to post
Share on other sites

buaaaaaaaaaa... cuando crei que estaba todo... actualizo fakesmc a su ultima version y deja de funcionar teclado, ethernet, grafica... no se por que puede ser si estaba funcionando :|

Share this post


Link to post
Share on other sites

Caché corrupta? Reconstruye caché con kext utility (indispensable utilizar la version 2.5.1 si estas en ML 10.8), también puedes instalar extensiones con dicha utilidad o alguna otra como kext wizard, etc, que sea reconocida. De igual manera cabe recordar que es recomendable estar siempre actualizado con las últimas versiones de aplicaciones tan importantes como kext utility (creada por cVaD). En ese sentido, kext helper por ejemplo, ya esta obsoleta y puede crear conflictos. Otro punto, luego de hacer cambios en /S/L/E es sumamente importante reparar permisos con la UTILIDAD DE DISCOS. En conclusión, siempre haz lo mismo cada vez que instales y/o elimines extensiones (.kexts). Vamos compañero, que son cosas básicas / elementales en el Hackintosh, y en Mac OS X en general. Por favor trata de buscar información en el foro sobre conceptos básicos. Ah, y la firma por favor. Gracias.

Share this post


Link to post
Share on other sites

Al fin!!! Todo funcionando y bien detectado, en principio claro... :D.

 

Solo una cosa, el lector/grabador de dvds aleatoriamente suena como si acabase de encender el pc, os suena de algo?

Share this post


Link to post
Share on other sites

Estas preguntando muchas cosas que tienen respuestas en el foro, busca por favor antes de seguir en esa onda. Ademas continuas mezclando temas en este topico que es sobre DSDT. Por lo tanto, por favor léete las reglas del foro en español para que tengas mas claro el contexto de como funcionan las cosas aca. Saludos.

Share this post


Link to post
Share on other sites

pues yo no lo he visto y si que he buscado pero ok xd

 

X cierto que sin animo de entrar a discusiones... las supuestas soluciones que me hayas podido dar tu en el post anterior ya las habia probado sin solucionarse, por eso pregunte.

 

Aunque no lo creas busco e intento hacer cosas antes de marearos. Aunque a veces este un poco atontado... q recién he visto que que en el foro de Español... hay post abajo... q yo estaba pensando que solo era en los subforos... lo mismo no estoy bobo no... :D

 

Por cierto, respecto al problema... supongo que es un patch para AHCI Sata pero si pongo este como leí en algún sitiio me deja de reconocer los SATA... seguire buscando pero si no es molestia y sabes cual es, te agradeceria que me lo dijeses.

 

Muchas gracias y sorry por estar tan embobado... q así no encontraba las reglas del foro... ¬¬

Share this post


Link to post
Share on other sites

Hola que tal. Esa placa lleva chipset G31 y controladora sata ICH7. Ahora bien, qué versión de Mac OS X tienes actualmente? Por favor tu firma.

 

En fin, el parche SATA en la DSDT funciona perfectamente, mira este breve comentario: CLICK AQUÍ

 

Se trata del famoso parche ESB2 AHCI universal para controladoras sata incompatibles, aplicado desde el 2009 a la fecha. Consiste en inyectar el ID del dispositivo nativo (ESB2) dentro del dispositivo SATA (Device SATA). Se agrega antes de su ultima llave de cierre así:

Device (SATA)
{
Name (_ADR, 0x001F0002) /* ruta o dirección (adress) segun ioreg*/
Name (^NATA, Package (0x01)
{
/*...*/
/*.... todo el resto del código original se respeta, y antes de su ultima llave de cierre va la inyección como sigue*/
/*...*/

Method (_DSM, 4, NotSerialized) /*comienzo de la inyección*/
{
Store (Package (0x02)
{
"device-id",
Buffer (0x04)
{
0x81, 0x26, 0x00, 0x00 /* id de dispositivo nativo ESB2*/
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
} /* fin de la inyección*/
} /* fin del dispositivo SATA, esta es su ultima llave de cierre*/

Nota: Requiere el método DTGP.

P.D. si no sabes hacerlo subeme tu dsdt.aml actual y tu .ioreg, y te lo aplico que es sumamente sencillo. Saludos.

Share this post


Link to post
Share on other sites

Solo una cosa, el lector/grabador de dvds aleatoriamente suena como si acabase de encender el pc, os suena de algo?

Si por supuesto, me suena a aquellos tiempos de principios del Hackintosh. Fin del off-topic.

Captura de pantalla 2013-02-19 a la(s) 22.28.14.png

Share this post


Link to post
Share on other sites

Voy a investigar lo de los SATA en el dsdt. Es que como reinstale me puse a trastear yo mismo con el dsdt y puse con el DSDT editor un parche llamado "AHCI SATA orange icon.txt" y dejaba de reconocerme el hd interno y el lector (tal vez por no editar ciertas cosas, no lo se). Respecto a lo otro, sorry, pensé que sería algo mas complejo... lo del hd interno imagine que seria algo así porque entraba en reposo y solo cuando lo utilizaba volvía a despertar... pero lo del lector me trajo un poco loco, porque cada X tiempo se ponía solo a funcionar sin yo utilizarlo ni nada de eso.

 

Gracias por todo y perdón si sonó mi respuesta un poco mal, pero es que ando muy perdido y aunque no lo creas si que leo y me metí en mil webs mirando cosas sobre lo del lector, también con el ALC662 (que yo creía al principio que con inyectar el parche con el dsdt editor ya funcionaria) y bastantes cosas.

 

De verdad, que aunque no lo parezca antes de preguntar busco!!!

 

PD: ya esta la firma!!! :)

Share this post


Link to post
Share on other sites

He revisado el dsdt... y es que no tengo el "Device SATA"... por eso aunque inyecto el parche con el dsdt editor no funciona y deja de detectar ambas unidades... cuando inyecto el patch lo pone dentro del device DRV1.

 

Device (DRV1)
{
Name (_ADR, One)
Name (H15F, Zero)
Method (_GTF, 0, NotSerialized)
{
Store (^^^^ICHX.GTF1 (ITM1, SIT1, UDC1, UDT1, ICF1, H15F, FAS1), Local0)
Concatenate (Local0, Buffer (0x07)
{
0x00, 0x00, 0x00, 0x00, 0x00, 0xB0, 0xF5
}, Local5)
Return (Local5)
}
}
}
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x02)
{
"device-id",
Buffer (0x04)
{
0x81, 0x26, 0x00, 0x00
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}

 

Sigo investigando, era solo por comentarte porque creo que me deja de funcionar!!! :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×