Jump to content
InsanelyMac Forum
Sign in to follow this  
Piuma

ASUS ULTRABOOK - A56CM - K56CM - TUTORIAL ML 10.8.2

Recommended Posts

ASUS A56CM – K56CM – TUTORIAL MOUNTAIN LION 10.8.2


  • Andate nel bios e settate i seguenti parametri:


    • Fast Boot: Disabled
    • Boot: Launch CSM
    • USB: Legacy Enabled
    • XHCI: Disabled
    • Secure Boot Control: Disabled

CONSIGLIO DI NON TOCCARE L'OPZIONE “Intel Anti-Theft”

La modifica di quel parametro nel bios, su alcune macchine,

può costringervi a dover mandare il notebook in assistenza.


  • Installate il sistema operativo:


    • Personalmente ho provato con diverse immagini su USB e l'unica che sono riuscito a far partire è un'immagine trovata su torrent.
      Ho provato con una USB creata da una copia legalmente acquistata di ML ma non sono riuscito a completare l'installazione.
    • In base all'immagine o alla distro con cui installerete potrebbe verificarsi il famigerato problema “boot0: error”
      Il problema è risolvibile. Se installate con altre immagini del sistema operativo o con una distro può essere che il problema “boot0: error” non si presenti, nel qual caso semplicemente saltate il punto della guida in cui spiego come risolverlo.


    • Dopo aver preparato la chiavetta, avviate il pc con la chiavetta inserita.
    • All'avvio del pc, quando compare il logo ASUS, premete ESC, dal menù che apparirà scegliete di avviare da chiavetta.
    • Una volta entrati nel processo di installazione, prima di installare, andate in alto su “Utilities” e selezionate “Disk Utility”. A questo punto dovete partizionare il disco (una partizione se volete installare solo OSX, due o più partizioni se volete fare dei multiboot con windows o linux). Importante: prima di partizionare cliccate sul tasto opzioni in basso e selezionate MASTER BOOT RECORD come mappa partizione.
    • Una volta partizionato date il via all'installazione.


  • Configurare il sistema operativo:


    • Terminata l'installazione al primo riavvio il pc si bloccherà se tenterete di entrare nel sistema operativo normalmente, quindi avviate ancora dalla chiavetta di installazione ma senza far partire l'installazione. All'avvio del pc, quando compare il logo ASUS, premete ESC, dal menù che apparirà scegliete di avviare da chiavetta, si presenterà un secondo menù, selezionate la partizione dove avete installato OSX e avviate con bootflag -x (modalità provvisoria)
    • Inserite i dati per la creazione del vostro account utente ma saltate la parte per la configurazione internet, altrimenti il sistema si riavvierà.
    • Ora è il momento di installare l'ultima versione del bootloader Chameleon o Chimera e il FakeSMC.
    • Installate Kext Drop o Kext Wizard e installate tutti i kext che trovate nello zip allegato.
    • Una volta installati non riavviate, andate nel finder, entrate nel vostro disco su cui avete installato OSX (se non compare potete entrarci tramite “disk utility”).
    • Nell'hard disk principale dovrebbero esserci 5 cartelle, a noi interessa quella chiamata “Extra”. Se la cartella “Extra” non c'è, createla manualmente e buttateci dentro tutti i file che troverete nello zip allegato.
    • Verificate di non avere precedentemente installato il kext nullCPU... e se lo avete fatto cancellatelo!
    • Ora aprite il terminale e digitate “sudo -s” (senza virgolette). Vi chiederà la password che avete appena scelto, scrivetela (non apparirà niente ma abbiate fede state scrivendo). A questo punto incollate questa stringa di comandi nel terminale e pigiate invio:

rm -rf /System/Library/Extensions/GeForce.kext

rm -rf /System/Library/Extensions/GeForceGA.plugin

rm -rf /System/Library/Extensions/GeForceGLDriver.bundle

rm -rf /System/Library/Extensions/GeForceVADriver.bundle

rm -rf /System/Library/Extensions/NVDAGF100Hal.kext

rm -rf /System/Library/Extensions/NVDAGK100Hal.kext

rm -rf /System/Library/Extensions/NVDANV50Hal.kext

rm -rf /System/Library/Extensions/NVDAResman.kext

rm -rf /System/Library/Extensions/NVDAStartup.kext


    • A questo punto riparate i permessi (per scaramanzia!) e riavviate.

A questo punto potrebbe presentarsi il famigerato problema “boot0: error” per la cui risoluzione seguite questa guida:

 

http://www.insanelymac.com/forum/topic/285021-risolvere-lerrore-boot-0/?do=findComment&comment=1873521

 

Fatto ciò il sistema dovrebbe avviarsi perfettamente.

 

Se aggiornerete alla versione 10.8.2 sarà poi necessario avviare nuovamente tramite chiavetta usb in modalità provvisoria (-x) e manualmente ripristinare i due kext che troverete nello zip nella cartella rirpistino 10.8.2. Installateli con Kext Drop.

Inoltre dovrete riaprire il terminale e ripetere il punto colorato in blu nella guida.

Riavviate e incrociate le dita.

 

Al momento è impossibile far funzionare il wifi, forse in futuro, consiglio l'acquisto di una chiavetta usb wifi (verificatene prima la compatibilità).

I tasti FN non funzionano, non tutti quantomeno.

Forse i più pignoli, come me, noteranno che lo schermo è poco luminoso, c'è un trick da fare per avere la luminosità massima. Praticamente, non si sa perchè, se lo schermo va in stop e si riaccende ecco che la luminosità è magicamente diventata normale. Quindi consiglio di configurare un angolo dello schermo per “mettere il monitor in stop” quando ci si passa col mouse. Così ad ogni avvio in un secondo avrete la luminosità massima.

Possono presentarsi vari altri problemi durante il processo di installazione e di configurazione troppo lunghi da spiegare. Se avete difficoltà scrivetemi che se posso vi aiuto, buon lavoro ;)

 

TNX TO LEJENK & TONIO1987

K56CM.zip

Share this post


Link to post
Share on other sites
Advertisement

Ciao!

Il problema del boot0 error ,e' dovuto al fatto ke il bootloader nn si installa sul tuo hard disk( ke sicuramente ,sarà da 500 gb o più )...quello è un problema ke puoi risolvere.. C'è una guida di Fabio ke trovi su questo sito,ke sottoscrive la soluzione..prima dovrest occuparti,ke tutte le periferiche vengono riconosciute!

 

Ke procedura stai seguendo x l'installazione ?

Share this post


Link to post
Share on other sites

Ciao, grazie per aver risposto, non mi è chiara la tua domanda. Che tipo di informazioni vuoi sapere?

 

Finora ho proceduto come ho fatto in passato per il mio PC desktop. Una volta installato il sistema ho usato multi beat, selezionato i kext per il mio sistema e usato [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], non avendo un file dsdt.aml per il mio computer.

 

Ho anche provato a installare manualmente i singoli kext e il bootloader senza utilizzare alcun tool di tonymac.

 

Ovviamente il problema del boot è rimasto. Puoi linkarmi la guida a cui accennavi per risolvere il problema? In effetti l'hard disk è di 750gb.

 

edit: Ho trovato la guida di Fabio71, speriamo sia il mio caso, perchè per esempio quando ho installato ml sul fisso con un hard disk da 2 tera, non ho avuto questo problema. boh!

Share this post


Link to post
Share on other sites

Forse il tuo 2 Tb è già " datato " nel senso buono del termine...sicuramente ha già un anno o più...il problema si presenta con quelli di nuova produzione;in quanto i settori dell' hd sono da 4096k contro i vecchi 512kb!

Di conseguenza devi agire cosi :

Scarica boot1h :boot1h.zip

Segui la guida di Fabio ; x come copiare il file sul tuo hard disk : http://www.insanelymac.com/forum/topic/285021-risolvere-lerrore-boot-0/#entry1873521

Se hai problemi con le righe di comando ; ke trovi nella guida prova queste :

sudo dd if=boot1h of=/dev/xdisk0xx ( la x và sostituita con posizione del tuo hd!)

 

Quello che intendevo sulla procedura .... era capire ; se sei riuscito ad installare e avviare ML ; o hai problemi in caricamento;se fai partire con -v che errore hai ?

Serve qualche dato in piu' per aiutarti..

Share this post


Link to post
Share on other sites

Ho risolto il problema del boot0 seguendo la guida di fabio, grazie mille! ;)

 

Ora sono bloccato, ritengo perchè non riesco a far sì che venga riconosciuta la hd4000, sto provando a inserire varie stringhe nel file org.chameleon.boot.plist

ma per ora niente, riesco a entrare nel sistema solo in modalità provvisoria e usando la chiavetta di installazione. La stessa modalità provvisoria non funziona se la lancio col bootloader installato, solo da usb.

Questo mi fa preoccupare e pensare che forse la scheda video non sia l'unico problema.

Share this post


Link to post
Share on other sites

Ciao!

Avviando con - v ; hai visto dove si blocca ?Intanto puoi provare cosi' :

Rimuovi qst kext :

 

 

 

 

 

AMD

- AMDRadeonAccelerator.kext

- AMDRadeonVADriver.bundle

- AMDRadeonX3000GLDriver.bundle

INTEL

- AppleIntelHD3000Graphics.kext

- AppleIntelHD3000GraphicsGA.plugin

- AppleIntelHD3000GraphicsGLDriver.bundle - AppleIntelHD3000GraphicsVADriver.bundle - AppleIntelHD4000Graphics.kext

- AppleIntelHD4000GraphicsGA.plugin

- AppleIntelHD4000GraphicsGLDriver.bundle - AppleIntelHD4000GraphicsVADriver.bundle - AppleIntelHDGraphics.kext

- AppleIntelHDGraphicsFB.kext

- AppleIntelHDGraphicsGA.plugin

- AppleIntelHDGraphicsGLDriver.bundle

- AppleIntelHDGraphicsVADriver.bundle

- AppleIntelIVBVA.bundle

- AppleIntelSNBGraphicsFB.kext

- AppleIntelSNBVA.bundle

ATI

- ATI2400Controller.kext

- ATI2600Controller.kext

- ATI3800Controller.kext

- ATI4600Controller.kext

- ATI4800Controller.kext

- ATI5000Controller.kext

- ATI6000Controller.kext

- ATIFramebuffer.kext

- ATIRadeonX2000.kext

- ATIRadeonX2000GA.plugin

- ATIRadeonX2000GLDriver.bundle - ATIRadeonX2000VADriver.bundle

 

 

 

- ATISupport.kext

 

 

Nvidia

- GeForce.kext

- GeForceGA.plugin

- GeForceGLDriver.bundle - GeForceVADriver.bundle - NVDAGF100Hal.kext

- NVDAGK100Hal.kext

- NVDANV50Hal.kext

- NVDAResman.kext

- NVSMU.kext

 

 

Dopo qst operazione ; RIPARA i permessi e la cache con kext wizard!(operazione FONDAMENTALE!)

Con Chamelon Wizard ; edita org.chamelon.boot.plist e imposta : graphics enabler = yes ; Ethernet built-in

( per il momento prova cosi' );

Poi edita smbios.plist e associa una configurazione mac ,che puo' assomigliare al tuo portatile ( guarda sotto gli ultimi MacBook Pro 9,xx );

RIPARA di nuovo permessi e cache!!

Prova a lanciare il sistema..e vedi se parte in modalità normale.. poi proveremo ad installare i kext grafici!

 

Dimenticavo....che bootloader stai usando?

Share this post


Link to post
Share on other sites

Ciao, nel frattempo ero già riuscito ad entrare tramite boot normale. La soluzione era eliminare tutti i kext GeForce e NVDA e inserire una stringa efi nel file boot.plist

Come bootloader sto usando Enoch ultima versione.

Adesso sto aggiornando alla 10.8.2

 

Ho ancora un paio di problemi, in primis la luminosità dello schermo fissa su valori bassi e non riesco ad alzarla, e in secondo luogo le funzioni sleep e wakeup.

Ho estratto il DSDT.aml "vergine" tramite linux, ma non so da che parte iniziare per editarlo al fine di arrivare la luminosità e lo sleep/wakeup

Share this post


Link to post
Share on other sites

Le schede grafiche sono state riconosciute?Hai l'accelerazione grafica?

Prova ad abilitare i controlli della luminosità schermo cercando il kext AsusHotkeys,cosi' dovrebbe abilitarsi il tasto FN e le varie funzioni tastiera!

Share this post


Link to post
Share on other sites

Si, ho l'accelerazione grafica, viene rilevata la HD4000. Non c'è verso di attivare la gt635m, ma questo credo valga per chiunque al mondo al momento.

Share this post


Link to post
Share on other sites

Sono riuscito a installare quasi tutto, e mi sono anche annotato i passaggi per scrivere un tutorial, ho però ancora un problema grande come una casa. Lo speedstep funziona, ma fà solo due step! Non va oltre i 1798 mhz, in altre parole il turbo boost non funziona, questo processore può arrivare a 3ghz! AIUTO!

Share this post


Link to post
Share on other sites

che smbios usi? tra l'altro se metti l'hardware in firma faciliti il compito a chi ti vuole aiutare ;) . Che processore hai? scaricati aida64 e fai un riepilogo del tuo hardware, probabilmente se metti un smbios diverso te ne riconosce di più

Share this post


Link to post
Share on other sites

che smbios usi? tra l'altro se metti l'hardware in firma faciliti il compito a chi ti vuole aiutare ;) . Che processore hai? scaricati aida64 e fai un riepilogo del tuo hardware, probabilmente se metti un smbios diverso te ne riconosce di più

 

ho risolto, a breve scriverò una guida passo passo per i k56cm e a56kcm, a quel punto spero che se qualcuno noterà qualche passaggio sbagliato o che possa essere fatto meglio me lo farà notare!

Share this post


Link to post
Share on other sites

appena finito a lavoro sono uscito e mi sono fiondato da marcopolo expert a vedere se trovavo un adattatore wireless usb per questo portatile con mountain lion..... beh ho trovato una digicom eccola sul sito http://www.digicom.it/italiano/supporto/driver/UsbWave150Nano.html è quella più piccola. tornato in camera ho installato i driver forniti sul cd di installazione per snow leopard, e indovinate un po? FUNZIONA!!! appena mi sono connesso alla rete ho scaricato i nuovi driver ci sono per tutte le versioni di osx tranne che per mountain lion al contrario di come descritto sul sito. Allora li mi son chiesto: forse quelli per lion vanno benissimo e infatti è stato così. Con 20 € ho il wireless sul mio hackintosh

Share this post


Link to post
Share on other sites

Salve, potreste indicarmi dove trovare i kext aggiornati per Mavericks. Sono riuscito a completare l'installazione e a far funzionare l'accelerazione video, il touchpad e tastiera (tranne i tasti FN). il resto non funziona. 

La mia configurazione:

Asus S56CM  - I5 - 6GB di Ram - Geforce 635 2GB.

Grazie.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By bob.farm3366
      Hi all,
       
      I'm new on this forum but I have some experience installing hackintosh infact I have a hackintosh running El Capitan. I started installing high sierra on my laptop but i encountered some issues. The installer wan't start.
      I attach the EFI partition with logs so that someone could help me.
       
       
      thanks
      clove_high_sierra_bobfarm.zip
    • By Lotrofans
      You can find the English guide here:  http://www.insanelymac.com/forum/topic/304403-guide-install-yosemite-on-asus-k56cm-and-similar-asus-laptops/
      Hallo, hier werde ich Ihnen zeigen, wie Sie Mac OS X Yosemite auf dem Asus K56CM und ähnlichen Laptops installieren.
      Wie Sie Mac OS X auf einem USB-Stick installieren bleibt Ihnen überlassen.
       
      Schritt für Schritt:
       Vorbereiten:
      Wenn Sie noch Windows installiert haben, deaktivieren Sie den 'Schnellstartmodus'. Starten Sie in das BIOS neu und setzen Sie die folgenden Einstellungen: Boot: Launch CMS XHCI: Disabled Secure Boot Control: Disabled USB Legacy: Enabled WARNUNG: Bearbeiten Sie nichts an den: 'INTEL ANTI-THEFT' Einstellungen!
       
       Mac OS X Yosemite Installieren
      Starten Sie ihren Laptop neu. Sobald das Asus Logo erscheint klicken Sie 'ESC' Wählen Sie nun ihren USB-Stick aus. (z.B: 'Vebratim Store 'n Go') Nun sollte Clover oder Chamäleon gestartet sein. Wählen Sie nun USB aus und geben Sie "-x" ein, drücken Sie dann 'Enter' Warten Sie bis der Setup-Assistent gestartet ist. Wählen Sie nun in der Oberen Leiste: 'Dienstprogramme' und Festplattendienstprogramm' aus. Klicken Sie nun ihre Festplatte an, und öffnen den Partition Tab. WARNUNG: HIER WERDEN ALLE DATEN AUF IHRER FESTPLATTE GELÖSCHT! Wählen Sie 1. Partition und klicken dann auf 'Anwenden' Schließen Sie das Festplattendienstprogramm und folgen Sie dem Setup-Assistenten.  Mac OS X 10.10 Einrichten
       
      Wenn die Installation Fertig ist, starten Sie neu. Drücken Sie wieder 'ESC' und starten Erneut vom USB-Stick. Wählen Sie dieses Mal NICHT den Setup-Assistenten sondern ihre Festplatten aus. Geben Sie wieder "-x" ein, und drücken Sie 'Enter'. Warten Sie bis ihr MAC gestartet ist. Folgen Sie dem Benutzer-Assistenten und Melden Sie sich an.  
       Treiber (Kext) installieren:
       
      Laden Sie 'K56CM.zip' herunter. K56CM.zip  
      Starten Sie 'Kext Wizard'
      Wechseln Sie zum 'Installieren' Tab. Ziehen Sie alle Kext aus dem 'Kext' Ordner in die Liste ein. Klicken Sie auf Installieren. Warten Sie... Gehen Sie zurück auf den 'Allgemein' Tab. Und wählen Sie den gesamten Abschnitt 'System/Library/Extensions' aus. Öffnen Sie nun den 'Finder' Gehen Sie in den '/System/Library/Extensions/' Ordner Löschen Sie alle Folgenden Dateien: GeForce.kext • GeForceGA.kext • GeForceGLDriver.bundle • GeForceVADriver.bundle • NVDAGF100Hal.kext • NVDAGK100Hal.kext • NVDAResman.kext • NVDAStartup.kext  
            12. Starten Sie ihren PC neu.
       
       Bootloader Installieren
      Starten Sie erneut vom USB. Starten Sie von Ihrer Festplatte, Sie müssen nun NICHT mehr "-x" eingeben! Melden Sie sich an. Laden Sie sich 'Extra.zip' herunter: https://www.dropbox..../Extra.zip?dl=0 Entpacken Sie Extra.zip Kopieren Sie den Extra Ordner nach: '/' (Ja, nach /) Starten Sie nun neu.  Und was ist mit dem Ton?
       
      Laden Sie sich VoodooHDA.zip herunter.  VoodooHDA.zip  
      Starten Sie den VoodooHDA Installer und Starten Sie neu.      
       Was läuft? Ethernet Bluetooth DVD's brennen und schauen. Musik hören. Trackpad USB Maus Webcam Intel HD4000 Ruhezustand HDMI VGA(Aber ziemlich schlecht)  Und was nicht?
      Realtek Card Reader WiFi ( Kann mit unterstützten Wlan-Chips vertauscht werden) Intern Microphone GT630M Graphics FN Keys  
       Danke an: Piuma für seine alte Anleitung Danke auch an das VoodooHDA Team
       Viel Spaß mit Mac OS X Yosemite  (Mit 10.10.1,10.10.2, 10.10.3 und 10.10.4 PB 1 getestet)
       Eine Youtube-Anleitung ist in Arbeit.
       
    • By leighman
      So I have successfully installed OS X 10.8.4 on my ASUS S56CM, which is a Ivy Bridge Core i7-3517U, Nvidia GT 635M 2gb and 8gb of ram. I have ethernet working but for the life of my I can't get Audio or Graphics or Battery display. I can boot into safe mode with GraphicsEnabler=No -f -x. But if I try to get into MAC OS X I get a black screen after booting. I have tried all the nvidida Kexts i can imagine. I swear my wife is going to leave me if I don't stop. I can see the light at the end of the tunnel I just don't know how to get there.
       
      Does anyone have any suggestions or have completed on one of these Laptops. I have tried the Kexts that are used on a K56CM but must be different because it can't boot. And well Mutlibeast doesn't work either.
       
      Thanks In Advance
       
      Leigh 
×