Jump to content
InsanelyMac Forum

Another 5450 issue

Recommended Posts

Ok go easy on me. I am never touched a mac before this and i have spent a whole day reading and searching.

I have a fully functional build on a optiplex 780 however my 5450 is not getting its kext to load. i have found a number of people having this same problem. and tried to follow some of those guides without much luck. For example this guide here


i have verified my ID(68f9) is in the info.plist from that guide along with trying to add it to other 5450 posts. Most of the time the kext doesnt load however there has been a time or two i have booted into ML and the screen was garbage I could tell i was in but beyond that it was unusable(maybe the kext loaded there?)

the 5450 i am using is an asus silent low profile that has an hdmi a dvi and a vga that has been detached. I am trying to use the DVI port.

Share this post

Link to post
Share on other sites

You are not describing what happens during or after boot. ATI5450 is kind of funny. After the successful initial install, you should have a boot screen of low resolution that the BIOS of the card to which it defaults. Then there are only 2 kexts you need to modify, AMDRadeonAccelerator.kext and ATI5000Controller.kext by adding ID 68f9x1002 to info.plist in the appropriate section. For ATI5000Controller.kext, just add this device ID in IOPCIMatch; for AMDRadeonAccelerator.kext, add ID in Cedar section. Repair permission and reboot. Additionally, use the latest Chameleon with Enabled Graphics.

You should have acceleration. Note that this works for maybe 2 out of 3 connector (DVI, HDMI, or VGA), or if the BIOS of the card is right, all 3 connectors. My card is an off brand and but it supports all 3.

Share this post

Link to post
Share on other sites

Ok so here is my current issue.

Fully working install to 10.8.2 except for the video kext. installed AMDRadeonAccelerator ATI5000Controller that both have my 68f9 in them.

inserted <key>ATIConfig</key>




After reboot i think i get in but i lose monitor input. Possible out of range? the monitor only supports 1680x1050.

booting with -x gives same results



Ok i found another monitor with 1900X1200 and and hdmi port. first tried it with dvi no luck then with hdmi and it worked. and the kext loaded :)

Although it would be convenient to get the dvi cable working. Thoughts?

Share this post

Link to post
Share on other sites

New problem, once again did some searching seeing alot of hits but nothing jumping out at me.

My mouse skips around. Every few seconds its like it hangs or jumps.

Anyone point me in the right direction?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.