Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
fcn

Intel i3 2370M HD 3000 and Mountain Lion 10.8.2

3 posts in this topic

Recommended Posts

Hi,

 

I'm having crashes with HD 3000 (0116) and Mountain Lion 10.8.2. They may be related to ring stall, but I'm not sure. My processor is Intel i3 2370M (http://ark.intel.com...-Cache-2_40-GHz). My boot loader is Chameleon 2.2svn (svn-r2140). I got full resolution and QE/CI by removing AppleIntelFramebufferCapri.kext and editing Info.plist of AppleIntelSNBGraphicsFB.kext (IOPCIPrimaryMatch key changed to 0x1E3A8086 from 0x1C3A8086). I don't have GraphicsEnabler=Yes in my org.chameleon.boot.plist. If I add it, the only difference is my graphics card is recognised as 'Intel HD Graphics 3000 384 MB Shared' instead of 'Intel HD Graphics 3000 384 MB'. I'm using MacBookPro8,2 SMBios. I'm having sudden crashes of WindowServer. Everything is frozen except for the mouse, and I see scrambled areas on screen. If I have music playing it keeps playing, I can move my mouse. Also I can reproduce these symptoms by opening a big (5000x1000) jpg with Preview and trying to make it fullscreen. The crashes occur without any relation to what I'm doing then.

 

I know this is a common issue and people are having similar issues with HD 3000 but also I've seen people claiming it was resolved by updates. I also tried editing AppleIntelSNBGraphicsFB.kext and some related DSDT edits but no go.

 

So I wanted to check if I'm missing something. Any help is appreciated. Also if you can check with a big jpg file it Preview crashes, it would be appreciated too. I'm attaching my DSDT.aml, my SMBios.plist, lspci -vv output from Linux and kernel log from a ring stall.

 

Thanks in advance.

fcn_insanelymac.zip

Edited by fcn

Share this post


Link to post
Share on other sites

Hi,

 

I'm having crashes with HD 3000 (0116) and Mountain Lion 10.8.2. They may be related to ring stall, but I'm not sure. My processor is Intel i3 2370M (http://ark.intel.com...-Cache-2_40-GHz). My boot loader is Chameleon 2.2svn (svn-r2140). I got full resolution and QE/CI by removing AppleIntelFramebufferCapri.kext and editing Info.plist of AppleIntelSNBGraphicsFB.kext (IOPCIPrimaryMatch key changed to 0x1E3A8086 from 0x1C3A8086). I don't have GraphicsEnabler=Yes in my org.chameleon.boot.plist. If I add it, the only difference is my graphics card is recognised as 'Intel HD Graphics 3000 384 MB Shared' instead of 'Intel HD Graphics 3000 384 MB'. I'm using MacBookPro8,2 SMBios. I'm having sudden crashes of WindowServer. Everything is frozen except for the mouse, and I see scrambled areas on screen. If I have music playing it keeps playing, I can move my mouse. Also I can reproduce these symptoms by opening a big (5000x1000) jpg with Preview and trying to make it fullscreen. The crashes occur without any relation to what I'm doing then.

 

I know this is a common issue and people are having similar issues with HD 3000 but also I've seen people claiming it was resolved by updates. I also tried editing AppleIntelSNBGraphicsFB.kext and some related DSDT edits but no go.

 

So I wanted to check if I'm missing something. Any help is appreciated. Also if you can check with a big jpg file it Preview crashes, it would be appreciated too. I'm attaching my DSDT.aml, my SMBios.plist, lspci -vv output from Linux and kernel log from a ring stall.

 

Thanks in advance.

Please put your hardware in signature to get proper support.

 

Have fun.

Share this post


Link to post
Share on other sites

Hi,

 

I'm having crashes with HD 3000 (0116) and Mountain Lion 10.8.2. They may be related to ring stall, but I'm not sure. My processor is Intel i3 2370M (http://ark.intel.com...-Cache-2_40-GHz). My boot loader is Chameleon 2.2svn (svn-r2140). I got full resolution and QE/CI by removing AppleIntelFramebufferCapri.kext and editing Info.plist of AppleIntelSNBGraphicsFB.kext (IOPCIPrimaryMatch key changed to 0x1E3A8086 from 0x1C3A8086). I don't have GraphicsEnabler=Yes in my org.chameleon.boot.plist. If I add it, the only difference is my graphics card is recognised as 'Intel HD Graphics 3000 384 MB Shared' instead of 'Intel HD Graphics 3000 384 MB'. I'm using MacBookPro8,2 SMBios.

 

Usually SMBios for MBP8,1 or 8,3 is used .. give it a try.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×