Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

Need help installing ML *Solved*

14 posts in this topic

Recommended Posts




I've built a pretty serious machine and I'm ready to install Mountain Lion on it.


Here's a list of the stuff, (important stuff anyway)


1: Intel Core i7-3770K Quad-Core Processor 3.5 GHz 8 MB Cache LGA 1155 - BX80637I73770K


1: Gigabyte Intel Z77 LGA 1155 AMD CrossFireX/NVIDIA SLI Dual LAN Dual UEFI BIOS ATX Motherboard GA-Z77X-UD5H


1: Rosewill 1.0 mm Thickness 4U Rackmount Server Chassis, Black Metal/Steel RSV-L4000


1: Corsair Professional Series HX 650 Watt ATX/EPS Modular 80 PLUS Gold (HX650)


1: Corsair Cooling Hydro-Series All-in-One High-Performance Liquid CPU Cooler CWCH60


1: EVGA GeForce GTX 660Ti 2048MB GDDR5 DVI-I, DVI-D, HDMI, DP, SLI Graphics Card (02G-P4-3660-KR) Graphics Cards 02G-P4-3660-KR


1: Asus 24xDVD-RW Serial ATA Internal OEM Drive DRW-24B1ST (Black)


1 set: Corsair Vengeance 32GB (4x8GB) DDR3 1600 MHz (PC3 12800) Desktop Memory (CMZ32GX3M4X1600C10)


1: Seagate ST2000DM001 Barracuda 7200RPM 2 TB SATA 6 GB/s NCQ 64 MB Cache 3.5-Inch Internal Bare Drive


1: OCZ Technology 180GB Agility 3 Series SATA 6Gb/s 2.5-Inch Solid State Drive (SSD) with Max 525MB/s Read and Max 85K IOPS- AGT3-


1: LG Electronics 14x Internal BDXL Blu-Ray Burner Rewriter WH14NS40 - Bulk Drive - Black



My old hackintosh died so I've built a whole new one from scratch.


After it died I borrowed an almost brand new genuine, 100% real Apple iMac from my dad who just got it from my son. Long story... :/




So I have the iMac here, it is running Lion 10.7.5


I went to the Apple store and bought a copy of Mountain Lion. I have the InstallESD.dmg saved in my Applications directory.



I TRIED to follow the directions in here, [GUIDE] A fast and easy way to install Mountain Lion


I downloaded the install.zip package from the link provided.


I have an 8gb pen drive. I formatted it as OSX Journaled and GUID enabled.


I named it "Boot" ( I also tried naming it "MountainLion" as the instructions also suggested. )


I open a terminal and attempt to execute the install command and this is all I get back..



Attaching OS X Mountain Lion...

hdiutil: attach failed - No such file or directory


What am I doing wrong?


Are these directions outdated? Or am I'm just stupid?


Please help me, my beautiful new machine is sitting here with no OS loaded on it...


Thank you.. :)

Share this post

Link to post
Share on other sites


The all-in-one guide to Vanilla OS X Mountain Lion + Chameleon + DSDT for beginners http://www.insanelym...howtopic=280756



I went to download the files from the OSx86.net site and it says I've exceeded my daily download quota and tells me I need to donate money. I've never downloaded from there before, ever.



Share this post

Link to post
Share on other sites

Now I don't know what's going on.. I also tried an alternate method of installing ML and it too failed.

So I did some reading and found that I should look in the /var/log files.


I found a message in there saying that it detected some sort of attempted piracy.. Really?? WTF???


That's where I'm stuck at now.


Here's my problem.


My old hackntosh which died last week WAS running an illicit copy of Lion. But it's DEAD.. It will never run again and it isn't an issue in this situation.


But now I don't understand why it doesn't like that I have a genuine iMac.


Last year my son bought an iMac to use in a small business he tried to start up. He borrowed the money from my dad.

The business didn't work out so he gave the iMac to my dad in leu of cash repayment. Now my dad owns the iMac. (Like he would know how to use it!)


After my hackintosh died about two weeks ago I borrowed the iMac from my dad (how has never even used it or even unboxed it) to hold me over until I could build a new hackintosh.


My dad does not have an Apple account at all of any kind. He's never used an Apple product in his life.

I have an Apple account, I created one years ago when I got an iPhone.

I'm on my 4th iPhone now, I just bought a new iPhone 5 less than a month ago. This new iPhone is tied to my original Apple account.

But on my Apple account I had never purchased OSX before.


Anyway, on this iMac I created a temporary user account to log in but I have supervisor and root privileges.

I log in as me then when I go to the app store it tells me that there are some apps on here that have updates available.

When I try to update them it tells me that this is the wrong account. They are FREE apps for f**** sake!!!


But it didn't complain when I purchased and downloaded Lion yesterday evening.


I fell asleep and when I got up it was finished.


But when I try to use any of the various utils to install this legit copy of ML they fail and the /var/logs tell me that the utils think I'm trying to pirate ML. WTF?


So a little more reading and I saw people having the same problem. Others suggested that the download was foobar and that it needs to be re-downloaded.


So I'm trying that now and the d*** thing is downloading like it's 1994 all over! It says there is SIX HOURS left to download! SIX HOURS!!!


What a pant load!! I don't know how long it took when I was asleep but I'm guessing it was probably about the same. Come on Apple!!

Are they really THAT screwed up?? SIX hours???


What am I doing wrong?

Share this post

Link to post
Share on other sites

I think I have it now. I guess the first download was corrupted or something, it seems to be trying to run the install app now.

But it's dog slow. This borrowed iMac is the entry level basic model.. Arrrrrgh!


But I think it's gonna work now..


Oh, one other thing, slightly related. Does anyone know of a good guide I can find for overclocking my system?

I got the unlocked CPU and a liquid cooler. I have seen people say they run the i7-3770K at 4.5ghz with no problems and some mentions of 4.7 but at 4.7 it can be touchy.

I would be very happy if I could run at 4.0 and be 100% stable. If I can get 4.5 and be 100% stable I would take that too. I would be concerned about shortening the life of my stuff, heat generation and power draw though.

I need a happy medium.. The other thing, I have some nice 32gb memory sticks and I want to be sure the mobo is configured to take full advantage of them.


Also, I have a 180gb SSD that I would like to use as swap/temp/scratch to speed things up. If I were building a Linux box that would be a snap, I've got about 13 years experience on Linux.

I've used OSX full time for about a year but on a pretty basic system that was borderline unstable so I never tried to fiddle with it, I just left it alone and was happy when it would work.

I know that when installing Linux you can define partitions for swap and temp. But I'm thinking Old Steveo wasn't too hip on people fiddling with his stuff...


Thanks... :)

Share this post

Link to post
Share on other sites

Ok, trial and error time..


Just trying all the options. I tried that "other guy's stuff" (it starts with Uni and ends with beast) and it installed ML on my new machine.

Everything works with two exceptions. No sound and won't boot from the hard disk. Same exact problem I had with the Lion install I ran for the past year.


It saw my bluetooth, my iPhone 5, the App Store works, updates work, etc... Everything seems good except no sound.

And no boot from hard disk.. :(


Well, it's 1am and I'm done for tonight. I'll try again tomorrow with some of the other methods you guys have suggested.


Oh, and I'm going to need some help getting my stuff off of the old hard disk from the dead Mac.

I popped it in a USB3 drive bay and it mounted right up. I can browse to it in finder and there's all my files.


BUT, I can't find the data stored by apps. Like my email ! I was using thunderbird (Actually the Earlybird daily build) and I had imported years worth of email from my old Linux box into it. There are a TON of emails on there that I absolutely can not lose! I have to somehow import them from that dead drive into the new machine. I browsed the disk but I could not find where the emails are stored. There is probably well over 6 gigabytes of email I have to recover.


There's a lot of stuff on that disk I have to get back.


Well, I'll give it another go in the morning..


Thanks.. :)

Share this post

Link to post
Share on other sites
it starts with Uni and ends with beast


you won't get support here if you use this !


your E-Mails and other User things are in Users Library Folder.


if you don't see that Folder than you should unhide it, look here http://osxdaily.com/...-mac-os-x-lion/


default Thunderbird location on Lion, if i'am right.




why you'll overlock your system, it's fast enough IMHO.


i wish i had a system like yours !




Share this post

Link to post
Share on other sites

Ok, I ~finally~ got it! My machine is now 100% up and running and ~everything~ works properly! Woo hoo!!!


It was NOT easy and I went through the gauntlet trying everything, over and over and over until I finally got it working!


Now, I have what is probably a weird question..


I'm booting and running the OS from the OCZ SSD disk. But it's only 180gb and I don't want to store any files on it other than apps and the basic OS.


I have a brand new 2tb 6gbs data III disk internal in the box for data storage. I also have a 3gbs data II disk in a USB 3.0 external dock that I plan to use as my Time Machine drive.

Currently that drive has all my old files and data from the dead Lion machine. After I move everything from it onto the new internal disk I'll erase it and activate it as the TM disk.

Eventually I will put more large disks in the box, I figure about one 2tb disc every other month. I've got more than enough room in the box for discs, I think I can fit 10 in there.

I'll need to get a sata multiplier or a sata controller on PCI. Which ever works best I suppose. But that's down the road a ways.


Anyway, here's what I really need to do, like ASAP.


For instance, on the primary disk, the SSD, it is disk0s2, it's mounted as /

all my folders such as Documents, Downloads, Music, Pictures, etc.. are like

/Users/dee/Documents, /Users/dee/Downloads, etc etc etc....


What I want to do is change things so that rather than the system using THOSE directories, it will instead use the same named directories that I created on the 2tb disk.


It's disk1s2 and is mounted as /Volumes/Mountain_Lion


I want the system to use it as follows,

/Volumes/Mountain_Lion/Users/dee/Documents, /Volumes/Mountain_Lion/Users/dee/Downloads, /Volumes/Mountain_Lion/Users/dee/Music, /Volumes/Mountain_Lion/Users/dee/Pictures, etc etc etc..


In Linux I could use the ln command to link to directories in other places. But I'm not sure how to go about that and maybe there's a better way in OSX.


I know for instance that you can edit something to change where screenshots are saved. I despise that it defaults to saving them to your desktop. I made a directory in my Documents folder called "Screenshots" and edited some stuff ( http://osxdaily.com/...on-in-mac-os-x/ ) and fixed that !

Mac-in-Black:/ dee$ defaults write com.apple.screencapture location /Volumes/Mountain_Lion/Users/dee/Documents/Screenshots

Mac-in-Black:/ dee$ killall SystemUIServer


What I'm hoping is that there is an equally simple way to change everything else.. ?? Yes?


I do not want to keep things on the SSD other than applications, I want things saved on the regular hard disc. Especially email. I have may gigabytes of years and years of emails that I've been migrating from machine to machine over the years and I want that on the hard disc too. I believe I saw one of you guys mentioned it's buried in /Library by default. I need to find a way to change that too. I know Apple doesn't approve of people tweaking things their own way but frankly, I don't give a flip. I have my reasons for doing things my way and I'll do them even if Steve Jobs is spinning in his grave..


Anyway, thank you very much guys for helping me get this beast running! It was quite the challenge and I'm quite proud of my little black box here..


Peace! :)

Share this post

Link to post
Share on other sites

you won't get support here if you use this !





I couldn't get that one to work. It gave me the same grief I had with my old and now dead machine. I'm certain that because of it it was corrupting the CMOS NVRAM and played a major role in the demise of that machine. It never had sound, app store didn't work, wouldn't boot from hard disc, etc.. Lots and lots of problems, not to mention, it was unstable. When I tried it on here it came up just exactly like the old one, no sound, no boot from hard disc. I walked away from it and ended up doing one of the other methods I found on here. I'm so tired now I can't think which one it was by name, all I can remember is install.zip..


And now it's fully operational, 101% in every way and I'm very happy about that. Now all that's left is to tweak it to my personal preference. I'm almost there... :)

Thanks again and good night.. :)

Share this post

Link to post
Share on other sites

I recovered my email !! Woo hoo !! Thank you CooSee !!


THAT was a huge relief!


I also learned about 'nohidden' and that led me to find other things saved on that old disc that I very much needed to recover !


Now think by the end of the week I should have recovered all my lost stuff. I'm hoping to recover my old Safari, Chrome and Firefox stuff. I would love to get back the browser histories, passwords, cookies, etc..

That would be great! I ~think~ I can do it......


So far, so good, I'm well on the way to being back on the road again only this time with a very serious machine. No more Mickey Mouse antique junk like before.. :)

Share this post

Link to post
Share on other sites


glad to hear and you're :welcomeani:


take your time, to get all the things back !


and next time use Time Machine or Carbon Copy Cloner ( <--- to make a " bootable " copy of your complete OS ), it'll make your Life easier !!!


please add " solved " to your Topic.



Share this post

Link to post
Share on other sites


glad to hear and you're :welcomeani:


take your time, to get all the things back !


and next time use Time Machine or Carbon Copy Cloner ( <--- to make a " bootable " copy of your complete OS ), it'll make your Life easier !!!


please add " solved " to your Topic.




Thank you for the additional advice! I will definitely take it..


As for using directories other than the SSD primary disc, I found and followed these basic instructions,




And did that for everything, Documents, Pictures, Movies, Music, etc..


The only thing (user files wise) I left to reside on the SSD are the applications.


I'll eventually find a way to modify Earlybird (Thunderbird Aurora) so that it saves all it's stuff to the 2tb mechanical disc rather than the SSD.


And with everything mirrored via Time Machine and CCC, I should be in good shape if anything ever happens and I have to move my stuff to a new machine.


Now that the hard stuff is over and behind me I have other questions about other tweaks but I'll just start new question threads when those arise.


Thanks again very much guys! :)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.