Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Tona102

ASUS P6X58D PREMIUM HACKINTOSH USB CONFUSION

3 posts in this topic

Recommended Posts

Ok, i don't have time toexplain much, the system is running about two years now with no problems! But i obviously need help with USB and iLOK2, i need it because of some apps that run only there!

 

The thing is, USB's all work ok, only with iLOK2 i have to wait for about 10 minutes for plugin to initialise (in Logic), also have MacBook, with older Lion 10.5.8 i think, there it works fast as it should!

 

Also have dualboot in win 7, where it also works fast! But all my important projects are on this build, and i really don't want to start moving files to another systems!

 

 

So far i tried to install/uninstall several kexts, but all i got was one time key and mouse not working, and the other unresponsive USB's! All fixed now, except damn iLok2 and waiting times!

 

This is how it looks in profiler:

 

post-667871-0-45994300-1357754630_thumb.png

 

 

And i really need this fixed fast, so please anyone! Even if i have to go DSDT!

Share this post


Link to post
Share on other sites

Ok, here's a portion of UHC from my DSDT:

 

Device (UHC1)

{

Name (_ADR, 0x001D0000)

Name (_PRW, Package (0x02)

{

0x03,

0x04

})

Name (_S3D, 0x02)

OperationRegion (BAR0, PCI_Config, 0xC4, One)

Field (BAR0, ByteAcc, NoLock, Preserve)

{

USBW, 2,

Offset (0x01)

}

 

Method (_PSW, 1, NotSerialized)

{

Multiply (0x03, Arg0, USBW)

}

 

Method (_DSM, 4, NotSerialized)

{

Store (Package (0x0F)

{

"device-id",

Buffer (0x04)

{

0x34, 0x3A, 0x00, 0x00

},

 

"AAPL,clock-id",

Buffer (One)

{

0x0A

},

 

"built-in",

Buffer (One)

{

0x00

},

 

"device_type",

Buffer (0x05)

{

"UHC1"

},

 

"AAPL,current-available",

0x04B0,

"AAPL,current-extra",

0x02BC,

"AAPL,current-in-sleep",

0x03E8,

Buffer (One)

{

0x00

}

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

}

}

 

...and so forth. What is missing/wrong here?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×