Jump to content
InsanelyMac Forum

Need help with Atheros AR5B91 adapter.

Recommended Posts



I bought and installed a Atheros AR5B91 adapter with a mini pci-e to pci e adapter and it works ok under Windows 7. If I boot OS X, I get a Failed to load kext com.apple.AirPort.Atheros21 error. THere is also a Failed to load IO80211family kext error. Can someone offer advice on how to fix this? It is appreciated as always.

Share this post

Link to post
Share on other sites

do u use patched dsdt ? irq conflict can cause this.


what motherboard is it ?


ive tried 3 different AR5B91 and all worked.


sounds like permissions issue.


i fact i just put one in asus P8Z77-V LX and no issues. ( i have removed irqs in dsdt with patcher)


ahh see u fixed it. . legacy kernel issue.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.