Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


[GUIDE] Acer Aspire 5738g (ATI Version) - Mountain Lion 10.8.2 - Possible Troubleshootings

2 posts in this topic

Recommended Posts

Here's the guide to install Mountain Lion 10.8.2 on the Acer Aspire 5738g (ATI Mobility HD 4570 Version)


What's work:

VGA: ATI Mobility HD 4570 - QE/CI Enabled but Photoshop's RGB Mode is green and OGL applications crash

Sound: ALC888 - Fully working

Ethernet: Gigabit Lan Ethernet - Fully working

Sleep Mode: Fully working

Camera: Native

Kernel cache



What doesn't work:

Wi-Fi: Intel WiFi Link 5100 AGN - Replaced with native Broadcom BCM4311MCG

HWMonitor: It crashes when i try to install Menu Bar extensions

GraphicsMode in BootScreen



Here's the guide:


What you need:

Mountain Lion Bootable USB (Google is your friend)

All the kext and pkgs here:







1- Boot with the USB in first position in Boot Option of the BIOS

2- In the USBLoader type USBBusFix=Yes

3- Install Mountain Lion normally





1- Open MBeast and check the option like in the image:





2- Now Install Chameleon_2.1svn_r1820_10.8_Peregrine_NB_780.pkg

3- Reboot with GraphicsEnabler=No

4- Install the 10.8.2 update from the AppStore and Reboot

5- Install kexts in the folders ALC888,4570m,Ethernet,Battery,Sleep Enabler

6- Copy DSDT.aml in /Extra folder

7- In Kext Wizard Repair Permissions and Restore Cache

8- Copy org.chameleon.Boot.plist

9- Reboot


Tips: Set you SMBios.plist to a Mid-2010 MacBook Pro to avoid the graphic update that ruins the 4570m injection



Enjoy your new AcerBook Pro



All kexts except VGA kexts (modified by me) are taken from osx86.net



Please feel free to post suggestions and fix :guitar:



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Nikita123
      Hello, I have been running OSX Yosemite on this laptop for quite some time now and I found a AppleHDA that works in Yosemite for this laptop for the speakers. It has a tuba surround system and only with this Kext I could get good sound (Not Microphone)
      I also got this kext to work in OSX El Capitan Developer Preview, but not in the final release, it just hangs in verbose mode and will never go to the login screen.
      So I tried a different approach. I Used CloverALC patch and now I can see my Audio devices but still no sound
      Also the script warns me and says codec 0x11c11040 not supported.
      The device ID of the HDA controller is 0x8086293E
      With the former kext I had to use Audio ID: 888, with this new solution I can only see the audio devices in System Preferences if I use Audio ID 1, 2 or 3.
      I have attached the former AppleHDA, the new (I think patched) AppleHDA, my config.plist, my DSDT and also the realtekALC kext placed in kexts/10.11 by the CloverALC script.
      If you want to use to former AppleHDA with Mavericks or Yosemite you must use Audio ID 888:
                                    "layout-id",                              Buffer (0x04)                             {                                 0x78, 0x03, 0x00, 0x00                             },    In this DSDT the Audio ID has been set to Audio ID 2 for the moment. So if you want to use the old patched AppleHDA you must change to 0x78, 0x03 in HDEF.   I hope anyone can help me out, if you need a linux codec dump tell me, I can create it if needed.   Here is my CloverALC Log:   Last login: Sun Oct  4 15:13:48 on console Computers-iMac:~ computerspecialist$ /Users/computerspecialist/Downloads/audio_cloverALC-110_v1.0f.command ; exit;
      The audio_cloverALC-110 script is for personal use only. Do not distribute
      the patch, any or all of the files or the resulting patched AppleHDA.kext
      for any reason without permission. The audio_cloverALC-110 script is
      provided as is and without any kind of warranty.
      File: audio_cloverALC-110.command_v1.0f
      EFI partition is mounted
      System Integrity Protection status: enabled (Custom Configuration).
      Apple Internal: disabled
      Kext Signing: disabled
      Filesystem Protections: disabled
      Debugging Restrictions: disabled
      DTrace Restrictions: disabled
      NVRAM Protections: disabled
      This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state.
      OK to patch
      Codec 0x11c11040 is not supported, continue (y/n): y
      Confirm Realtek ALC888 (y/n): y
      ALC888 v_0x100202 (Legacy)
      Clover Audio ID Injection (y/n): n
      Download ALC888 files ...
        % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                       Dload  Upload   Total   Spent    Left  Speed
      100 23970  100 23970    0     0  24549      0 --:--:-- --:--:-- --:--:-- 24559
      Edit config.plist/Devices/Audio/Inject/1
      Edit config.plist/SystemParameters/InjectKexts/YES
      Download kext patches
        % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                       Dload  Upload   Total   Spent    Left  Speed
      100  1404  100  1404    0     0   4044      0 --:--:-- --:--:-- --:--:--  4046
      Install /Volumes/EFI/EFI/CLOVER/kexts/10.11/realtekALC.kext
      Download config kext and install ...
        % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                       Dload  Upload   Total   Spent    Left  Speed
      100  3586  100  3586    0     0  11042      0 --:--:-- --:--:-- --:--:-- 11067
      Install System/Library/Extensions/AppleHDA.kext/ALC888 zml files
      Fix permissions ...
      Kernel cache...
      rebuilding //System/Library/PrelinkedKernels/prelinkedkernel
      kext-dev-mode allowing invalid signature -67054 0xFFFFFFFFFFFEFA12 for kext AppleHDA.kext
      kextcache updated critical boot files, requesting launchd reboot
      Install finished, restart required.
      To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
      Saving session...
      ...copying shared history...
      ...saving history...truncating history files...
      [Process completed]

    • By Velislide
      Well, Ive successfully installed Mavericks 10.9.0, using Niresh's USB Distro. Install went great, I only ran into the root error, which bypassed with just -v -f usbbusfix=yes, nothing worked till I tossed in the -f. I also updated to 10.9.5 using the combo updater, and didn't break anything, no issues with the install. 
      As far as my laptop goes, specs are...
      -MSI VR705- (Though my laptop is rebranded Nobilis) 
      Core 2 Duo 2.0ghz
      3 gigs DDR2
      Realtek ALC888 (popping & crackling during audio playback)
      Ralink RT2790 Wi-Fi (can't get it to work) 
      Realtek ALC 8111C Ethernet (works great)
      Nvidia Geforce 8200M G (works great) 
      I really don't understand how to install drivers for hardware on osx86. I'm pretty sure "kexts" are basically the drivers compiled into a single file? And I use a kext installer, to install it, and then I resync the cache and permissions? But what I don't understand is what points the OS to using THAT kext for THAT hardware. I've spent days and days reading, and still don't understand. I think its something to do with DSDT is some type of configuration file that points the hardware to a kext or something? Really don't know. 
      I've tried installing kexts and stuff to get my sound working right, and still hasn't changed at all. Also tried stuff to get my wifi working, no luck. The biggest reason I wanted osx86 is for iMessage, which gives me an error when I try to login. iCloud, FaceTime and all that work fine. I installed the NVRAM thing, didn't change anything. 
      Anyone able to point me in the right direction? 
      I got to the point where iMessage says, it cannot be setup right now with my user ID, and need to contact Apple. Progress I guess.
    • By cyberderf
      I tried 2 different methods without success:
      ALC888 HDA Kext (Legacy 100202) : fine Rear/font line-in and out working, with automatic switch when inserting headphone. But I get a big pop when using sound after a period of inactivity. I tried 100203 and the Toleda Kext too. All the same.. perfect except pops and cracks. VoodaHDA 2.8.6 : Wow. Perfect audio without cracks!  I also get rear/font line-in and out working, but no automatic switch to the headphones when I plug them. I also loose my sound after each reboot. I can get it back by doing to sound option and selecting rear green line-out again. Well.. I am stuck.  Any idea what to do? 
    • By MAC IN TOSH
      This VoodooHDA 2.8.7 can enable ALC888 audio on OS X Yosemite. Install it, restart you Hackintosh. You may hear some noise. To fix the noise, go to VoodooHDA pref pane in System Preferences and decrease Input Grain. Enjoy.
      Should work with Mavericks
      Will Work with Yosemite
      Might work with other audio devices on yosemite
    • By Vadimios
      Please tell me how to enable graphics card ATI Mobility Radeon HD 4570 (0x95531002) 1024 MB on MAC OS X 10.9 Mavericks!
      Notebook: Samsung R-540
      CPU: Intel CORE i5 (without integrated graphics)
      GPU: ATI Mobility Radeon HD 4570 (0x95531002) 1024 MB
      I heard about the successful integration of this card in the Mavericks, but the video memory of them was 512 MB. In my video card video memory is 1 GB and I did not get it included in OS X!
      Here is my patch framebuffer:
      Radeon Bios Decode:
      ATOM BIOS Rom:
      SubsystemVendorID: 0x144d SubsystemID: 0xc07f
      IOBaseAddress: 0xd000
      Filename: BR36795.011
      BIOS Bootup Message:
      BR036795-001 M92 DDR3 64bit 720e/800m
      PCI ID: 1002:9553
      Connector at index 0
      Type [@offset 45650]: LVDS (7)
      Encoder [@offset 45654]: INTERNAL_UNIPHY2 (0x21)
      i2cid [@offset 45712]: 0x91, OSX senseid: 0x2
      Connector at index 1
      Type [@offset 45660]: VGA (1)
      Encoder [@offset 45664]: INTERNAL_KLDSCP_DAC1 (0x15)
      i2cid [@offset 45735]: 0x90, OSX senseid: 0x1
      Connector at index 2
      Type [@offset 45670]: HDMI-A (11)
      Encoder [@offset 45674]: INTERNAL_UNIPHY (0x1e)
      i2cid [@offset 45758]: 0x95, OSX senseid: 0x6
      Redsock Bios Decode:
      BR36795.011 :
      BR036795-001 M92 DDR3 64bit 720e/800m
      Subsystem Vendor ID: 144d
      Subsystem ID: c07f
      Object Header Structure Size: 197
      Connector Object Table Offset: 32
      Router Object Table Offset: 0
      Encoder Object Table Offset: 97
      Display Path Table Offset: 10
      Connector Object Id [14] which is [LVDS]
      encoder obj id [0x21] which is [iNTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false
      Connector Object Id [5] which is [VGA]
      encoder obj id [0x15] which is [iNTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false
      Connector Object Id [12] which is [HDMI_TYPE_A]
      encoder obj id [0x1e] which is [iNTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false
      I then added ID my graphics card in kext: AMD4600Controller. kext (rights restored through the kext Wizard)
      Then I looked at the list of framebuffers (OS X 10.9) ATI4600Controller.kext
      Here's what wrote a terminal:
      Kext /System/Library/Extensions/AMD4600Controller.kext/Contents/MacOS/AMD4600Controller
      Personality: Flicker
      ConnectorInfo count in decimal: 3
      Disk offset in decimal 535312
      0000000 00 04 00 00 00 04 00 00 00 01 00 00 02 01 03 05
      0000010 00 04 00 00 00 04 00 00 00 01 00 00 01 00 02 02
      0000020 00 02 00 00 14 02 00 00 00 01 00 00 00 10 01 04
      Personality: Gliff
      ConnectorInfo count in decimal: 3
      Disk offset in decimal 535360
      0000000 02 00 00 00 40 00 00 00 09 01 00 00 02 01 00 03
      0000010 02 00 00 00 00 01 00 00 09 01 00 00 20 01 02 02
      0000020 00 04 00 00 04 06 00 00 00 01 00 00 10 00 01 01
      Personality: Shrike
      ConnectorInfo count in decimal: 3
      Disk offset in decimal 535408
      0000000 02 00 00 00 40 00 00 00 09 01 00 00 02 01 00 03
      0000010 02 00 00 00 00 01 00 00 09 01 00 00 20 01 02 02
      0000020 00 04 00 00 04 03 00 00 00 01 00 00 10 00 01 01
      I chose the Shrike.
      This unpatched framebuffer:
      02 00 00 00 40 00 00 00 09 01 00 00 02 01 00 03
      02 00 00 00 00 01 00 00 09 01 00 00 20 01 02 02
      00 04 00 00 04 03 00 00 00 01 00 00 10 00 01 01
      This patched framebuffer:
      02 00 00 00 40 00 00 00 09 01 00 00 02 04 00 02
      10 00 00 00 00 01 00 00 09 01 00 00 00 10 02 01
      00 08 00 00 04 03 00 00 00 01 00 00 00 00 01 06
      Then i removed all the gaps and put it in Clover Configurator(config.plist):
      Ati Connectors Data: 020000004000000009010000020100030200000000010000090100002001020200040000040300000001000010000101
      Ati Connectors Patch:020000004000000009010000020400021000000000010000090100000010020100080000040300000001000000000106
      Put a tick on Load VBios, Patch VBios, Inject ATI
      In FBName wrote Shrike, duallink = 0 VRAM = 1024
      But I did not succeed. At the end of the boot was a reboot (if you remove the check mark from InjectATI or Load VBIOS, then there wasn't a reboot, but the video memory was 4MB)
      Please help!!!!!
      And sorry for my english.