Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


GA-Z77-DS3H HD4000 HDMI problem

7 posts in this topic

Recommended Posts

I've managed to setup HD4000 with DSDT Editing using ig-platform-id: 0166000A on a GA Z77 DS3H motherboard with i5 3570k. (DSDT fixes + patched AppleHDA)
I have full acceleration and HDMI audio using HDMI output to my Sony TV.
The problem is that it boots fine with 1920x1080p BUT if i try to change resolution to something lower than that everything gets messed up.
The only way to have correct resolution change is to put computer to sleep and after wake everything is OK i can then change resolution to anything i want ,after reboot the problem appears again.
I also tried with DVI to HDMI adaptor but same issue.

Tried with latest chameleon from http://chameleon.osx86.hu Chameleon-2.1-r2069.pkg.zip and latest Chimera.
Bios settings have been checked and Graphics Enabler in boot loader is disabled.(Also tried with out any dsdt and Graphics Enabler = True in Chimera but same results)

Tried also MacPro3,1,MacMini5,1 and iMac12,2 if i remember correct.

Any help will be appreciated.

Share this post

Link to post
Share on other sites

Coming back and using modified ozmosis bios i have excellent results.

BUT the same problem remains :

Booting is fine everything works only problem is resolution change to something other than 1080 results in distorted image.

The weird thing is that if i put computer to sleep after wake everything is fine and resolution change works as it should.


The card is connected to SONY TV with Hdmi.


By the way i have set vram variables for smb to mac mini 6,2.

Share this post

Link to post
Share on other sites
you only need this in IGPU

Return (Package (0x04)



                    Buffer (0x04)


                         0x05, 0x00, 0x62, 0x01



                    Buffer (0x0A)





should FIX resolution change ;)

Share this post

Link to post
Share on other sites

I tried every "AAPL,ig-platform-id" possible values in dsdt but the problem remains. Only way to show correct resolutions lower than 1080 is to put compauter to sleep and after wake everything is ok.

I even compared ioreg before and after sleep but icannot spot any difference .

If i boot computer and try to open a game with lower resolution than native everything gets messed up.


I cant understand why after sleep and wake everything works but not after boot ?

any suggestions ?????????

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.