Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Help! Boot Camp destroyed my OS X Master Boot partition

2 posts in this topic

Recommended Posts


As a 2 decades of MS-Windows user I have switched to Mac OS X a month ago. And my knowledge is not enough to fix my problem which encountered yesterday and my brand new MBPro is dead now.

I installed Win-7 x64 on Boot Camp. My mistake at first is I have allocated very little space to Windows from my precious SSD disk. Yesterday I have tried to increase the Boot Camp partition from 80GB to 250GB. What exactly i did is;

1- Started in Windows 7, taken a full Windows system backup into an external USB Disk.

2- Switched to OS X and created a disk image (dmg) from my existing Boot Camp partition (Using Std. OS X's Disk Utility) this was my second backup. Since I don't want to get in trouble with activation of all my MS Office, Windows 7, Games etc. I was planning to restore one of those to my New Windows with larger disk capacity.

3- in OS X, I have erased the Boot Camp partition (disk0s4) and enlarged the master HFS+ partition (disk0s2) to maximum physical disk capacity using Disk Utility so I had single HFS partition with ~750GB

4- Started Boot Camp and performed a clean copy of Windows x64 and this time I have given a disk size of 250GB for the new Boot Camp partition (simply; 250GB to Boot Camp, 500GB to OS X)

5- Standard installatin went well. Windows asked for product key, i skipped this and started up new Windows for the first time, saw that it is running well. I shut it down and restart in OS X.

6- Now the first of the series of the problems that eventually ended up with the death of my MBPro is coming up, Disk Utility refused to restore from DMG file (ref.step 2 - image was created from previous Windows partition so it is NTFS!) to new pysical Boot Camp partition (also NTFS). It said something like both disks were not identical or something like that. I checked the block sizes etc. Both was 512kb. I googled and found an alternative way to restore and skipped Disk Utility and switched to terminal window. Executed DD if=dmg of=disk04s to copy content of backup DMG file to new Boot Camp partition. Needles to say, Windows didn't start up, a black screen appeared and the worst thing is when I started in OS X, Disk Utility was showing only 80GB for the Boot Camp partition (which has to be 250). The capacity was overwritten by the previous partition's image file and all of a sudden I happen to lost 250-80=170GB.

7- I decided to go with the other option to install a clean windows and use Windows7@s Backup/restore. To be able to do this I needed to start over and delete the Boot Camp partition again and resized the (single partition) master HFS volume to its Max (of 750) as I already did in step 3-4.

8- Started Boot Camp, this time Boot Camp gave me an error saying 'Can't install Boot Camp to multiple partitioned disk'. I already knew that Boot Camp requires a single OS X (HFS) partitioned disk so he can manage the partition table withing his screens. I was amazed with this error cause I knew that I already removed the last Boot Camp partition and resized the main HFS partition to its maximum.

9- The golden shot, I have restarted my OS X. And it never came back. Thanks God, my repair partition was still healthy so I booted with command+r in repair mode. Now I have terminal windows open.

I have run `diskutil list` and I couldn't believe the thing I saw, Boot Camp (or Disk Utility not sure) has changed the type of my primary OS X partition to MS-DOS (Fat 32) I guess, it says 'Microsoft Basic Data'.

I've been desperately looking for a way to change the corrupted type of my existing primary HFS+ partition (I know all my data is healthy and waiting for me if I could manage to reach them)

Here's the outputs of;

diskutil list



0: GUID_partition_scheme *751.3 GB disk0

1: EFI 209.7 MB disk0s1

2: Microsoft Basic Data 750.4 GB disk0s2

3: Apple_Boot Recovery HD 650.0 MB disk0s3



0: Apple_partition_scheme *1.3 GB disk1

1: Apple_partition_map 30.7 KB disk1s1

2: Apple_HFS Mac OS X Base System 1.3 GB disk1s2



0: untitled *524.3 KB disk2

(*I cleared the rest as they're irrelevant with various mount points of repair disk)

and result of df

Filesystem 512-blocks

Used Available Capacity iused ifree %iused Mounted on

/dev/disk1s2 2464464 2223200 216624 92% 280978 27078 91% /

devfs 399 399 0 100% 691 0 100% /dev

/dev/disk2 1024 288 736 29% 34 92 27% /Volumes

/dev/disk3 1024 280 744 28% 33 93 26% /private/var/tmp

/dev/disk4 1024 312 712 31% 37 89 29% /private/var/run

/dev/disk5 1024 280 744 28% 33 93 26% /System/Installation

/dev/disk6 1024 528 496 52% 64 62 51% /private/var/db

/dev/disk7 12288 3304 8984 27% 411 1123 27% /private/var/folders

/dev/disk8 4096 832 3264 21% 102 408 20% /private/var/root/Library

/dev/disk9 2048 288 1760 15% 34 220 13% /Library/ColorSync/Profiles/Displays

/dev/disk10 1024 336 688 33% 40 86 32% /Library/Preferences

/dev/disk11 1024 312 712 31% 37 89 29% /Library/Preferences/SystemConfiguration

/dev/disk12 2048 280 1768 14% 33 221 13% /Library/Keychains

/dev/disk13s1 15600632 283400 15317232 2% 0 0 100% /Volumes/GPARTED


Btw, I have the OS X Mountain Lion with latest updates (10.8.x).

Until now, I have tried GPARTED (made a bootable thumb-drive, it didn't run, it has frozen in keyboard selection screen), I have tried TestDisk, it didn't run either, simply returned an error code, made a search about gpt, fdisk etc. but couldn't find any information that's worth to try.

So I'm here and waiting for an answer from you guys, can you suggest me any direction to go, a tool to use to fix my existing partition with the wrong file system type?

Kind Regards


Share this post

Link to post
Share on other sites

It would be easier to help if you actual used complete coherent sentences. Seriously, we don't need your life story. All we need is the problem itself and what you've tried. I sure as hell don't want to read through all this nonsense trying to pick out the tiny little tidbits that do make sense in order to figure it out. I doubt anyone else would want to either. Please, just re-describe it more clearly. Use only relevant information and don't use run-on sentences. Thank you.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.