Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.



10 posts in this topic

Recommended Posts

Good evening,

I am sorry, but my English is not the best.


I've had installed SL, lion and now I have the mount lion 10.8.2.


It turns out that in all versions have a problem with my graphics.


From time to time the following happens.

When you start the mac screen turns black and the monitor light turns orange.

I click the reset button and then opens fine.

Have you put in chamaleon with-v-x and the same thing happens verbose mode disappears and instead of the login screen appears the screen goes black and the monitor light turns orange.

I reset and then opens fine.



tried GraphicsEnabler = yes and then = and the problem continues.


The Graphic is an Ati Radeon HD5770 GigaByte Distributor: ATI (0x1002) Device ID: 0x68b8


The Monitor is: HP L1908w vga converter connected to dvi


Motherboad: ASUS P5P43TD PRO Chipset: Processor: C2Q Q9400 -

Memory: 4GB DDR3 1666Mhz 7-8-7-24 gskill

HD: SAMSUNG SATA II 500GB f3 / Network: Realtek

Audio: ACL887

Video: ATI 5770 1GB DDR5 / Keyboard and Mouse: Generic USB



Who can give help thank.

Edited by fantomas1
If you have a question please do your best to use the search feature and search the forum before creating a new topic.

Share this post

Link to post
Share on other sites

If it happens a lot, specifying framebuffer may do the trick, varies a bit between different manufacturers versions of 5770 and their different sets of outputs. To test a framebuffer, while using GraphicsEnabler=Yes, at Chameleon boot prompt type:


followed by the name of the framebuffer. Also important syntax is exact. Try these ones first, one at a time: Eulemur, Hoolock, Vervet, Uakari

It would look like this when typed in Chameleon






Even still, maybe once in every 30+ reboots, I'll see that same exact issue, but using screen sharing from my MacBook, if I change the resolution in SystemSetings>Displays to lowest setting and then back to default, display will kick back on. Have seen same thing also on a couple real MacMini's where it was probably DHCP handshake issue, my main monitor is DVI so shouldn't be a DHCP problem, but is very rare occurrence none the less.

Share this post

Link to post
Share on other sites

Good afternoon,

I think I have another problem and that might be cause the problem I mentioned in the previous post.


If I use GraphicsEnabler = yes my grafica is recognized as HD5770.

Now if use GraphicsEnabler or GraphicsEnabler=no then put in my grafica is recognized as Ati HD5000.


According read by google should not use Graphics Enabler = yes.


After searching on google I do edit framebuffer and when I read the rom appears something strange. Do not know Personality



TOM BIOS Rom: SubsystemVendorID: SubsystemID 0x1002: 0x2543

IOBaseAddress: 0x0000

Filename: S3C01001.100

BIOS Bootup Message:




PCI ID: 1002:68 b8

Connector at index 0

Type [@ offset 44462]: DisplayPort (10)

Encoder [@ offset 44466]: INTERNAL_UNIPHY2 (0x21)

i2cid [@ offset 44590]: 0x91, OSX senseid: 0x2

Connector at index 1

Type [@ offset 44472]: HDMI-A (11)

Encoder [@ offset 44476]: INTERNAL_UNIPHY2 (0x21)

i2cid [@ offset 44617]: 0x90, OSX senseid: 0x1

Connector at index 2

Type [@ offset 44482]: DVI-I (2)

Encoder [@ offset 44486]: INTERNAL_UNIPHY1 (0x20)

i2cid [@ offset 44654]: 0x93, OSX senseid: 0x4

Connector at index 3

Type [@ offset 44492]: DVI-I (2)

Encoder [@ offset 44496]: INTERNAL_KLDSCP_DAC2 (0x16)

i2cid [@ offset 44654]: 0x93, OSX senseid: 0x4

Connector at index 4

Type [@ offset 44502]: DVI-I (2)

Encoder [@ offset 44506]: INTERNAL_UNIPHY (0x1e)

i2cid [@ offset 44691]: 0x92, OSX senseid: 0x3

Connector at index 5

Type [@ offset 44512]: DVI-I (2)

Encoder [@ offset 44516]: INTERNAL_KLDSCP_DAC1 (0x15)

Share this post

Link to post
Share on other sites

I used the settings you said and put the rom in the extra folder and it did not work.

I still try out using the rom that I took of my Graphic but also did not.


GE = yes in the dvd player and power point microsoft office works well.


If GE = no, and the changes you mentioned the dvd player does not work and gives power point error when I put in full screen.

Share this post

Link to post
Share on other sites

try to change the vgabios whit AtiFlash or AtiFlashWin, you can find some vgabios of your manufacture (gygabite) in "techpowerup" website , dont remember to back up the bios first to flash it.. i had the same problems whit my HD 5770 but not sapphire, have XFX, i solved changing the vgabios , also set macpro 5,1 and in org.chameleon only set "graphicenabler=yes"

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Recent Status Updates

    • Bios-PC  »  MaLd0n

      Hi MaLd0n
      you helped me with dsdt and everything working fine .
      I fix the audio issue.
      I need to add wifi bcm4360 original apple to dsdt to be  en0 all the time 
      also to add it to pci list.
      and I change from gtx970 to AMD radeon pro rx580 and I have issue with vtencoderxpcservice that make my cpu 300% and high temperature . with Nvidia it doesn't happen.
      I search the internet days and night and try to fix this issue no luck.
      best regards
      · 0 replies
    • DynaFEX  »  MaLd0n

      Hi MaLd0n!!
      I just don't know what the hell to do with this issue and I was wondering if you might please have any ideas??
      Sorry to bother you and thanks for all your help!
      · 0 replies
    • mrjayviper  »  e97

      hello. Can you please share instructions and files to get OSX working on a dual 2011 setup? you included a link to sixflow but it's not loading anymore. Thanks
      · 0 replies
    • adamfox

      I added a video to a @YouTube playlist https://t.co/EXJucl9T8B Go the distance sung by Adam Fox karaoke cover Disney Hurculese
      · 0 replies
    • Mr. Xtreme

      Hey, I'm not dead, I've moved over to using the nickname "Mr. Xtreme", and mostly use Linux distros/Windows 10, though it seems I'm gonna have to hackintosh again, so, hey everyone who remembers me! :wave:
      · 0 replies