Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Tip: VMWare Tools for OSX as a guest

8 posts in this topic

Recommended Posts

If you need to get the VMWare Tools for OS X as guest OS running on, say, Windows 7 - you can download the "darwin.iso" from the software update site directly...




Grab the


file. You may want to browse back up to the http://softwareupdate.vmware.com/cds/vmw-desktop/fusion/ level to make sure you've grabbed the latest version of the tools.


Once you have the "zip.tar" file (it's only about 2Mb), you can extract it and browse into the archive to find the ISO. Mount the ISO inside OSX and run the installer.

Share this post

Link to post
Share on other sites

Another tip - if you are trying to do this within VMWare Player running Mountain Lion, you may run into Gatekeeper not allowing the installation due to "Your security preferences allow installation of only apps from the Mac App Store and identified developers."


The following link shows screenshots on how to disable it:



Basically you need to go to System Preferences > Security & Privacy. Under General, make sure you have unlocked the settings and then set the "Allow applications downloaded from..." to Anywhere. After the installation you might want to switch back to the previous setting.

Share this post

Link to post
Share on other sites

Sorry for the old bump, but just tried it in my VMWare image and i got error in the preflight script which unloads the kexts, but since i don't have it already installed i can't unload the kext and the installer errors out.


Any solutions (this is v5.0.3)?

Share this post

Link to post
Share on other sites

I found the issue that causes this. In the VMWare tools installer package, there is a "install check" script that checks whether the timestamp on the kernel is newer than the latest system boot time, and if so, it errors out. For some reason (I believe having to do with the VM syncing the time with the physical PC) my kernel had a funky timestamp on it which was in the future. I just updated the time stamp on the kernel by touching the file with the command:


sudo touch /mach_kernel


and rebooted, then I was able to install the VMWare tools without any problems. Hope this helps. BTW, I'm running 10.8.3 and installed VMWare tools 5.0.3.

Share this post

Link to post
Share on other sites

Thought I'd finally solved the problem by using ixxxion's solution but I get a kernel panic upon reboot after (successfully) installing vmware tools....


Anymore ideas or thoughts? Thanks.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.