Jump to content

HP Envy SleekBook 4t mountain lion 10.8 (Installation Guide)


15 posts in this topic

Recommended Posts


I5 3317U IvyBridge

10GB G.SKILL 1333 (problem with 16GB on this NB)

HD4000 full QE/CE

Webcam works

Audio perfect Vendor ID: 8086 Device id : 1e20 changed in VoodooHDA info.plist

Wifi replaced with AR9280


Doesn't work :

Card Reader





as we don't have any option to change in BIOS all locked by HP and we no have any Insyde Bios Unlocked with this model and bios F0a so we have to use some Flag in bootloader to pass USB and wait for root device (AHCI) problems, and CPUS=1 is for paching the lapic kernel

make USB installer with one of them (niresh 10.8, myHack 1.3.2,###### )

Boot with it plugged in USB2 (single left part )and write CPUS=1 USBBusFix=yes ForceHPEToff=yes


Choose your lang , open disk utility partition your HDD

start install it without any customise setting

when install finished again the flags

CPUS=1 USBBusFix=yes ForceHPEToff=yes


but this time choose your HDD not USB (i called it ML)

choose keyboard bla bla

when you are in desktop

install the KEXTS you downloaded from the link blow on with KEXT Wizzard



Download Cameleon Wizard from here and make the org.chameleon.Boot.plist and SMBIOS.plist in Extra Folder one the close it and REPLACE my Extra Folder with the old one with all flags ready and full HD4000 QE/CE inside string



What you need to download





VoodooPS2 controller and Trackpad for Synaptics



FAKESMC if you get KP









Check this thread for problem , Kernel Panics





1.if you have problem with VoodooHDA



I add modified Info.plist in the folder u download (voodoo hp audio info) with vendor and device id and Control fix already done, replace with mine the info.plist then reboot


2. if you install/remove/modify any kext you have to repair permissions and rebuilding kext caches with KEXT WIZARD

Link to comment
Share on other sites

This didn't work for me. I tried both below with "CPUS=1 USBBusFix=yes ForceHPEToff=yes".

Then I realized that "ForceHPEToff" is not a valid option (it's not, I checked Chimera), so I deleted AppleHPET.kext instead.


I tried this with ###### 1.5 and got stuck at "Still waiting for device root...".


I tried again with ###### 1.4 with "-v -x cpus=1" and got to the installer page, but I don't see any hard drives listed.


Any help?

Link to comment
Share on other sites

Thanks for your help, finally got OS X up and running!


I got a problem now though... I replaced the WiFi with an AR9280 and tested it, works great in Windows. But when I start OS X, the Wifi Button (on the keyboard) is red and stays red... pressing it doesn't work... and the WiFi in OS X cannot find any networks.


Did you face this problem?

Link to comment
Share on other sites

Yep, got it. Apparently the led stays red but pressing the button turns the WiFi on and off.


By the way, I'm using DSDT and doing edits right now, and with DSDT you can delete the IOUSB* kexts, EvOReboot, NullCPUPowerManagement, ElliotRTCLegacy kexts for a more vanilla and stable system.

Plus, DSDT + SleepEnabler has sleep working almost perfect (USB drives get ejected on wake, but plug in/out will work again. USB mouse receivers wake properly.)


And, I've tested the mach_kernel and it does not give me KP. What gives KP is the VoodooBattery and VoodooHDA, both are pretty poorly written and unstable, trying to find alternatives/fixes...


What I have left to fix:

- DSDT fix for AHCIPortInjector

- DSDT fix for SleepEnabler

- Better Battery

- Better Audio

- USB 3 support (IORegistryExplorer shows XHC not loaded)

- Webcam

- Card Reader (PCI-E, most people say can't get it to work)

- Brightness adjustments doesn't work

Link to comment
Share on other sites

My webcam works with no problem


Brightness doeasnt work with what i found even niresh latest pkg

I will open notebook to check audio chip i know its idt but dunno with one maybe we can find a solution for applehda

I really dont care about usb3 speed all my ports works like usb2

Card reader i tried old voodoo cardreader but nothing works

Post ur dsdt and lets fix error together

What mach kernel u used ? I tried 10.8 1 and 2 downloaded from osx86 but always got kp u can see in second post i am stillgoing with cpus=1



New error is airplay and 10.8.2 update

Airplay stop working after a while

10.8.2 maje system 100% unstable with a lot of different kp s

Link to comment
Share on other sites

Did your webcam use any kext? When I open Photo Booth, the working symbol shows in the middle and nothing shows up.


I've attached my DSDT. You need to use MuIti Beast to apply the AppleIntelCPUPowerManagement patch (under System) or you will still KP with this.

You also need to add GenerateCStates=yes and GeneratePStates=yes for your boot.plist.

My boot.plist also has Kernel Cache enabled for faster boot. I attached my boot.plist too. (NOTE! With cache on, /Extra/Extensions extensions won't be loaded on boot. Move them to /S/L/E)


The DSDT fixes:

- Brightness adjustment in System Prefs -> Display. Keyboard doesn't work, can't figure out why yet... :(

- Sleep. Use SleepEnabler.kext with the DSDT to enable it.

- USB. Don't need legacy USB anymore, suggest you remove the legacy USB kexts for better stability.

- With AppleIntelCPUManagement patch, don't need NullCPUPowerManagement, EvOReboot, ElliotRTCLegacy. Remove 'em all.


I'm currently running 10.8.2 with mach_kernel lapic-patched for 10.8.2.

Download it here: http://www.osx86.net...ic_fix.zip.html


For 10.8.2, you need the old 10.8.0 AppleACPIPlatform.kext or you will KP on boot.

I also attached it to this post.




What left to fix:

- Webcam

- Card Reader

- USB 3




Link to comment
Share on other sites

The webcam is suddenly working without any changes made by me... *shrug*

I'm getting KP when I shutdown now, strangely, never happened prior, no changes there either.


Working on that, brightness keyboard fix + card reader + usb3.

Link to comment
Share on other sites

Kp on voodoobattery is caz the acpiplatform we installed with 10.8.2 update, replaced with old one ( witch u posted ) no more kp but battery doesnt work , i prefer random kp lol


Now i have another problem, i always tried mouse for installing and checked fast trackpad functional, right click and left click on touchpad doesnt work for me.

Link to comment
Share on other sites

  • 3 weeks later...

Hi guy

Do you have CPU running a 1.7ghz with speed stepping? or just 1600MHz

I did an ML install with a lenovo U410 with the same CPU,no one manage to run this cpu at it's real speed with speed stepping on ML.


What about HDMI audio?



Link to comment
Share on other sites

  • 7 months later...

  • Create New...