Jump to content

Stuck...Mac OS X 10.8 Installer not recognizing HDD's / partitions...


3 posts in this topic

Recommended Posts

Hey everyone,


After some freelance work has shown an increase in Mac users requesting help, I decided to get Mac OS X ML installed on my PC. A few days were spent researching into the methods/procedures and quirks necessary to install ML successfully.


Now i've successfully prepared ML on a USB flashdisk and reached the installer without any issues/extra command lines required. However, the Disk Utility does not recognize any of my internal hardisks...it only picks up one of my DVD drives and the USB flashdisk. After researching, my HDD's partition tables are set to MBR...and ML only wants GUID/GPT. There is an MBR fix that replaces 'OSInstall' and 'OSInstall.mpkg' in the relevant folders on the ML installer on the USB flashdisk to rectify this. Despite the fix, the result is the same....it won't recognize my HDD's.


Then there is the matter of the DSDT. My motherboard is the MSi Big Bang X-Power LGA 1366 (MS 7666), which isn't on the archive database of motherboard DSDT's. So, by popular practice, the DSDT.aml is created and patched with specific motherboard DSDT patch/.txt from the database. But as my boards patch isn't there, I found a program called DSDTFixer which can take an original/unmodified DSDT.aml and patch it. There were no errors during the patching and it created the DSDT.aml for my board.


The contents made from DSDTFixer were: dsdt.aml , dsdt.dsl , dsdt.orig.aml ...so I assume the dsdt.aml is the patched one.


So I placed the dsdt.aml in the /Extras folder on the USB flashdisk. I don't know if this attributes to whether ML will read my HDD's or not...but, irrespective of whether I place the dsdt.aml in the /Extras folder or not (also, I can confirm that when booting off the USB flashdisk, viewing the progress in verbose mode, it definintely loads the dsdt.aml), the HDD's are still not read.


Now, I prepared ML (while testing) in two ways:


1. Manually prepping ML through Disk Utility and installing Chameleon_2.1svn_r1820_trunk_10.8.pkg (with/without MBR fix)


2. Using ###### - Mountain Lion (with/without MBR fix)


The result is the same with either preparation.


I also tested using and not using FakeSMC.kext and NullCPUPowerManagement.kext (don't know if it's related but i'm sharing what i've attempted so far).



My system specs are:


Intel Core i7 920 LGA 1366 CPU

MSi Big Bang X-Power LGA 1366 Mobo (MS 7666)

3x2GB Corsair Dominator 2000MHz RAM

Realtek ALC889 chipset


I have multiple HDD's, with the primary one (where my OS's go) configured with 2 partitions; one for Windows (NTFS) and one for Mac (tried NTFS/FAT..no go, in regards to recognition in ML installer). All HDD's are connected via SATA 3G ports. My BIOS is configured to AHCI completely. Also, all SpeedStep/C-States have been disabled (for consistant OCing).


That's all I can think of at the moment.....what do you guys think? I'm really interested in getting this up-and-running, but the HDD recognition is the only thing holding this back. What could it be?


Any feedback is appreciated.

Link to comment
Share on other sites

It's not because of MBR that disks don't show in Disk Utility. True OSX don't like to be installed to MBR, but you would be able to reformat to GUID (if you didn't have patched OSInstall.mpkg/mbr fix). It's your sata controller not loading. AppleAHCIPort.kext has entries in info.plist for ICH10

<key>Chipset Name</key>
<string>ICH10 AHCI</string>
<key>Vendor Name</key>

with device ID 3a22 which is ICH10 or ICH10-R chipset set to AHCI mode, but no other variants like ICH10-D/DO which would be device ID 3a02 in AHCI or any ICH9. Double check you controller and it's device ID and edit plist as neededUltimately though you'll want to fix this via DSDT edit, I doubt the auto patch tool you used did much good, they usually use a collection of specific mobo patch files and if your's is not included, would only apply a few very basic fixes that won't provide much in function. If needed upload clean DSDT before having ran auto patcher and can fix sata


For ICH10, as I understand it, you have 4 possible chipsets, each capable of IDE, and AHCI with the R and DO variants capable of RAID as well. Changing the mode in BIOS, will change the device ID, here see pic.

PCI Devices.jpg

Link to comment
Share on other sites

You are absolutely right! I feel like an idiot right now... :)


I checked my BIOS again...and my eSATA and SATA 6G were set to AHCI...there was an ATA setting (under RAID) that was set to IDE...when I changed it to AHCI, it worked! I guess I was being hasty and didn't read the 6G part. :P


It installed fine now. Thanks for the feedback.

Link to comment
Share on other sites


  • Create New...