Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Lenovo z580 + i3 2350 instalation freeze

5 posts in this topic

Recommended Posts

So I'm trying to install ML on my new laptop but I stuck at instalation process.


Using tony's method (i know u dont like it but it's always worth a try) it stops at: ApplerRTL8169Ethernet: phyWaitForAutonegotiation TIMEOUT. It doesn't matted how long i'm waiting it won't move further. (screen at http://d.pr/i/uSuS ).


Using Chameleon method (from: http://www.insanelym...howtopic=280756 ) it freezes at [iOBluetoothHCController][start] -- completed. It's 2 lines before Tonys method (also can be seen on a screen just 2 lines before the end).


I read that it's not related to bluetooth or ethernet, it's matter of graphic. I tried: PCIRootUID=1/0, GraphicsEneabler=Yes/No, -x, -f and -v. And many cominations of them on both tony's and Chameleon method. And it doesn't help. I also disabled Optimus in bios but without succes.


Full specs:

CPU: i3-2350 (sandy not ivy, i saw that at tonys forum people made it with ivy, but this method doesn't work for me)

Mobo: Can't say exactly, its some lenovo timly-wimy thing


GPU: nv630m (probably it won't be working) + HD3000 (i hope this will)

Network: Realtek PCIe FE Family Controller 10/100 (10MBit) (it should be working with related kext and good dsdt)

Intel Centrino Wireless-N 2200 (abgn), 4.0 Bluetooth (for wifi, it won't work anyway)


What else can i do? Probably modyfying kexts at instlation usb? Or there is something i dont know about running hackintosh?

Share this post

Link to post
Share on other sites

The problem actually starts about 10 lines up from the bottom of your screen shot and you'll see about 4 lines of AppleIntelSBGraphicsFB.kext failing to load. Not sure the exact fix, but that much may help your search. For bootflags, when using GraphicsEnabler=Yes, don't include -x. Pciroot shouldn't matter for intel built in igpu. You may also want to include npci=0x3000 and cpus=1 so something like:


GraphicsEnabler=Yes -f -v cpus=1 npci=0x3000


On a side note, both methods you described rely on Chameleon as the bootloader. Chameleon is a open source project, with a few branches that are activly developed, all of which rely on the same trunk and are synced to it often. Although it doesn't seem to mention this for some reason on the Chimera download page, it is a Chameleon bootloader that could not exist without the past and present work of the entire voodoo labs dev team. The fact it is not mentioned leads to wide spread confusion and many people under the false impression that Chimera and Chameleon are 2 different things. Any differences, depending on when changes were synced with the trunk, would be minor and/or cosmetic.



Share this post

Link to post
Share on other sites

You are a genius!

But there is a problem booting without USB. When I try to boot with -v i see text running down the screen and then laptop reboot itself. I read it's related to HD3000 and I don't know how to fix it.

What I did:

- deleted nvidia and ati kexts from s/l/e

- new dsdt with DTGP, RTC, UHCI and EHCI pathes for SB (here it is: http://dl.dropbox.com/u/69771093/Extra/dsdt.aml)

- new AppleIntelCPUPowerManagement.kext installed with Kext utility



<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">






<key>Graphics Mode</key>












SMBios set for macbook pro 8,1

Share this post

Link to post
Share on other sites

Nope, not working.


I didn't say that I installed Chameleon becaus i think it is some kind of oblivious.

I did copy and still it's not working.


Using ip4 as video recorder to see when it stops: http://d.pr/i/tutJ (here is the last line, after this laptop reboots itself). Dunno why there is PCIRootUID=1, didnt using it. Tried diferent sets of booting flags but none of them worked.




Yes! I did it.

Now it's working but with nullcpupowermanagement. Is there anybody who help me patching my dsdt (or tells me which pathes should i use)?

Btw. audio is not working and when i try to sleep there is white screen (i think its because nullcpu...).

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.