Jump to content

GA-Z77X-UD5H is verrrrrry quiet…Â Almost too quiet…


13 posts in this topic

Recommended Posts

So my LSPCI thing tells me I have this audio device:

00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)


From what I can tell there are three options to get audio working on a Hackintosh:


1) Patch AppleHDA, which looks absolutely daunting to me (see this thread).


2) Install voodoohda, which also looks rather daunting, and I'm seeing lots of reports of crackling, sub-par audio.


3) Run MultiBovine :glare: from the silly cartoon Hackintosh site.


Is there anyone running my motherboard who has gotten their built-in audio working properly?

Link to comment
Share on other sites

I believe you have realtek alc898 audio codec on that board (which lspci won't tell you) so you can use appleHDA patched for alc898 with an enabler or without an enabler if you have audio edits done in DSDT. Voodoo is always plan B

Link to comment
Share on other sites

Guys, thanks for the tips and the help, but I ended up running MultiBovine to get audio. I tried installing the hacked AppleHDA kext files as suggested in the other thread as suggested by René_, but without success. I may have been doing something wrong, but after spending many hours on it I decided to try the alternative and it worked on restart right away. I am noticing an annoying pop after the sound has been idle for a while, but for now I'm moving on to bigger problems (like getting some real work done). :)


Taruga, I saved that kext file and will try that first if I have to rebuild my system again. Thanks again for the help guys!

Link to comment
Share on other sites

Actually I since I had just rebuilt the system, I wasn't using any Extra/smbios.plist file! myHack 3.1.2 doesn't appear to install anything (About This Mac reports a "Summer 2001" iMac, lol). I tried installing a premade iMac (12,2) SMBios in Chameleon Wizard + restart and the popping remained, just like you experienced on your system. Then I switched to Mac Pro (5,1) + restart and the popping disappeared! So thanks a lot for that tip. I would never have guessed that.

Link to comment
Share on other sites

Hmm, well I tried both darkwake=no npci=0x3000 and darkwake=0 (Chameleon Wizard's GUI implementation) and I'm getting the same sleep symptoms as before. When I invoke sleep manually via the Apple menu, it takes about 20 seconds for anything to happen (a long time), then my monitors go dark and my hard drive activity light blips a few times. BUT, the computer fans still run and the little lights on my motherboard say "A0", same as ever.


I actually don't care that much about sleep, but if you've got any other ideas I'll try them out.

Link to comment
Share on other sites



I also got the GA-Z77X-UD5H, first of all tnx for all the infos you allready provided here and in your other threads,

that you are using myhack und kextwizard, makes it really more easy for me .. :)

but the only problem I still have is getting my sound working .. I tried the options described here:

- download the kext Taruga told but no success

- also tried MultiB"e"ast and installed the realtek audio driver but still no success

you wrote you used MultiBovine in the end .. but I don't find any programm called MultiBovine

or do you mean MultiB"e"ast .. if so can you please tell me what you have installed ? I just installed the driver ..

do I need any other packages installed?


thanks for you help

Link to comment
Share on other sites

To look further into sleep...must not be using NullCPUPowermanagement and have native power management working. Then when failed sleep, check console logs as well as "pmset -g assertions" in terminal


pupazze-yes, he meant what you think. You need to use HDA enabler if you don't have patched DSDT along with patched appleHDA.kext. With proper DSDT edits, just need patched appleHDA.kext. We cannot offer any support for how to use or troubleshoot 3rd party proprietary tools and support would need to come from their creator.

Link to comment
Share on other sites

I'm still planning on investigating the sleep issue sometime soon, but I wanted to report that after updating to 10.8.2 and getting my audio broken again, I used the AppleHDA.kext file Taruga linked to and installed it using Kext Wizard… and audio works perfectly again. So no need for MultiBovine!

Link to comment
Share on other sites

I got around to removing NullCPUPowerManagement.kext (from ~/Extra/Extensions to ~/Extra/RemovedExtensions), rebooted, and I get the same symptoms as before; I wait about 30 seconds, my displays go black eventually, and my optical mouse goes dark. But the fans keep spinning in the case and the keyboard is unresponsive (no recovering from this stuck sleep state). Curiously, when I click the mouse, the red laser flashes for a split second. Each time I click I can make it flash. I end up having to hit the reset button to restart the computer.


…when failed sleep, check console logs as well as "pmset -g assertions" in terminal


Here's the results of the pmset command you suggested—I don't understand any of it, really.

Last login: Fri Sep 21 20:01:19 on console
Mattintosh:~ mdlarson$ pmset -g assertions
9/21/12 8:03:00 PM CDT
Assertion status system-wide:
PreventUserIdleDisplaySleep 0
PreventSystemSleep			 0
PreventUserIdleSystemSleep	 0
ExternalMedia				 0
UserIsActive				 0
ApplePushServiceTask		 0
BackgroundTask				 1
Listed by owning process:
pid 72(mds): [0x0000000c0000012e] 00:01:53 BackgroundTask named: "com.apple.metadata.mds"
pid 176(helpd): [0x0000000c0000015c] 00:01:35 BackgroundTask named: "com.apple.helpd.sdmbuilding"
Kernel Assertions: 0x0132
* Kernel Assertion ID = 500
Created At = 9/21/12 8:01:16 PM CDT
Modified At = 9/21/12 8:05:58 PM CDT
Owner ID = 0xffffff803b0da000
Level = 255
Assertions Set = None (4)
* Kernel Assertion ID = 501
Created At = 9/21/12 8:01:20 PM CDT
Modified At = 9/21/12 8:06:03 PM CDT
Owner ID = 0xffffff803b05f000
Level = 255
Assertions Set = None (4)
* Kernel Assertion ID = 502
Created At = 9/21/12 8:02:15 PM CDT
Modified At = 9/21/12 8:11:44 PM CDT
Owner ID = 0xffffff8337b06000
Level = 255
Assertions Set = None (4)
* Kernel Assertion ID = 503
Created At = 9/21/12 8:03:25 PM CDT
Modified At = 12/31/69 6:00:00 PM CST
Owner ID = 0xffffff803b231b00
Level = 255
Assertions Set = None (128)
Mattintosh:~ mdlarson$

Link to comment
Share on other sites

I' not using any extensions on /Extra/Extensions, I'm only using FakeSMC.kext, patched AppleHDA.kext on /System/Library/Extensions


My org.chameleon.Boot.plist is like this:



<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<key>Boot Graphics</key>
<key>Graphics Mode</key>
<key>Kernel Flags</key>
<string>darkwake=no npci=0x3000</string>



Sleep, autosleep and Wake all work fine. I don't use any DSDT.aml , but I'm using a SSDT.aml

If you don't have any extra kexts that may be causing sleep/wake problems, that it may a bios settings issue. If you need, I can save my bios (including settings) to a file that you can flash.


Link to comment
Share on other sites


  • Create New...