Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


VMware Workstation 9 - upgrade Lion to Mountain Lion - change guest OS version

4 posts in this topic

Recommended Posts

First off, apologies if I've inadvertently duplicated some information already in another post; I tried searching but couldn't find anything which mentioned this:


If you're going to upgrade Lion to Mountain Lion, make sure you also update the VM guest Settings so that OS X 10.8 is selected under Options -> General.


Until this morning I had a working copy of Lion running inside VMware Workstation 8 on a Windows 7 host. Then I bought Mountain Lion and tried to install it. The installer did something for a few minutes and then tried to reboot the guest. After that point, the guest would no longer boot; it would constantly drop into the EFI shell after a minute or so.


I tried installing VMware 9 (and the 1.1.0 unlocker again), but that wasn't enough. I tried using Lion Disk Maker - http://blog.gete.net...n-diskmaker-us/ - on my real Mac (early-2007 Mini with a C2D upgrade) to create a couple of USB sticks, one with Lion and the other with Mountain Lion. The Lion USB stick would boot inside the VM but then gave a bland "there has been an error installing Lion - please try again" message or words to that effect (I can't remember the exact text), but the Mountain Lion USB stick wouldn't boot inside the VM at all.


Then I had - I think - a brainwave. I powered off the VM guest and went into the VM's settings. On the Options tab, under General, is a control to select the type and version of the guest OS. I changed it from 10.7 to 10.8.


Once I made that change, the VM guest booted successfully into the expected installer. As I write this, it's installing OS X with "About 16 minutes" remaining. Once the installation is finished, I'll see if I've got any further headaches with drivers, kexts and the like before the guest runs stably.

Share this post

Link to post
Share on other sites

On the face of it, OS X 10.8.1 appears to have installed successfully. Sound is working without any further fiddling (I don't know if that's because I upgraded from Lion with working sound, or whether a fresh install would also be fine) and all my previous settings and applications appear - so far - to have been preserved.


So far, so good...

Share this post

Link to post
Share on other sites


One thing I noticed is that LaunchPad is not working anymore: so slow that it is completely unusable.

Can you confirm you have the same issue?


Also, I'm curious about your audio settings.



Share this post

Link to post
Share on other sites

Sorry for the slow response; I only just saw your reply.


I don't normally use LaunchPad, as it's a gimmick to appease those weaned on touchscreens. However, I've just tried using it and can confirm that it runs abysmally slowly on my setup as well.


As for audio settings, what would you like to know?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.