Jump to content

Building a hackintosh, HELP


johnrod.john
 Share

13 posts in this topic

Recommended Posts

Hi everybody thank you so much in advance for your help, this is a first-time hackintosh build and I really want to get it working.

 

Parts List:

i3-2015

h61N-USB3 Gigabyte mb

Mi008 case

8gb ram

500gb hard drive

 

Problem:

I successfully created. Bootable USB drive with mountain lion, then installed, no problems! Then when I went to boot up the system with the boot flags -v, the installation halted at the line Sound Assertion in AppleHDADrivrr at line 1050. Been lookin around on like 10 forums, couldn't find anything. Thanks for the help in advance!

 

P.S. I have tried so many boot flags it is crazy but none of them work, if you need a list of the ones that I tried I ca provide one!

 

THANKS AGAIN!

Link to comment
Share on other sites

remove appleHDA.kext for now if that's really what's holding up the boot process. If you have no other mac to use to do this, boot single user mode to get to a command line by using -s boot flag. Once there follow the directions listed to mount the file system as R/W and then do the following.

cd /System/Library/Extensions

mv AppleHDA.kext /Library/Audio/

Normally would move it to ~/Desktop/ but since you haven't created a user folder yet it doesn't exist until you go through the initial setup. Just remember the kext will be in /Library/Audio for when you need it or move it to the desktop once booted. Boot using -v and -f so the kext doesn't try to load from cache: -v -f

 

if you haven't tried booting in safe mode, try that first and skip the cache: -v -x -f

Link to comment
Share on other sites

HI, thanks for the reply. To remove the appleHDA.kext can I use another mac because I do have access to one. I will try these boot flags and see what happens.

 

Ok, I tried the -v -x and it stopped at the line [AGPM Controller] unknown platform

 

I will try the -s boot flag and move that kext and then once booted access my desktop.

 

I tried the -s to move the kext, but when I boot in single-user mode it gives me :/root# and then the cursor, but when I type something nothing shows up. You refer to there being a command-line, how do I access that??

 

Even though I hadn't moved that file, I tried -v -x -f and it still stopped at the agpm controller thing.

 

THANK YOU so much for you help and I hope that I can get this to work and figure out how to move that kext.

Link to comment
Share on other sites

You were at the command line, right above your cusor it should say something about running fsck, but your keyboard may not be working. If it's not a USB keyboard, get one. And yes, you can move files with another mac, but am not sure that's even your problem. [AGPM Controller] unknown platform is normal unless you have one of a couple cards listed in the AGPM kext for the mac model your using in smbios. If you let it sit at that last message for like 10mins do you get "still waiting on root device"? before waiting 10min, try adding PCIRootID=1 and/or npci=0x3000

Link to comment
Share on other sites

About the keyboard, my keyboard worked fine for boot flags, but I will try another keyboard.

 

I am trying PCIRootUID=1 and then waiting the ten minutes. It still stayed on that line.

 

What do you mean about the couple cards? What type of cards? Graphics Cards? I am using on board graphics. Sound Cards? None.

 

I tried switching the keyboard, I still couldn't type and I don't know if this is related, but above the root# thing it said SingleUserBoot -- fsack not done.

Link to comment
Share on other sites

cards=gpus, that is command line your at but obviously your keyboard needs to work. Add boot flag USBBusFix=Yes and GraphicsEnabler=Yes or also try with No. beyond that, would need detailed hardware specs to offer any other advice

Link to comment
Share on other sites

Ok, I will do that in the morning and get back to you, hopefully that will work, I got past the agpm controller thing when I took out and extra 4gbs of ram to make the total 4gbs and added the boot flags PCIRootUID=1 and GraphicsEnabler=No and -x and -v. Then it halted on Taruga audio, will try removing the kexts, etc.

Link to comment
Share on other sites

Hi, thank you so much for your help so far,

 

Answers to questions, I am never patcher any kext just using default bios and stuff, no patched audio kexts.

 

I just tried booting with the flags USBBusFix=Yes GraphicsEnabler=No PCIRootUID=1 -x -v -s to try the command line stuff, then I will do the same but with graphics enabler =no and see what happens, what detailed hardware specs do you need I should be able to provide them! Thank you so much for you help.

 

Ok, I tried it and bot keyboards didn't work, even though they worked for the boot flags, one of the keyboards is an apple keyboard. Now I will try the graphics enabler = no.

 

And then I have a pobably stupid question, when I want to boot my mac, after I have installed osx on the hard drive I boot from USB, then in the multibease menu select the hard drive, type in applicable boot flags and then hit enter? That is what I am doing, am I supposed to boot from the hard drive or the usb if I want to load a pre-installed copy of OSX. Am I doing this right or am I crazy??

 

Ok, with the graphicsenabler changed nothing changed... Thanks again -- johnrod.john

Link to comment
Share on other sites

Here is a extra folder I made for someone a few weeks ago for that MB. Update your BIOS to version F8 install extra folder at the root of the drive and then install the appropriate kexts. If you install a AppleHDA for ALC 887 from Lion or newer you will have working HDMI Audio because the edit is in the DSDT. Enjoy.

Extra.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...