Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

after upgrading to 10.6.8 computer won't boot

4 posts in this topic

Recommended Posts

I have upgraded 3 times from 10.6.7 to 10.6.8 via Software Update. All 3 times my computer wouldn't boot. I'm not getting a kernel panic, it just stops in the middle of the boot up process. I've tried booting in safe mode (-x) no change. I also turn off one of my cores (cpus=1) I've had to do that ever since I installed Snow Leopard (about 1.5 year ago). I have never been able to run Snow Leopard with both cores running, without having my screen flash and being all messed up. I was able to resolve the core problem in Leopard using "idlehalt=0" between <string></string> in "com. apple.Boot.plist" but it doesn't work in Snow Leopard so for now I've decided to live with it. Now back to my original problem, with Mountain Lion out now I would at least like to be running 10.6.8 as I will not be able to ever run Lion on my existing hardware (core Duo processor). If you think you can help me and need a screen shot of my computer please request it. In advance, thank you.



Acer Aspire 5601 AWLMi

Intel Core Duo processor T2050

(1.6 GHz, 533 MHz FSB, 2MB L2 cache)

15.4" WXGA CrystalBrite LCD (16ms)

Intel Graphics Media Accelerator 950

100GB HDD 5400 rpm (no internal HD using and external USB HD (160GB - 2 partitions - 80GB - 10.6.7 bootable and 10.6.8 non bootable)

DVD-Super Multi double layer (support DVD+R Double Layer/DVD+-RW)

512MB DDR2 (support dual-channel) (I added another 512MB so it's actually 1GB now)

802.11a/b/g wireless LAN (which I'm sure you already know that it doesn't work with Mac OS X. I'm using a USB wifi adapter)

Share this post

Link to post
Share on other sites

from memory, you need the ACPIPlatform.kext and IOPCIFamily.kext from either 10.6.7 or 10.6.6 to solve the non-bootable issue after applying the 10.6.8 update to your snow leopard install.


hope that helps


Troy :)

Share this post

Link to post
Share on other sites

Sorry for taking so long to reply to this post but I had to reinstall 10.6.3 then upgrade to 10.6.7 and finally now 10.6.8. Yes that's right, Troy's solution worked. Replaced APPLEACPIPlatform.kext and IOPCIFamily.kext from my 10.6.7 and now it's working.


Now you might be asking why I had to reinstall. The first time I made the change I could only boot in safe mode, so I removed my audi driver Voodo HDA which I had to do in the past every time I updated and that seem to work except at the end of the installation of my audi driver I got a kernel panic and every time I rebooted after a few second without doing anything just left it at the desktop it would get a kernel panic. So I tried re installing the audio driver in safe mode and I think it was after that I was not able to boot again. My computer was not seeing the drive non of the partitions 10.6.7 or 10.6.8 anyway after I reinstalled 10.6.3 over my non working 10.6.8 I was able to boot in to both partitions so I started again. This time every thing seem to work except what doesn't work in 10.6.7


Troy or anyone else would you have a solution for my other issues. Have to use the flag cpus=1 on every boot or I'll either get a kernel panic or it will boot but I'll get a jittery screen. Even though my sound works I can't change the volume and the last one which I didn't really try on 10.6.7 is sleep. I know that was an kext you had to remove when upgrading because it caused problems so I decided not to bother to install it, so now that I've done all the updates i tried installing it, was successful but a few second later I got a kernel panic. Rebooted, checked sleep doesn't work. Well it's not really that my sleep doesn't work, it's that it won't wake up from sleep, I end up having to reboot.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.