Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Tuen

Asus P5K-E Wifi (Socket 775) Installation Guide for Mountain Lion

11 posts in this topic

Recommended Posts

More information can be found on my blog:

http://blog.vondroid.com/?p=2631

 

Lan, Sound, Sleep tested and work.

Also it works on my NVidia 8800 GTS 320MB only apply EFI-String

Flash browsing in Safari works with that Graphic card without problem.

 

Did you have to do anything besides use the included kext for your ethernet?

 

I can't seem to get the right combination of DSDT/audio/ethernet for everything to work correctly.

Share this post


Link to post
Share on other sites

 

Did you have to do anything besides use the included kext for your ethernet?

 

I can't seem to get the right combination of DSDT/audio/ethernet for everything to work correctly.

 

There is a modified kext file for ethernet.

For audio you need follow the blog: after install OSX you need to install AppleHDA.kext to fix the audio (also need it for future update)

Share this post


Link to post
Share on other sites

There is a modified kext file for ethernet.

For audio you need follow the blog: after install OSX you need to install AppleHDA.kext to fix the audio (also need it for future update)

 

I've tried using your attached Marvell 88E8056.kext and modifying the Info.plist of IONetworking.kext (this was what worked for me previously in SL and Lion), but neither of these work for me now on Mountain Lion.

 

I've got most everything working, except ethernet is the big one that doesn't. The weird thing is, the Marvell 88E8056.kext worked fine for my ethernet using my SL DSDT, but I couldn't get ICH9 patched (for DVD eject) in my DSDT (gave me a bunch of errors that I didn't know how to fix). Using your DSDT, the ICH9 DVD patch works (can eject with holding down F12), but I can't boot the system with the 88E8056 kext.

 

Any ideas?

Share this post


Link to post
Share on other sites

I've tried using your attached Marvell 88E8056.kext and modifying the Info.plist of IONetworking.kext (this was what worked for me previously in SL and Lion), but neither of these work for me now on Mountain Lion.

 

I've got most everything working, except ethernet is the big one that doesn't. The weird thing is, the Marvell 88E8056.kext worked fine for my ethernet using my SL DSDT, but I couldn't get ICH9 patched (for DVD eject) in my DSDT (gave me a bunch of errors that I didn't know how to fix). Using your DSDT, the ICH9 DVD patch works (can eject with holding down F12), but I can't boot the system with the 88E8056 kext.

 

Any ideas?

 

You have the same board?

you have follow the whole tutorial on the blog?

Use the same files from my blog?

using the same bootloader as described?

Share this post


Link to post
Share on other sites

You have the same board?

you have follow the whole tutorial on the blog?

Use the same files from my blog?

using the same bootloader as described?

 

Yes, I have the exact same P5K-E / Wifi-AP board. Yes, I followed the whole tutorial with the same files. I modified it only slightly (such as not copying .disk_Label, .Disk_Label_2x, Boot.efi, Kernelcache) in comparison with the Vanilla install thread that's usually on the first page of this sub-forum. Using Chameleon-2.1svn-r2030. So a few things are different (I don't think they would be the culprit, but I didn't want to start fresh all over).

 

In any event, I've got everything working except for SpeedStep finally. There must've been something wrong with the DSDT I was using. Both my unpatched DSDT (extracted from Windows) and your DSDT, Tuen, gave me one error and lots of warnings when compiling. My Lion DSDT, however, compiled fine straight from Lion and after patching it.

 

I can't attach my DSDT (Note: My DSDT is built for the P5K-E / Wifi-AP with 4 GB of RAM!) and audio kexts (probably due to number of posts?), but in case anyone needs them, PM me with an e-mail address to send them to.

 

Tuen (or anyone else), is there a way for me to check if SpeedStep is working in Terminal or through some program? I didn't notice anything new booting in -v with Tuen's IntelCPU kext.

Share this post


Link to post
Share on other sites

Did any of you get the WIFI working, I had it working in a previous version of Lion.. Can't find the Reltek software or kext anymore

Share this post


Link to post
Share on other sites

Got 10.8 working with your blog

 

Still can't get the video to work fully with QE/QC

 

do you think I need to do the efi string?

Share this post


Link to post
Share on other sites

No matter what I do, I can't get the sleep working? I'm afraid to use a DSDT because I can't seem to find one easily enough... it seems like the few I see mentioned when I google P5K-E DSDT have really customized versions and I'm pretty new to this, so I don't wanna start throwing in wrong DSDTs if I don't have to.

 

I have a Sapphire Radeon HD7770 GHz edition, and putting the computer to sleep seems to be the only way to get this card to work.

 

I boot to a white screen with a movable cursor. When I press the power button, nothing happens. If I come back after a few minutes, the monitor is off, but the computer and fans are still on... Moving the mouse or hitting the keybaord just brings me back to the white screen.

Share this post


Link to post
Share on other sites

got it working by extracting my own dsdt and patching it with olarilas p5k wifi ap.txt

 

only problem now is i cna't get audio to work! tuen's appleHDA doesnt work for me, neither does voodooHDA

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • What did you add exactly, i did inject the unsupported 100 series kext and did see my macOS partition. I couldn't boot at all. I still get an error from VoodooPS2Mouse i think here is an image: https://drive.google.com/open?id=1dkcoWh2ZXj56ketONkrV8x9TNOVJdXkf
    • @Slice what's te correct russian translation for "copy to clip board"?   .. I need also a translation for "log copied to clip board!"
    • Hello MaLd0n,   Could you please make DSDT edits for my new Skylake desktop Lenovo M910t    RunMe files: https://www96.zippyshare.com/v/5bgqAiga/file.html
        Thank you very much in advance!
    • Have you tried adjusting the Khz in midi pref pane or editing the info plist to suit your needs. that sometimes corrects weird noise behavior.
    • Hello Mald0n:

      Nice to meet you, I have created a post about my problem on High Sierra before and I was redirected to this guide by Allan.

      As mentioned in the post, I was not able to get pass the login screen at initial boot and the system could not shutdown occasionally.

      However I solve the high temperature problem when I replace the clover folder you provide on first post, currently the cpu temperature is around 5x-6x'c after 10 mins up time.

      Attached is the clover folder, ioreg as well as the send me app, thanks for your help!

      p.s. I notice that your clover boot efi is a old traditional grey apple boot logo, Is there a version of modern dark and white logo one that I could replace with? Thank you!

      https://www.insanelymac.com/forum/topic/333867-cant-get-pass-2nd-stage-boot-logo-on-initial-boot-and-high-temperature/   My system:
      Gigabyte GA-X48-DQ6
      Core 2 Extreme QX9650 C0
      4 x Kingston DDR2 800ghz Ram
      Galaxy GTX460 1GB
      120GB SSD Leven JS500120C, high Sierra installed
      250GB seagate ST3250310AS
      250GB WDC WD2500JS-08NCB1
      File: https://drive.google.com/file/d/1_k3_jxvzGaLfDzin0zSAUT5ml16Hq15c/view?usp=sharing      


×