Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Wolf-Mac

ML 10.8 funcionando en vieja Gigabyte con Kakewalk 4.5

3 posts in this topic

Recommended Posts

Hola a todos!!!

 

Al final lo he conseguido :)

 

OS X ML 10.8 GM funcionando en mi viejita Gigabyte GA-P35-DS4 con el demás hardware de mi firma :)

 

Me falta hacer funcionar el audio, lo de los iconos naranja de las particiones, la red ya lo solucioné y por ahora no he visto nada más, apenas si llevo unos minutos en ML 10.8 :)

 

Ahh, aceleración gráfica OK

 

Como ya comenté en el foro de Herramientas OSX he hecho el USB Boot con el nuevo Kakewalk 4.5.0 el cual ya trae soporte para ML http://www.kakewalk.se

 

He usado el .dmg de la Golden Master

 

Lo poco que llevo en ML lo veo muy suave y rápido, el arranque superrápido lo mismo que el apagado

 

El kakewalk te pone el DSDT.aml, smbios.plist, org.chameleon.Boot.plist y demás kext como el fakeSMC el NullCPUPowerManagement etc...

 

Ahí ya vamos personalizando según nuestro equipo

 

En mi caso como mi Gigabyte (P35-DS4) ya es vieja y no viene en la lista del Kakewalk he elegido la segunda opción por parecerme más parecida y todo ok (EP45-DS3L)

 

Como ya no tenía discos he tenido que instalarlo donde tenía mi Snow Leopard 10.6.8, me ha dado pena quitarlo pero bueno, hay que evolucionar.

 

Y bueno, eso es más o menos así por encima lo que llevo a esta hora, voy a ver si puedo ir poniendo las cosas que me faltan :)

 

Este mensaje es para haceros saber que el nuevo Kakewalk 4.5.0 funciona perfecto con las Gigabyte y Mountain Lion, así que ya sabéis si poseeis una Gigabyte ;)

 

aclXLEMN.jpg

 

 

Saludos

Share this post


Link to post
Share on other sites

que bueno.

 

 

me subes es

smbios.plist, org.chameleon.Boot.plist que te puso kakewalk.

 

 

 

Ok, veamos

 

Este el org.chameleon.Boot.plist, solo he modificado el timeout de 3 a 5 segundos

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Boot Banner</key>
<string>No</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>npci=0x3000</string>
<key>Theme</key>
<string>Default</string>
<key>Timeout</key>
<string>5</string>
</dict>
</plist>

 

 

Este el smbios.plist

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMbiosvendor</key>
<string>Apple Inc.</string>
<key>SMbiosversion</key>
<string>MP31.88Z.006C.B05.0802291410</string>
<key>SMboardproduct</key>
<string>Mac-F42C88C8</string>
<key>SMfamily</key>
<string>Mac Pro</string>
<key>SMmemspeed</key>
<string>800</string>
<key>SMproductname</key>
<string>MacPro3,1</string>
<key>SMserial</key>
<string>QT8212N5XYK</string>
</dict>
</plist>

 

 

Solo he añadido la parte de la velocidad de la memoria que me la tomaba como 600 mhz y es de 800

 

<key>SMmemspeed</key>
<string>800</string>

 

 

Algunas notas:

 

He tenido que desechar el DSDT.aml que pone Kakewalk y usar mi DSDT.aml que vengo arrastrando dese mi primera instalación Retail de Snow Leopard 10.6 para que me funcionara el audio con mi AppleHDA de siempre

 

Lo mismo con los demás kext para AHCI, IOAHCIBlockstorajeinjector etc etc.... he usado los mismos que vengo arrastrando desde mi primer Sow Leopard y que luego he usdao en Lion 10.7

 

De los kexts que pone el kakewalk solo he dejado estos: Extensions.mkext, NullCPUPowerManagement.kext y FakeSMC.kext y he eliminado dos que no me sirven, ALC8xxHDA.kext y AppleRTC_Patched_Lion.kext (este no se para que es)

 

No se como lo hace pero usando mi DSDT.aml que dije antes que traigo desde Snow Leopard más mis kext de siempre que los traigo también desde Snow me funciona todo a la perfección y sin hacer cosas raras como veo en muchos hilos, solamente colocar mis kexts en Extra instalar mi audio y ya :)

 

Ahora voy a instalar iLife'11 y a probar si actualiza

 

Un saludo

 

Edito: Instalada la suitte iLife 11 y actualizada desde la App Store sin problemas: http://www.insanelymac.com/forum/index.php?showtopic=280980&view=findpost&p=1837185

 

Extra: El IntelCPUMonitor.kext da Kernel Panic, a mi me ha pasado y he tenido que borrarlo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×