Jump to content
InsanelyMac Forum
Sign in to follow this  

ATI 5650M right resolution but no QE/CI

Recommended Posts

Hello folks, its been a very busy week working hard to get some Snow Leopard flavors working on my Sony Vaio VPCEB3M1E. Initially I was trying to install Lion straight up using myhack, however I didnt have much luck with it due to a kernel panic right after the installation.


However according to this wiki post I found out my laptop is 90% Snow Leopard compatible so I decided to just focus on it.


ACPI, keyboard, mouse and GPU with vesa driver works out of the box, however I had to fix some things after the update to 10.6.6, but so far most of the hw works.


The thing that has been driving me nuts for the past two days is to make the GPU to actually work in full resolution and with hardware acceleration enabled.


After having spent hours reading and reading, sorting out the monitor EDID and getting the right driver (I guess) I managed to get full resolution, and I must say it looks good.


However though, I am still stuck with no hw acceleration. Menu bar is solid, frontrow wont turn on, and no flash player. Yes, you heard that.. No youporn FML!! ;)


I have tried some drivers around the net, but those are the ones I am using now http://www.osx86.net/downloads.php?do=file&id=1502&page=3 , same result with all those I tried so far, full resolution and no QE/CI. Actually the ones I used before had some less flickering when moving windows around, I might go back to those for now.


I tried booting with the flags Hoolock and Eulemur, but same result really.


Here's my monitor info retrieved with moninfo as suggested.


 Windows description...... Generic PnP Monitor 
 Manufacturer............. Sony
 Plug and Play ID......... SNY05FA
 Serial number............ n/a
 Manufacture date......... 2009, ISO week 4
 Filter driver............ Monitor
 EDID revision............ 1.3
 Input signal type........ Digital
 Color bit depth.......... Undefined
 Display type............. Non-RGB multicolor
 Screen size.............. 340 x 190 mm (15,3 in)
 Power management......... Standby, Suspend, Active off/sleep
 Extension blocs.......... None
 DDC/CI................... n/a

Color characteristics
 Default color space...... Non-sRGB
 Display gamma............ 2,20
 Red chromaticity......... Rx 0,640 - Ry 0,340
 Green chromaticity....... Gx 0,300 - Gy 0,600
 Blue chromaticity........ Bx 0,149 - By 0,060
 White point (default).... Wx 0,313 - Wy 0,328
 Additional descriptors... None

Timing characteristics
 Range limits............. Not available
 GTF standard............. Not supported
 Additional descriptors... None
 Preferred timing......... Yes
 Native/preferred timing.. 1366x768p at 60Hz 
   Modeline............... "1366x768" 72,000 1366 1395 1453 1540 768 770 774 780 -hsync -vsync
 Detailed timing #1....... 1366x768p at 50Hz 
   Modeline............... "1366x768" 54,860 1366 1374 1390 1414 768 769 771 776 -hsync -vsync

Standard timings supported

Report information
 Date generated........... 01/07/2012
 Software revision........
 Data source.............. Registry-Active
 Operating system......... 6.1.7600.2

Raw data


And here's my EDID converted to base64 and the rest of /System/Library/Displays/Overrides/DisplayVendorID-756e6b6e/DisplayProductID-717


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<string>Internal LCD Forced EDID</string>


Anyone knows where I can get the right driver? Otherwise what am I doing wrong??



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • I guess having pre{max-height: 500px;overflow: auto;} in CSS was too much for IPS Devs' tast.  Until an admin has hands on this, you still can use stylish plugin to accomplish it.     In fact, it is pretty easy than it appears - Just apply a simple click on the codebox (it will highlight it), then 'delete' key.
    • all the possible frequencyes i have added seems to work fine at the moment, i have added a lot of different frequencyes to support better all kinds of professional applications, inclunding strange sampling rates and goes from 8khz up to 176.4 khz, unfortunately 192 khz does not seems to work even on cards which should support it like the audigy rx, but other frequencyes just works fine and at the moment i have tested only the sound blaster audigy rx and the audigy sb0090 (1st gen audigy) and i can confirm that all the frequencyes from 8khz up to 176.4 khz does work on that card, so i think that such frequencyes should work on all the audigy 2, 2sz, 4 cards as well, tomorrow i will test with my sound blaster live! cards and i will let you know, but here are also some photos (pro tip: use cmd + alt/opton + 4 and then press space to make a screenshot of a single window):
    • Guy's if something happened, this is most likely Admins and Moderators are working there, yes we still need some things to be done, but if it's still not yet, it's because of time or something we don't know, we just have to be patient! Slow things is just because they are working in the same time, patience for that problem is good, and loading things, but apparently now is good, for me these things I've accounted them yesterday and this morning, but now they are gone. For the missing things like the Old insanelymac and theme, please we need them, and excuse my ignorance!
    • Good evening to all. So, I have an external 1TB seagate HD and it always reads normally, but now when I plug it into my HACK it just does not read, it does not even appear on the disk utility. The light always turns blue from the HD without blinking. However I plugged it into windows, on a macbook and it worked normally. I already formatted my hack but it did not work. Thank you in advance for the help and sorry my bad english   my kexts: AppleALC.kext FakeSMC.kext IntelGraphicsFixup.kext IntelMausiEthernet.kext Lilu.kext WhateverGreen.kext VoodooHDA.kext USBInjectAll.kext NvidiaGraphicsFixup.kext   GTX 1080 Windforce core i5 7º generation 8gb Ram H170M Plus BR    
    • WOL packet is reaching the machine from LAN and from WAN (set with port forwarding), tested with "nc -l -u 9".