Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Wardy125

Need to find the right graphics kext

11 posts in this topic

Recommended Posts

Hi,

 

I have a custom-built laptop that i ordered online, with a dual core intel b950 cpu with on-board graphics. The only thing that confuses me about this thing is that it doesn't actually tell me anything specific about the graphics side of things.

 

Under windows i used dxdiag and device manager, both reported just "Intel HD Graphics Family" no model number or anything. I tried to use system info from the os x install disk, which told me i had an i7 processor and was using a Mac Pro, so i didn't really trust what it had to say.

 

The reason i'm trying to find this out is so i can get the right graphics kext for me to boot, because so far, the install works fine...it just hangs on "DSMOS has arrived." (Which i've read is a graphics issue) I also assumed this because the welcome music played first time, but the screen was frozen on the apple logo and the wheel stopped spinning. Earlier, it even started talking to me about voiceover, but still at the logo.

 

I'm using iAtkos L2 Lion (which i'm currently running on my desktop machine perfectly), i just need to find out which kexts i need for the graphics.

 

Any help is greatly appreciated :)

Share this post


Link to post
Share on other sites

You need a better program to tell you what graphics are installed on your system. Try either GPUZ or PC Wizard. Both of them are made by the same company. You find their site here. Also you can try GPUZ. Their site is here. This should at least point you in the right direction as to which graphics (card or onboard) your system has.

 

 

post-1022570-0-01171400-1339970778_thumb.png post-1022570-0-04306600-1339970944_thumb.gif

 

Correction...both of them are not made by the same company. Anyway these of course are Windows based programs.

Share this post


Link to post
Share on other sites

Ahh thankyou, i totally forgot GPUZ even existed, even though i've used it a few times before! ><

 

However, i'm still stuck :P

 

I looked for anything relating to hackintosh or os x with a GT1 (or apparently HD 1000) and nothing seems to exist.

However, i looked at the components list for lion on osx86project and saw that HD 3000 works out of the box.

 

Am i missing something still? :S

 

40y.png

Share this post


Link to post
Share on other sites

I just remembered....there is someone called netkas...he is supposed to be the "Guru" on graphics drivers. I believe it is netkas.org. I hope this helps!!

Share this post


Link to post
Share on other sites

the chances are fairly high that the graphics are Intel HD Graphics 3000. if you don't install any kext it should use the X3100 graphics kext and work natively, but apparently not very well... that said, i really never had any problem... i was able to watch videos and stuff, and if you want to play games, well stick with a PC ;)

 

the driver in your report is igdumd64.dll, which is indeed used for Intel 3000 graphics, though maybe for others too, i don't know...

Share this post


Link to post
Share on other sites

I re-installed using chimera bootloader instead of chameleon this time, and i get a different message.

 

Something to do with bluetooth?

 

I tried booting with combinations of -x -f arch=i386 & cpus=1

photo.jpg

Share this post


Link to post
Share on other sites

i had same problems with my acer one laptop.. 2 files that allow the OSX to see the internal hard drive IOATAfamily.kext and AppleIntelPIIXATA.kext. Many people just blindly copying files and get confused about why they don’t see the internal hard drive, there’s nothing mysterious about it, the controller for MY particular Netbook and Dell mini 10 has the id 811A8086, so this id must be included in the info.plist of the kexts, that’s all. In fact, we don’t need to install any of this until the final booting. add the AppleIntelPIIATA.kext inside the IOATAfamily.kextand this is the only file needed to see the internal hard drive. this fixed "STILL WAITING ON ROOT DEVICE" LET ME KNOW IF IT WORKS ON YOURS

AppleIntelPIIXATA.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • MAld0n, I can't post a new topic on post installation forum. is it on maintenance?
      Notebook Asus X550VX i7 - 7700hq
      GTX950MX - UHD630
      A1718086 - 025510ec ALC255 that works only on VoodooHDA 
      RTL8111 LAN Hwinfo
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL   Not work:
      1. White Screen Wake up
      EDID not a asolution
      IOREG output http://www.mediafire.com/file/u7odzbaxa7bbb6a/ioregSaved.txt and EDID
      http://www.mediafire.com/file/hqlapgf4luwchdf/DisplayProductID-69c.plist Image
      https://ibb.co/faL5wx 2. Battery info status bar sometimes goes on / off like battery has off
      3. Crackle Sound using   earphone using VoodooHDA
             Still investigation using patched iomatch voodooha info.plist
             The sound card can’t be using AppleALC, no sound came out using layout 3, 13, 17, 18, 27, 28, 99
      I have your (Mald0n) DSDT   http://www.mediafire.com/file/lmp5yy65rblx9ne/DSDTtitomaldon2.dsl   I have re-patched again for FnKeys and Brighness Key http://www.mediafire.com/file/5rs93ij0wco99s6/DSDTtitomaldon2editv2.aml

       
      codec dump linux
      https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view
       
       
      latest debug
      http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip
       
      clover and kext
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL
       
    • somehow I can't post a topic using safari and Firefox on Mac. no box for inserting text, is this kind of maintenance?  
    • Hello Allan!   I do have ACPIBatteryManager.kext and if i use IntelBacklight then I get stuck on boot with an error along of the lines of "busy timeout, (60s), : 'PEG0'". I have tried to patch the DSDT but failed. If i understand right, ACPIBatteryManager.kext needs DSDT edits to work? same goes for IntelBacklight?   EDIT: I tried to edit my stock DSDT using MacIASL again and i applied the battery patch for Asus Q550LF from @RehabMan Repo! I also applied the AsusFNkey DSDT patch. Now the battery meter pops up when i unplug the laptop. If i plug the charger back in, then the battery meter stays but does not update to show that the charger has been plugged in. Ive attached the DSDT below.. DSDT.aml.zip
    • Unfortunately it still doesn't sleep. Monitor does but not computer
    • go to your applications folder and select midi prefpane try lowering or raising the Khz there.


×