Jump to content

help with DSDT for Sony Vaio f23jfx


1 post in this topic

Recommended Posts

DEAD - sold the laptop








took that using system_info app on windows


check my signature for specs


I had a nice system until update to 10.7.4 from 10.7.3


But I was missing sleep,

brightness control,

fn keyboard (worked for voodooHDA audio F2 - F4, but not for brightness F5 and F6),

headphone audio,

and native power management.


I followed the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] guide for laptops on tonymacx86 for post installation.

graphics worked with the injector in ###### for nvidia geforce gt 540m (picture above is misleading)

wireless worked ar9287 (no bluetooth, i think it is a 2-in-1 card) with a kext found at osx86.net



and the error I was stuck on after updating to 10.7.4 is something about "bluetoothhcicontroller"





Now I want a clean as can be install.


I looked through some guides but can't make heads or tails of the DSDT layout.


Whoever takes my dsdt (attached) and patches it for me with the features mentioned above and other required optimizations for use in OS X, then would you please take the time to explain what patches weren't needed because of the latest chimera version, 1.10


and if the patching person would so kindly point out what chimera boot options would be needed to avoid those patches.



please, any other info needed, do not hesitate to ask.



UPDATE: Got info on my bluetooth module. via Windows


Foxconn - T77H114

Chipset: BroadcomBCM2070

just followed the guide linked below to add my bluetooth ID's to my kext.



up'ped the bluetooth kext below for 10.7.4 (may be compatible in every version of lion if nothing changes)


UPDATE 2: new problem, I'm trying to move on without dsdt while I wait for response.

I am stuck at the no mouse or trackpad connected screen


and I can't add any USB mice or bluetooth, even though I added the device ID of my module into the bluetooth. and I tried PCIRootUID=0 and with value =1


any ideas? (this is probably a known issue and discussed before please lead me to right direction before flaming)


thanks everybody!

dsdt_ninditsu - prePatch.zip

Broadcom BCM2070 Bluetooth.zip

Link to comment
Share on other sites


  • Create New...