Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
badaxe2

DWL-G520 Mountain Lion DP4

6 posts in this topic

Recommended Posts

DWL-G520 in Mountain Lion DP4

 

This wifi card worked fine in DP2 but now after updating to DP4 it doesn't work, even when using atherosfix.kext

 

Any help would be much appreciated :)

Share this post


Link to post
Share on other sites

Yes the above is correct.

 

Install AtheroFix.kext.

Install DP1 or DP2 or DP3 IO80211Networking.Kext.

 

Reboot, and Wifi will work. They've redone something in the IO kext, and it needs to use an older version.

Share this post


Link to post
Share on other sites

Can somebody throw me the DP3

IO80211Networking.Kext , I did manage to get it working though with my 10.7.4

IO80211Networking.Kext and atheros fix..

thanks for the quick response guys...

Share this post


Link to post
Share on other sites

Thanks a lot.

Works perfect with Devout's solution.

1. Download the files above (DP3 works for me);

2. With kext Wizard, for exemple, install AtheroFix.kext and IO80211Networking.Kext;

3. Reboot and Enjoy.

 

Specs:

MOBO: Gigabyte GA-G41MT-ES2L Rev 1.0 F5

Wifi: D-LINK Air Plus Extreme - DWL-G520

OSX: Niresh12495 Mountain Lion

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×